[Résolu] Dates et formatage automatique

Discussions à propos du tableur Calc.
Les questions sur les macros doivent être postées dans la section dédiée en dessous.

Modérateur: Vilains modOOs

Règles du forum
Cette section est uniquement dédiée au tableur Calc. Vous ne devez pas poster ici de questions sur les macros mais utiliser la section éponyme.

[Résolu] Dates et formatage automatique

Messagepar aimti » 29 Déc 2005 12:34

Bonjour,
Lorsque je saisis une date dans calc, souvent le formatage est correct mais parfois la date saisie est formatée automatiquement comme un texte (alignement à droite, non reconnaissance comme nombre par les fonctions travaillant sur les nombres ...). Lorsque je vais sur la cellule il y a un ' avant le nombre qui a été placé là automatiquement par calc (et qu'on ne peut enlever, il se remet automatiquement à la validation.
noter que la même date est parfois concernée parfois non (selon les moments dans un même fichier, selon les fichiers au même moment ...).

Merci pour votre aide
Open office 2.0.1 sous windows XP
aimti
NOOuvel adepte
NOOuvel adepte
 
Message(s) : 18
Inscrit le : 28 Déc 2005 15:06

Messagepar bm92 » 29 Déc 2005 13:46

OpenOffice.org reconnaît une date tapée dans différents formats. Mais dans certains cas, il est obligé de faire des suppositions sur la signification de chaque nombre (jour, mois, an). De plus il reconnaît les dates écrites avec un séparateur / ou - ou .
Quant à l'affichage de la date, il dépend seulement du formatage de la cellule; si la cellule est standard, la date affiche selon un format par défaut.

S'il n'y a que deux nombres, il suppose qu'il manque, soit le jour, soit l'année. Il complètera avec le jour 1 ou l'année en cours.
Premier cas, année implicite (testé en 2005):
15/3 => 15 mars 2005
11-10 => 11 octobre 2005
11.10 => 11 octobre 2005
Si le deuxième nombre est supérieur à 12, il suppose qu'il s'agit de : mois/an :
8/13 => 1er aout 2013
3.15 => 1er mars 2015
5/55 => 1er mai 1955

Maintenant, essayons : 23/15
Affichage: 23/15 cadré à gauche.
Ce que nous avons tapé ne peut pas être an/mois, ni mois/an, ni jour/mois, ni mois/jour. Donc ce n'est pas une date, et c'est donc un texte.

Plus compliqué : 31/11
Affichage: 31/11 cadré à gauche.
Pourquoi n'a-t-il pas interprété en 31 nov 2005 ? En effet, 30/11 est bien interprété comme 30 nov 2005 ! OOo n'accepte pas une année à 2 chiffres supérieure à 30, s'il n'a pas explicitement jour mois et an.

Conseil
N'hésitez pas à mettre une année à 4 chiffres.
bm92
ManitOOu
ManitOOu
 
Message(s) : 2562
Inscrit le : 26 Nov 2005 14:42

Messagepar aimti » 30 Déc 2005 13:11

J'en sais dorénavant plus sur le formatage des dates malheureusement cela ne règle pas mon problème. les formats de saisie qui posent problème sont du type 15/12/05 ou 15/12/2005. j'ai fait de nombreux essais avec des dates différentes, de nouveaux fichiers ... j'arrive à saisir un certain nombre de dates (moins de 10 le plus souvent) sans problèmes mais inévitablement au bout d'un moment le problème apparait.
de fait je me demande s'il s'agit d'un bogue du logiciel.
Open office 2.0.1 sous windows XP
aimti
NOOuvel adepte
NOOuvel adepte
 
Message(s) : 18
Inscrit le : 28 Déc 2005 15:06

Messagepar Papayes » 30 Déc 2005 13:38

Bonjour,
un petit coup d'antivirus et tu envoies un de tes fichiers récalcitrants à :

http://oooforum.free.fr/cijoint/

puis tu nous indiques l'adresse url proposée par cijoint dans un nouveau post.

on regardera ces vilaines dates ...

Question: es-tu sur 2.0.0 ou 2.0.1. ?

A+
papayes
"Tout ce qui n'est pas donné est perdu"
Avatar de l’utilisateur
Papayes
Membre fOOndateur
Membre fOOndateur
 
Message(s) : 4154
Inscrit le : 07 Déc 2005 14:55
Localisation : Vic-Fezensac dans le Gers

Messagepar aimti » 01 Jan 2006 17:57

Bonjour,

Voilà l'adresse du fichier demandé.
http://oooforum.free.fr/cijoint/fichier/060101054636.ods
noter que certaines dates incorrectes il y a 3 jours (A5 par exemple que je ne parvenais pas à passer en format date) ne posent plus de problème aujourd'hui. Par contre il a suffit d'en saisir 2 ou 3 autres (celles de 2007 par exemple) pour voir le problème resurgir.
En ce qui conerne la version précise de OO, dans le menu aide a propos, la version indiquée est 2.0. où dois je regarder pour avoir davantage de précisions ?
Open office 2.0.1 sous windows XP
aimti
NOOuvel adepte
NOOuvel adepte
 
Message(s) : 18
Inscrit le : 28 Déc 2005 15:06

Messagepar Papayes » 01 Jan 2006 19:11

Bonne Année, :D
pour la question 2:
bm92 a écrit:Menu Aide > À propos d'OpenOffice.org
Appuyer sur la touche Control en tapant successivement S D T
Dans la liste qui défile on lit : 680m1(Build:8990)
C'est la signature du 2.0.1
Pour info, SDT signifie : StarOffice Development Team

pour les dates, à demain :oops: quand la GDB ira mieux...
Pour info, GDB signifie Gueule De Bois :wink:

A+
papayes
"Tout ce qui n'est pas donné est perdu"
Avatar de l’utilisateur
Papayes
Membre fOOndateur
Membre fOOndateur
 
Message(s) : 4154
Inscrit le : 07 Déc 2005 14:55
Localisation : Vic-Fezensac dans le Gers

Messagepar aimti » 02 Jan 2006 10:11

Bonjour,

En suivant ta procédure j'ai 680m1(build:8958)
Open office 2.0.1 sous windows XP
aimti
NOOuvel adepte
NOOuvel adepte
 
Message(s) : 18
Inscrit le : 28 Déc 2005 15:06

Messagepar Papayes » 02 Jan 2006 11:37

Bonjour,
c'est la signature de la version 2.0.0
j'ai vu votre fichier, c'est normal pour les entrées : / , 23/15 (15 mois)
pas normal pour 18/1/05 et 27/1/07 qui sont en plus au format nombre standard.
Avez-vous essayé, avant d'entrer vos dates, de formater votre colonne entièrement en Format date ?
(sélectionner la colonne > Menu Format > Cellules... onglet nombre : Catégorie : dates...)
De toute façon, vous avez manifestement un fichier corrompu ...

Passez donc à la version 2.0.1. qui corrige de nombreux bugs et possède des options supplémentaires,
ce n'est pas la peine de perdre du temps avec la 2.0.0 !
mais passez par la procédure complète !

Pour installer OOo2.0.1 sur une 2.0.0 , il est préférable de:

A. Comme vous avez un problème, il faut changer le nom du dossier OpenOffice.org2
( .OpenOffice.org2 sous Linux) que le programme place dans C: Documents and Settings/Nom_d'utilisateur/Application Data/
OpenOffice.org2.
Nommez le par exemple en "AncienOpenOffice.org2" ,
cela évite de le supprimer et vous permettra par exemple de récupérer vos modèles...entre-autre.
Application Data est un dossier caché, pour le faire apparaître ,
A partir de n'importe quel dossier ouvert: Menu > Outils > Options des dossiers ... >
Onglet Affichage : Dans le cadre Paramètres avancés :
Fichiers et dossiers cachés : Cliquez sur le bouton Afficher les fichiers et dossiers cachés. Bouton Appliquer pour valider


B. Poursuivre l'installation normale...

1. Désinstaller la version OOo2.0. par l'intermédiaire de
Démarrer > ...Panneau de configuration > ...Ajout/Suppression de programme.

2. Défragmenter votre Disque Dur ...
3. Redémarrer.

4. Fermer tous les programmes même Spybot-CD , rester hors connexion internet et lancer l'installation.

5. Durant l'installation, cocher la case "Tous les utilisateurs" (garder l'option par défaut) .

6. A la fin de l'installation, redémarrer : ça ne sert à rien mais on n'est jamais trop prudent avec XP.

Voilà, il suffit d'ouvrir avec Démarrer > Tous les programmes > OpenOffice.org2.0 > Clic sur OpenOffice.org Writer

n'oubliez pas d'installer les dictionnaires et les fonts avec l'aide des Assistants : Menu > Fichiers > Assistants...
"Installer de nouveaux dictionnaires"
puis "Installer des polices à partir du web.";
Fermer Ooo et le démarrage rapide (s'il s'est affiché), d'ouvrir de nouveau OOo.

et de passer par le menu Outils > Options > Paramètres linguistiques >
..de mettre les 4 cadres avec "Français(France) et cocher la case "Identique à l'environnement..."

A+
papayes
"Tout ce qui n'est pas donné est perdu"
Avatar de l’utilisateur
Papayes
Membre fOOndateur
Membre fOOndateur
 
Message(s) : 4154
Inscrit le : 07 Déc 2005 14:55
Localisation : Vic-Fezensac dans le Gers

Messagepar aimti » 07 Jan 2006 10:29

Bonjour,

Après installation de la version 2.0.1 le problème persiste. J'ai alors installé la même version sur un autre poste. cette fois pas de problème. il s'agissait donc d'un problème probablement directement lié à ma machine, soit au niveau logiciel soit au niveau matériel. afin de savoir s'il s'agissait d'un problème matériel ou d'une interaction avec d'autres logiciels que windows, j'ai donc créé une 2ème partition sur le pc posant problème, installé un windows minimum dessus et renouvellé mes essais. et patatra même problème. donc il s'agit ou d'un problème avec mon matériel ou d'un problème avec la version de windows XP installée.

voilà, problème non résolu mais merci à tous
Open office 2.0.1 sous windows XP
aimti
NOOuvel adepte
NOOuvel adepte
 
Message(s) : 18
Inscrit le : 28 Déc 2005 15:06


Retour vers Tableur

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Google [Bot] et 15 invité(s)