Recherche d'occurences dans une plage de cellules

Discussions à propos du tableur Calc.
Les questions sur les macros doivent être postées dans la section dédiée en dessous.

Modérateur: Vilains modOOs

Règles du forum
Cette section est uniquement dédiée au tableur Calc. Vous ne devez pas poster ici de questions sur les macros mais utiliser la section éponyme.

Recherche d'occurences dans une plage de cellules

Messagepar oukourj » 29 Déc 2005 11:40

Bonjour.

J'aimerais simplement faire une action lorsque AU MOINS UNE des valeurs d'une de mes colones vaut plus de 0.

Et je vois pas comment faire.

La relation logique est bien entendu un OU.
Mais le OU de openoffice ne permets pas (ou je n'ai pas su le faire), de donner une plage de cellules que l'on teste ensuite (tel que:
=SI(OU((N1:N200)>0);bien;pabien)
).
Selon ce que j'ai compri, je serais obligé, pour faire le test ci-dessus, de faire une énorme liste du genre ( OU(N1>0;N2>0;N3>0;...) ), et quand on sais que chez moi ca ressemblerais plutôt à ( SI(OU($CORRESPONDANCES.$n$1>0; etc... )
on comprends aisément mon besoin d'une autre solution.

J'ai bien trouvé la forumle "BDNB", mais j'ai eu de la peine à l'utiliser.
Je l'ai déclarée comme suit:

BDNB(N1:N200;0;J7)

où N1:N200 est ma plage de données et J7 une cellule contenant >0.


Qqun en sais plus ?

Merci d'avance pour votre aide.



ouk.
OOo 3.3.0 \ Windows XP Pro SP3 Fr
oukourj
Membre lOOyal
Membre lOOyal
 
Message(s) : 36
Inscrit le : 22 Nov 2005 09:44
Localisation : Genève

Messagepar Papayes » 29 Déc 2005 14:31

Bonjour,
ta formule SI contient des mots qu'il faut mettre entre quottes :
=SI(F6<1;"bien";"pasbien")
ta formule OU(A1:B2) ne respecte pas la syntaxe
OU( A1>1;B2>1;...) est correcte et renvoie VRAI ou FAUX
je te propose d'utiliser la formule SOMMEPROD() comme compteur, en version OOo2.0.x seulement ( sinon formule matricielle)
Image

pour en savoir plus sur les tableurs, le site de Christian,
http://christianwtd.free.fr/

aussi les fiches de Vincent

http://www.framasoft.net/article3640.html

sur la fonction SOMMEPROD ici:
http://www.framasoft.net/article4198.html
A+
papayes
"Tout ce qui n'est pas donné est perdu"
Avatar de l’utilisateur
Papayes
Membre fOOndateur
Membre fOOndateur
 
Message(s) : 4154
Inscrit le : 07 Déc 2005 14:55
Localisation : Vic-Fezensac dans le Gers

Messagepar oukourj » 30 Déc 2005 08:40

Merci beaucoup, je vais chercher sur cette voie.
OOo 3.3.0 \ Windows XP Pro SP3 Fr
oukourj
Membre lOOyal
Membre lOOyal
 
Message(s) : 36
Inscrit le : 22 Nov 2005 09:44
Localisation : Genève


Retour vers Tableur

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Aucun utilisateur inscrit et 44 invité(s)