Fenêtre de rappel

Discussions à propos du tableur Calc.
Les questions sur les macros doivent être postées dans la section dédiée en dessous.

Modérateur: Vilains modOOs

Règles du forum
Cette section est uniquement dédiée au tableur Calc. Vous ne devez pas poster ici de questions sur les macros mais utiliser la section éponyme.

Fenêtre de rappel

Messagepar BERRANNICE » 04 Août 2006 11:44

Sur Calc, je travaille avec un calendrier perpétuel. Le 15 octobre 2006, je dois signer un contrat. J'aimerai créer une fenêtre ou boite de dialogue qui 1 mois avant (le 15 août 2006) me signale que je dois faire certaines choses. Comment puis-je faire

WINDOXS XP SP1
OOO 2.0.2
Windows XP, version 2.0
BERRANNICE
NOOuvel adepte
NOOuvel adepte
 
Message(s) : 23
Inscrit le : 29 Jan 2006 14:40
Localisation : CHAUMONT, FRANCE

Messagepar Pierre-Yves Samyn » 05 Août 2006 08:02

Bonjour

Afficher ce genre de dialogue sans programmation, là tout de suite je ne vois pas. Sans macro il est toutefois possible d'afficher le rappel dans une cellule avec en plus mise en valeur de ladite cellule.

Avec une plage de données (calendrier) en $A$3:$B$30 (dates en A et actions en B)
Saisie en A1 du nombre de jours "d'avance" (30 par exemple)
En B1 saisie de la formule :

=RECHERCHEV(AUJOURDHUI()+$A$1;$A$3:$B$30;2)&TEXTE(STYLE(SI(ACTUELLE()<>"";"jaune";"Standard"));"#")

RECHERCHEV recherche dans le calendrier la date d'aujourd'hui plus le nombre mis en paramètre et "retourne" l'action à entreprendre à cette date.
STYLE met en jaune la cellule si la recherche a retourné quelquechose.
La fonction STYLE retournant elle-même la valeur zéro, on utilise la fonction TEXTE pour masquer ledit zéro.

Nota :
- le style "jaune" (par exemple) doit avoir été créé
- s'agissant de la concaténation de chaînes, il faut utiliser l'opérateur & pour éviter l'erreur 502
Pierre-Yves Samyn
Grand Maître de l'OOffice
Grand Maître de l'OOffice
 
Message(s) : 11276
Inscrit le : 02 Mai 2006 09:42

Re: Fenêtre de rappel

Messagepar bm92 » 05 Août 2006 10:57

BERRANNICE a écrit:Sur Calc, je travaille avec un calendrier perpétuel. Le 15 octobre 2006, je dois signer un contrat. J'aimerai créer une fenêtre ou boite de dialogue qui 1 mois avant (le 15 août 2006) me signale que je dois faire certaines choses. Comment puis-je faire

Le rappel d'une tâche est une fonction de base de tous les organiseurs électroniques ou logiciels. Peut-être même disponible sur un téléphone portable. Pourquoi se compliquer la vie à mal faire ce travail avec un tableur?
On peut visser une vis avec un couteau, mais avec un tournevis c'est plus efficace.
bm92
ManitOOu
ManitOOu
 
Message(s) : 2562
Inscrit le : 26 Nov 2005 14:42


Retour vers Tableur

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Google [Bot] et 45 invité(s)