[Résolu] Concaténer des cellules vides et non vides

Discussions à propos du tableur Calc.
Les questions sur les macros doivent être postées dans la section dédiée en dessous.

Modérateur: Vilains modOOs

Règles du forum
Cette section est uniquement dédiée au tableur Calc. Vous ne devez pas poster ici de questions sur les macros mais utiliser la section éponyme.

[Résolu] Concaténer des cellules vides et non vides

Messagepar bobbylecaribou » 14 Jan 2009 10:15

Bonjour,

voici un extrait de fichier sur lequel je travaille :
sample_01.jpg


je cherche une formule me permettant de rassembler les infos des colonnes "forme" et "abondance" dans la troisème, de la manière indiquer dans l'entête de ma colonne (les infos doivent être séparées par ", "). Tout ça car j'utilise l'auto complétion pour la colonne "abondance" (souvent les même termes utilisés).
Au final, j'utilise la dernière colonne pour d'autres opération.

Auparavant j'utilisai :
Code : Tout sélectionner   AgrandirRéduire
D2=A2&", "&B2

le problème avec cette formule, c'est que lorsque l'une des 2 cellules est vide, je me retrouve avec ", " en trop et qui me gène pour la suite...

j'ai essayé ce type de formule :
Code : Tout sélectionner   AgrandirRéduire
D2=SI(B2=vide;=A2;=A2&", "&B2)


Ca, ça ne marche pas, et j'ai un problème, car ça ne prend pas en compte le cas où A2 serait vide et B2 non vide...
Je ne suis pas encore très à l'aise avec ces histoires de formules, et si quelqu'un à une idée, ça me ferait gangner beaucoup de temps

Merci, et à plus
Bobby
ps : je suis au boulot...
Dernière édition par bobbylecaribou le 14 Jan 2009 11:02, édité 2 fois.
Au taf : OOo 3.2.1 sous Windows xp PRO SP3
Avatar de l’utilisateur
bobbylecaribou
Membre OOrganisé
Membre OOrganisé
 
Message(s) : 51
Inscrit le : 09 Nov 2007 11:35
Localisation : Lyon

Re: Concaténer des cellules vides et non vides

Messagepar SlOOoP » 14 Jan 2009 10:39

En imbriquant des SI, cela donne

Code : Tout sélectionner   AgrandirRéduire
D2=SI(NBVAL(A2:B2)=0;"";SI(NBVAL(A2:B2)=2;A2&" , "&B2;SI(ESTVIDE(A2);B2;A2)))


Explications
NBVAL renvoie le nombre de cellules non vides dans la plage
ESTVIDE renvoie Vrai si la cellule concernée (A2) est vide
OpenOffice 3.1 - Win XP SP2
SlOOoP
PassiOOnné
PassiOOnné
 
Message(s) : 744
Inscrit le : 27 Fév 2008 14:59

Re: Concaténer des cellules vides et non vides

Messagepar bobbylecaribou » 14 Jan 2009 10:49

Ok,
merci beaucoup pour la rapidité...
Donc, si je te suis bien pour la formule ESTVIDE, si je veux prendre en compte que la cellule B2 est vide, je dois rajouter à la formule :
Code : Tout sélectionner   AgrandirRéduire
SI(ESTVIDE(B2);A2;B2)


Question bis : toutes les parenthèses à la fin sont nécessaires???

Merci encore
à plus,Bobby

EDIT : Bon apparemment non, pas besoin de rajouter quelque chose, la formule marche très bien comme ça.
encore merci...
Au taf : OOo 3.2.1 sous Windows xp PRO SP3
Avatar de l’utilisateur
bobbylecaribou
Membre OOrganisé
Membre OOrganisé
 
Message(s) : 51
Inscrit le : 09 Nov 2007 11:35
Localisation : Lyon


Retour vers Tableur

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Aucun utilisateur inscrit et 5 invité(s)