NB.SI à plusieurs critères

Discussions à propos du tableur Calc.
Les questions sur les macros doivent être postées dans la section dédiée en dessous.

Modérateur: Vilains modOOs

Règles du forum
Cette section est uniquement dédiée au tableur Calc. Vous ne devez pas poster ici de questions sur les macros mais utiliser la section éponyme.

NB.SI à plusieurs critères

Messagepar totoro » 27 Oct 2008 14:28

Bonjour,
Je vous explique, je cherche à connaitre le nombre de ligne ayant une chaine de caractère, mais cela en fonction d'un autre critère sur la même ligne.
Pour l'instant j'ai ça:
Code : Tout sélectionner   AgrandirRéduire
=NB.SI(Incidents.$C$2:Incidents.$C$20;$A4)
Mais j'aimerais rajouter en plus la condition de mon second critère.
Est ce qu'il y en a qui voit une solution ?
Merci
Totoro
Dernière édition par totoro le 27 Oct 2008 16:00, édité 2 fois.
v3.2 sous Ubuntu (Karmic) Linux
totoro
NOOuvel adepte
NOOuvel adepte
 
Message(s) : 12
Inscrit le : 06 Déc 2006 20:41

Re: Connaitre la quantité d'action par semaine

Messagepar Dude » 27 Oct 2008 14:40

totoro a écrit:Est ce qu'il y en a qui vois une solution ?

Est-ce que tu as ton classeur sous les yeux ?
AOO 4.0.1 sous Windows 7 Pro x64

Poser une question, c'est bien. Répondre aux autres, c'est encore mieux.
Améliorez AOO et votez pour les issues
Avatar de l’utilisateur
Dude
Grand Maître de l'OOffice
Grand Maître de l'OOffice
 
Message(s) : 16295
Inscrit le : 03 Mars 2006 08:45
Localisation : 127.0.0.1

Re: NB.SI à plusieurs critère

Messagepar SlOOoP » 27 Oct 2008 16:52

Sans voir ton classeur, il est difficile de reproduire ton exemple.
Cependant la fonction BDNB() semble faite pour toi
OpenOffice 3.1 - Win XP SP2
SlOOoP
PassiOOnné
PassiOOnné
 
Message(s) : 744
Inscrit le : 27 Fév 2008 14:59

Re: NB.SI à plusieurs critère

Messagepar Pierre-Yves Samyn » 27 Oct 2008 17:45

SlOOoP a écrit:Sans voir ton classeur, il est difficile de reproduire ton exemple.
Cependant la fonction BDNB() semble faite pour toi


Avec un exemple, quelques fils avant le tien : viewtopic.php?p=70997#p70997

Par ailleurs NB.SI acceptant les expressions régulières il est possible d'utiliser une syntaxe du type :

Code : Tout sélectionner   AgrandirRéduire
=NB.SI(A1:A4;".*u.*|.*r.*")


Capture-1.png
Capture-1.png (2.33 Kio) Consulté 1277 fois


pour rechercher sur deux (ou plus) critères, en l'occurrence les cellules contenant u ou r
Pierre-Yves Samyn
Grand Maître de l'OOffice
Grand Maître de l'OOffice
 
Message(s) : 11277
Inscrit le : 02 Mai 2006 09:42


Retour vers Tableur

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Google [Bot] et 15 invité(s)