[Résolu] Afficher une date fixe sous condition

Discussions à propos du tableur Calc.
Les questions sur les macros doivent être postées dans la section dédiée en dessous.

Modérateur: Vilains modOOs

Règles du forum
Cette section est uniquement dédiée au tableur Calc. Vous ne devez pas poster ici de questions sur les macros mais utiliser la section éponyme.

[Résolu] Afficher une date fixe sous condition

Messagepar Herve30 » 17 Mai 2021 18:35

Bonjour,
Si A1 est rempli, je souhaite afficher dans B1 la date du jour FIXE (avec l'heure si possible )
J'utilise actuellement cette formule dans B1:
=SI(ET(A1=0;A1="");"";AUJOURDHUI())
Mais la date s'actualise tous les jours ....

Cordialement
Dernière édition par micmac le 20 Mai 2021 16:07, édité 2 fois.
Raison: Ajout de la coche verte
AOO 4.1.7
OS X Yosemite 10.10
Libre Office version 7.0.3.1
Herve30
Membre OOrganisé
Membre OOrganisé
 
Message(s) : 51
Inscrit le : 26 Fév 2019 15:57

Re: Afficher une date fixe sous condition

Messagepar Jean-Louis Cadeillan » 17 Mai 2021 19:11

Bonsoir,
Il est difficile d'être égal à zéro et rien à la fois… remplace ET() par OU(), ça devrait mieux aller…
Quand au fait que la date change tous les jours, c'est la destinée de la fonction AUJOURDHUI(). Si tu veux éviter cela, mets cette fonction dans un contrôle de validité attaché à B1 (avec MAINTENANT() qui te donne l'heure) :
Code : Tout sélectionner   AgrandirRéduire
=TEXTE(AUJOURDHUI();"jj/mm/aa")&"  "&TEXTE(MAINTENANT();"HH:MM")

Cordialement,
Jean-Louis
LibO 7.0.6.2 (x64 avec Java 1.8.0_281) et AOO 4.1.10 (avec Java x32 1.8.0_241), Windows 7 Édition Intégrale 64 SP1, (Domicile)
LibO 5.4.1.2 (x86) sous Ubuntu LTS 16.04.1, noyau 4.4.0-93 et Xfce 4.12, Java (x86) 1.8.0_131 (Travail) [obligation de version]
Avatar de l’utilisateur
Jean-Louis Cadeillan
GourOOu
GourOOu
 
Message(s) : 5182
Inscrit le : 03 Jan 2009 00:56

Re: Afficher une date fixe sous condition

Messagepar yclik » 18 Mai 2021 08:16

Bonjour
Herve30 a écrit:Mais la date s'actualise tous les jours ....


Il faudrait une macro associée à un "Evenement" feuille pour mettre la date et heure dans une colonne formatée en date et heure

exemple illustré :
date heure auto.ods
(56.63 Kio) Téléchargé 15 fois


Si cela ne convient pas ouvrir un post dans la section macro o les "pros" sévissent :D
OpenOffice 4.1.7 sous Windows 10
Avatar de l’utilisateur
yclik
SuppOOrter
SuppOOrter
 
Message(s) : 1293
Inscrit le : 15 Déc 2010 09:33

Re: Afficher une date fixe sous condition

Messagepar Herve30 » 18 Mai 2021 09:02

Bonjour,
Jean-louis serait il possible d'avoir un petit exemple pour illustrer ta formule ?
Merci d'avance
AOO 4.1.7
OS X Yosemite 10.10
Libre Office version 7.0.3.1
Herve30
Membre OOrganisé
Membre OOrganisé
 
Message(s) : 51
Inscrit le : 26 Fév 2019 15:57

Re: Afficher une date fixe sous condition

Messagepar Jeff » 18 Mai 2021 11:39

Bonjour,

Le tuto sur les listes déroulantes est ici :
viewtopic.php?f=29&t=22412

Et tu y trouve même un exemple de formule avec MAINTENANT en fin du premier message.

A +
À lire avant tout !

Pour télécharger Apache OpenOffice

AOO 4.1.10 sur Ubuntu 20.04.02 x64 (Focal Fossa), et sur Win 10 pro x64
Jeff
GourOOu
GourOOu
 
Message(s) : 8513
Inscrit le : 18 Sep 2006 10:40
Localisation : France

Re: Afficher une date fixe sous condition

Messagepar Herve30 » 20 Mai 2021 15:18

Merci à vous,
Problème résolu
Vos solutions m'ont bien aidées
Cordialement
AOO 4.1.7
OS X Yosemite 10.10
Libre Office version 7.0.3.1
Herve30
Membre OOrganisé
Membre OOrganisé
 
Message(s) : 51
Inscrit le : 26 Fév 2019 15:57


Retour vers Tableur

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Aucun utilisateur inscrit et 18 invité(s)