[Résolu] Caractère joker sur NB.SI

Discussions à propos du tableur Calc.
Les questions sur les macros doivent être postées dans la section dédiée en dessous.

Modérateur: Vilains modOOs

Règles du forum
Cette section est uniquement dédiée au tableur Calc. Vous ne devez pas poster ici de questions sur les macros mais utiliser la section éponyme.

[Résolu] Caractère joker sur NB.SI

Messagepar Kev74 » 11 Mai 2021 22:50

Bonsoir,

J'ai un petit souci sur le caractère joker.

En faite, je veux avec par exemple :

"Somme_Amiens" et "Amiens_Somme" , je veux avoir avec une seule formule avec =NB.SI(plage; critères) tel que cela me compte 1 lorsque j'inverse "Somme_Amiens" et "Amiens_Somme" dans les critères du NB.SI.

J'ai essayé avec le caractère joker : | mais cela me copte les deux formes et pas qu'une seule, et j'ai manipulé avec le caractère joker : "*." mais sans succès.

Merci de votre aide.

Bonne soirée.
Dernière édition par Kev74 le 22 Mai 2021 15:44, édité 2 fois.
LibreOffice 7.0.5.2 sous Windows 10
Kev74
Membre lOOyal
Membre lOOyal
 
Message(s) : 48
Inscrit le : 24 Avr 2021 20:09

Re: Caractère joker sur NB.SI

Messagepar Jeff » 12 Mai 2021 05:20

Bonjour.

Il faut employer .* dans ta formule (et pas l'inverse)

Veille également à ce que soit coché "Utiliser les expressions régulières dans les formules", via le menu Outils > Options > Calc > Calculer

A +
À lire avant tout !

Pour télécharger Apache OpenOffice

AOO 4.1.10 sur Ubuntu 20.04.02 x64 (Focal Fossa), et sur Win 10 pro x64
Jeff
GourOOu
GourOOu
 
Message(s) : 8505
Inscrit le : 18 Sep 2006 10:40
Localisation : France

Re: Caractère joker sur NB.SI

Messagepar Kev74 » 12 Mai 2021 10:11

Bonjour,

Oui en faite, j'avais essayé avec le .* et cette fonction est bien activée. Par contre je trouve pas de solutions pour comme écrit dans le titre tel qu'avec exemple Somme_Amiens et Amiens_Somme, cela me trouve un avec NB.SI ...
LibreOffice 7.0.5.2 sous Windows 10
Kev74
Membre lOOyal
Membre lOOyal
 
Message(s) : 48
Inscrit le : 24 Avr 2021 20:09

Re: Caractère joker sur NB.SI

Messagepar Michel JANZEF » 12 Mai 2021 11:27

Bonjour,
Avez-vous mis le point et l'astérisque avant et après le mot à comptabiliser ?
Ex :
Code : Tout sélectionner   AgrandirRéduire
=NB.SI(A1:A7;".*Amiens.*")
1- AOo 4.1.10 et LibO 7.0.6.2 (x64) - Windows 10 Famille 1909 64 bits
2- AOo 4.0.1 et LibO 4.1.5.3 sous Windows XP Familiale SP3
Avatar de l’utilisateur
Michel JANZEF
ManitOOu
ManitOOu
 
Message(s) : 2665
Inscrit le : 12 Jan 2006 11:04

Re: Caractère joker sur NB.SI

Messagepar Kev74 » 12 Mai 2021 12:02

Oui, j'ai essayé mais j'ai un autre nom que je vais rendre anonyme : "Test_Amiens" et "Somme_Amiens", le soucis c'est que là si je fais comme vous me dites, ça va me compter deux avec NB.SI . Et si j'inverse Somme_Amiens, ça va aussi me compter deux car y a aussi Test_Amiens.

Merci de votre réponse.
LibreOffice 7.0.5.2 sous Windows 10
Kev74
Membre lOOyal
Membre lOOyal
 
Message(s) : 48
Inscrit le : 24 Avr 2021 20:09

Re: Caractère joker sur NB.SI

Messagepar Jean-Louis Cadeillan » 12 Mai 2021 13:17

Bonjour,
Si ton problème est de savoir si, dans une plage de cellules, se trouve au moins dans une cellule, comme tout ou partie du contenu, la chaîne de caractères « Amiens », utilise la formule de Michel dans un test :
Code : Tout sélectionner   AgrandirRéduire
=NB.SI(A1:A7;".*Amiens.*")>0
Le test retournera VRAI, ce qui, en formatage Nombre Standard, égale 1, ou FAUX (=0). Si tu ne veux pas cocher les expressions régulières, tu pourrais utiliser :
Code : Tout sélectionner   AgrandirRéduire
=SOMMEPROD(ESTERR(TROUVE("Amiens";A1:A7)))<LIGNES(A1:A7)
Cordialement,
Jean-Louis
LibO 7.0.6.2 (x64 avec Java 1.8.0_281) et AOO 4.1.10 (avec Java x32 1.8.0_241), Windows 7 Édition Intégrale 64 SP1, (Domicile)
LibO 5.4.1.2 (x86) sous Ubuntu LTS 16.04.1, noyau 4.4.0-93 et Xfce 4.12, Java (x86) 1.8.0_131 (Travail) [obligation de version]
Avatar de l’utilisateur
Jean-Louis Cadeillan
GourOOu
GourOOu
 
Message(s) : 5176
Inscrit le : 03 Jan 2009 00:56

Re: Caractère joker sur NB.SI

Messagepar Kev74 » 12 Mai 2021 13:42

Merci de votre réponse, oui si j'accepte les expressions régulières, mais le souci, c'est comme expliqué dans le fichier ci-joint:
NB.SI LibreOffice.ods
(10.84 Kio) Téléchargé 10 fois
tel qu'en inversant SOMME_AMIENS, on se retrouve avec la même fonction dans le critère du NB.SI et qu'on obtient 1 si vous voyez ce que je veux dire. Merci
LibreOffice 7.0.5.2 sous Windows 10
Kev74
Membre lOOyal
Membre lOOyal
 
Message(s) : 48
Inscrit le : 24 Avr 2021 20:09

Re: Caractère joker sur NB.SI

Messagepar Jean-Louis Cadeillan » 12 Mai 2021 13:57

Kev74 a écrit:si vous voyez ce que je veux dire
Je ne suis pas sûr… mais si tu veux que la formule détecte le nombre de cellules qui contiennent «SOMME» et «AMIENS», tu peux utiliser :
Code : Tout sélectionner   AgrandirRéduire
=NB.SI.ENS(A1:A2;".*SOMME.*";A1:A2;".*AMIENS.*")
Cordialement,
Jean-Louis
LibO 7.0.6.2 (x64 avec Java 1.8.0_281) et AOO 4.1.10 (avec Java x32 1.8.0_241), Windows 7 Édition Intégrale 64 SP1, (Domicile)
LibO 5.4.1.2 (x86) sous Ubuntu LTS 16.04.1, noyau 4.4.0-93 et Xfce 4.12, Java (x86) 1.8.0_131 (Travail) [obligation de version]
Avatar de l’utilisateur
Jean-Louis Cadeillan
GourOOu
GourOOu
 
Message(s) : 5176
Inscrit le : 03 Jan 2009 00:56

Re: Caractère joker sur NB.SI

Messagepar Kev74 » 12 Mai 2021 15:40

Jean-Louis Cadeillan a écrit:
Kev74 a écrit:si vous voyez ce que je veux dire
Je ne suis pas sûr… mais si tu veux que la formule détecte le nombre de cellules qui contiennent «SOMME» et «AMIENS», tu peux utiliser :
Code : Tout sélectionner   AgrandirRéduire
=NB.SI.ENS(A1:A2;".*SOMME.*";A1:A2;".*AMIENS.*")
Cordialement,
Jean-Louis


Merci je cherchais cela, juste comment inclure ces deux critères de recherche dans le début de la rechercheV() ? Merci d'avance
LibreOffice 7.0.5.2 sous Windows 10
Kev74
Membre lOOyal
Membre lOOyal
 
Message(s) : 48
Inscrit le : 24 Avr 2021 20:09

Re: Caractère joker sur NB.SI

Messagepar Jean-Louis Cadeillan » 12 Mai 2021 15:54

Kev74 a écrit:comment inclure ces deux critères de recherche dans le début de la rechercheV() ?
Règle n°7 du forum : afin d'avoir une base de connaissance efficace, évite de mettre deux problèmes différents dans une même question. Démarre donc un nouveau fil pour cette autre question.
Cordialement,
Jean-Louis
LibO 7.0.6.2 (x64 avec Java 1.8.0_281) et AOO 4.1.10 (avec Java x32 1.8.0_241), Windows 7 Édition Intégrale 64 SP1, (Domicile)
LibO 5.4.1.2 (x86) sous Ubuntu LTS 16.04.1, noyau 4.4.0-93 et Xfce 4.12, Java (x86) 1.8.0_131 (Travail) [obligation de version]
Avatar de l’utilisateur
Jean-Louis Cadeillan
GourOOu
GourOOu
 
Message(s) : 5176
Inscrit le : 03 Jan 2009 00:56

Re: Caractère joker sur NB.SI

Messagepar Jeff » 12 Mai 2021 17:28

Bonjour à tous,

Comme tu sais compter tout ce qui contient "Amiens", tu devrais également pouvoir compter tout ce qui contient "Test", et une soustraction de l’un et l’autre devrait retourner également le bon résultat...

A +
À lire avant tout !

Pour télécharger Apache OpenOffice

AOO 4.1.10 sur Ubuntu 20.04.02 x64 (Focal Fossa), et sur Win 10 pro x64
Jeff
GourOOu
GourOOu
 
Message(s) : 8505
Inscrit le : 18 Sep 2006 10:40
Localisation : France


Retour vers Tableur

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Aucun utilisateur inscrit et 13 invité(s)