[Résolu] Détection de doublon et ordre de tri

Discussions à propos du tableur Calc.
Les questions sur les macros doivent être postées dans la section dédiée en dessous.

Modérateur: Vilains modOOs

Règles du forum
Cette section est uniquement dédiée au tableur Calc. Vous ne devez pas poster ici de questions sur les macros mais utiliser la section éponyme.

[Résolu] Détection de doublon et ordre de tri

Messagepar elde » 13 Jan 2021 11:18

Bonjour,

Je dispose d'un fichier qui comprend pour chaque enregistrement un code alphanumérique (col. A), un libellé (Col. B) ainsi que l'indication éventuelle d'un doublon (col. C et D).

Je souhaite détecter les doublons sur les codes alphanumériques.
J'utilise pour cela la fonction "EXACT". Cependant pour obtenir un résultat correct, le fichier doit être trié dans l'ordre des codes. S'il est trié dans l'ordre des libellés cela ne fonctionne pas.

Y-a-t'il un moyen pour détecter les doublons quelque soit l'ordre de tri du fichier ?

Je joins un fichier à titre d'exemple.

Merci pour votre aide.
Pièces jointes
Détection de doublon.ods
(19.21 Kio) Téléchargé 3 fois
Dernière édition par elde le 13 Jan 2021 14:24, édité 1 fois.
Libre Office 5.2.6.2.lin14 (x64) (Obligation de version) sous Windows 10
Libre Office 6.3.2.2 (x64) sous Windows 10
elde
Membre hOOnoraire
Membre hOOnoraire
 
Message(s) : 178
Inscrit le : 14 Mai 2010 14:13

Re: Détection de doublon et ordre de tri

Messagepar Michel JANZEF » 13 Jan 2021 11:39

Bonjour,
Pour le 1er tableau, vous pouvez utiliser
Code : Tout sélectionner   AgrandirRéduire
=NB.SI($A$5:$A$16;A5)>1

Et pour le 2ème :
Code : Tout sélectionner   AgrandirRéduire
=NB.SI($A$20:$A$30;A20)>1
Pièces jointes
elde-MJ_13012021_01.ods
(19 Kio) Téléchargé 5 fois
1- AOo 4.1.8 et LibO 6.4.7.2 (x64) - Windows 10 Famille 1909 64 bits
2- AOo 4.0.1 et LibO 4.1.5.3 sous Windows XP Familiale SP3
Avatar de l’utilisateur
Michel JANZEF
HédOOniste
HédOOniste
 
Message(s) : 2429
Inscrit le : 12 Jan 2006 11:04

Re: Détection de doublon et ordre de tri

Messagepar elde » 13 Jan 2021 14:21

C'est parfait !
Juste une petite précision pour les futurs lecteurs de cet échange, la position du signe supérieur après la parenthèse est importante... sinon ça ne fonctionne pas.

Merci beaucoup.
Libre Office 5.2.6.2.lin14 (x64) (Obligation de version) sous Windows 10
Libre Office 6.3.2.2 (x64) sous Windows 10
elde
Membre hOOnoraire
Membre hOOnoraire
 
Message(s) : 178
Inscrit le : 14 Mai 2010 14:13


Retour vers Tableur

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Aucun utilisateur inscrit et 10 invité(s)