[Résolu] copier coller dans onglet de synthèse

Discussions à propos du tableur Calc.
Les questions sur les macros doivent être postées dans la section dédiée en dessous.

Modérateur: Vilains modOOs

Règles du forum
Cette section est uniquement dédiée au tableur Calc. Vous ne devez pas poster ici de questions sur les macros mais utiliser la section éponyme.

[Résolu] copier coller dans onglet de synthèse

Messagepar Yoyannick » 26 Mars 2020 15:22

Bonjour à tous,
Je vous sollicite à nouveau pour le même tableur.
Arreté hebdomadaire.ods
(127.49 Kio) Téléchargé 4 fois

Je souhaite centraliser dans l'onglet synthèse hebdo les écritures passées chaque jour dans chaque onglet mardi mercredi jeudi...
A part = dans la cellule et clic sur la cellule d'origine.
Problème, j'ai 5 jours* 6 colonnes*40 lignes 1200 saisies.
En plus, quand je fais copier coller dans la cellule apparaît =Mardi A3.
Je suis sur qu'il existe une solution plus simple.
Je vous remercie de votre aide.

Restez couverts

La modération vous a écrit: Il faudra penser à votre précédent message Somme dans colonne avec cellules filtrées qui attend une suite de votre part.

Dernière édition par micmac le 27 Mars 2020 08:53, édité 2 fois.
Raison: Ajout de [Résolu]
OpenOffice 4.1.6 sous Windows XP
Yoyannick
Fraîchement OOthentifié
 
Message(s) : 3
Inscrit le : 25 Mars 2020 21:45

Re: copier coller dans onglet de synthèse

Messagepar njhub » 27 Mars 2020 02:13

Bonjour Yoyannick,

Voyez si la solution proposée dans la pièce jointe, respectant vos paramètres en colonne H, vous convient
mardi
Code : Tout sélectionner   AgrandirRéduire
=SI(LIGNE()-2>NB.SI($Mardi.$A$2:$A$39;"<>"&"");"";INDIRECT(ADRESSE(LIGNE()-1;COLONNE();4;1;"Mardi");1))

mercredi
Code : Tout sélectionner   AgrandirRéduire
=SI(LIGNE()-40>NB.SI($Mercredi.$A$2:$A$40;"<>"&"");"";INDIRECT(ADRESSE(LIGNE()-39;COLONNE();4;1;"Mercredi");1))

jeudi
Code : Tout sélectionner   AgrandirRéduire
=SI(LIGNE()-78>NB.SI($Jeudi.$A$2:$A$40;"<>"&"");"";INDIRECT(ADRESSE(LIGNE()-77;COLONNE();4;1;"Jeudi");1))

vendredi
Code : Tout sélectionner   AgrandirRéduire
=SI(LIGNE()-117>NB.SI($Vendredi.$A$2:$A$40;"<>"&"");"";INDIRECT(ADRESSE(LIGNE()-116;COLONNE();4;1;"Vendredi");1))

lundi
Code : Tout sélectionner   AgrandirRéduire
=SI(LIGNE()-155>NB.SI($Lundi.$A$2:$A$40;"<>"&"");"";INDIRECT(ADRESSE(LIGNE()-154;COLONNE();4;1;"Lundi");1))

Yoyannick_Arreté hebdomadaire.ods
(134.25 Kio) Téléchargé 3 fois

:wink:
LibreOffice 6.3.5.2 (x64) FR-YT 07-03-20
OS : Windows 10.0
njhub
Membre cOOnfirmé
Membre cOOnfirmé
 
Message(s) : 233
Inscrit le : 18 Juin 2017 06:43
Localisation : 976

Re: copier coller dans onglet de synthèse

Messagepar Yoyannick » 27 Mars 2020 08:41

Bonjour,
formidable, pile poil.
Par contre, la formule, c'est du chinois pour moi
J'aime comprendre ce que je fais
Est il possible d'avoir une traduction ?
rien que le ligne () je suppose que cela signifie toutes les lignes mais pourquoi -2? pour ne pas tenir compte des 2 premières.

En tout cas un grand merci à vous
OpenOffice 4.1.6 sous Windows XP
Yoyannick
Fraîchement OOthentifié
 
Message(s) : 3
Inscrit le : 25 Mars 2020 21:45

Re: [Résolu] copier coller dans onglet de synthèse

Messagepar njhub » 27 Mars 2020 09:07

Bonjour Yoyannick,

Décortiquons la formule :
Code : Tout sélectionner   AgrandirRéduire
=SI(LIGNE()-2>NB.SI($Mardi.$A$2:$A$39;"<>"&"");"";INDIRECT(ADRESSE(LIGNE()-1;COLONNE();4;1;"Mardi");1))


la fonction SI() :
SI(CONDITION RESPECTÉE;ALORS;SINON)

CONDITION : LIGNE()-2>NB.SI($Mardi.$A$2:$A$39;"<>"&"")
quand le numéro de ligne où on se trouve moins 2 (pour ne pas tenir compte des 2 premières) est supérieur au nombre de lignes remplies dans la colonne A de la feuille "Mardi" de $A$2 à $A$39 (étendue des lignes que vous avez définies pour le mardi)
ALORS : ;""
qui veut dire vide

SINON : ;INDIRECT(ADRESSE(LIGNE()-1;COLONNE();4;1;"Mardi");1)
INDIRECT renvoie le contenu de l'adresse indiquée par la fonction ADRESSE

Pour plus de précision, notamment avec votre version de tableur, je vous invite à utiliser la touche F1 quand le fichier est ouvert, c'est une mine de renseignements et d'astuces, c'est l'aide spécifique à votre version de tableur, c'est magique, il y a tout et plus..

:wink:
LibreOffice 6.3.5.2 (x64) FR-YT 07-03-20
OS : Windows 10.0
njhub
Membre cOOnfirmé
Membre cOOnfirmé
 
Message(s) : 233
Inscrit le : 18 Juin 2017 06:43
Localisation : 976


Retour vers Tableur

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Aucun utilisateur inscrit et 21 invité(s)