[Résolu] version 2019 - Déclaration : cases à zéro

Discussion et problème sur le facturier pour Auto-entrepreneur réalisé sous OpenOffice et ses dérivés

Modérateur: Vilains modOOs

[Résolu] version 2019 - Déclaration : cases à zéro

Messagepar The dids » 17 Oct 2019 12:34

Bonjour,

Je post un nouveau message qui fait référence à un vieux post :

margranger a écrit:Bonjour,
je débute avec ce programme, et si tout semble fonctionner correctement, la déclaration me pose problème : en effet, toutes les cases restent désespérément à zéro. Par où puis-je commencer à chercher ce qui cloche ?
Merci !

--
Martin


Excepté que j'utilise AEfacturier pour la deuxième année, je suis dans le même cas de figure :

[img]h**ps://framapic.org/LKFW9w8yABsn/zIfrm2MsNFgB.png[/img]

Comme @margranger j'ai des cases qui affichent 0 alors qu'il y a du CA réalisé et pointé, c'est visible dans l'onglet «Saisie».
Auparavant, je n'avais pas ce problème.
Pourquoi la macro se mettrait-elle à déconner ?

En pièce jointe, mon fichier anonymisé.
[EDIT] fichier ajouté après coup

Merci pour vos retours :)

P.S. : signature à jour
Pièces jointes
MicroFacturier2019-VA.ods
(124.59 Kio) Téléchargé 68 fois
Dernière édition par micmac le 17 Oct 2019 22:48, édité 4 fois.
Raison: Ajout de la coche verte
LibreOffice Version: 5.4.6.2
Build ID: 1:5.4.6-0ubuntu0.17.10.1
CPU threads: 2; OS: Linux 4.13; UI render: default; VCL: x11;
Locale: fr-FR (fr_FR.UTF-8); Calc: group

sous Lubuntu 17.10
Avatar de l’utilisateur
The dids
Membre OOrganisé
Membre OOrganisé
 
Message(s) : 53
Inscrit le : 06 Mai 2018 19:28

Re: version 2019 - Déclaration : cases restent à zéro

Messagepar micmac » 17 Oct 2019 13:17

Bonjour,

Dans votre signature il y a écrit:LibreOffice Version: 5.4.6.2
The dids a écrit:signature à jour
Afin de profiter des dernières améliorations, il est fortement recommandé d'être à jour de la dernière version stable 6.2.7.

Vous devriez essayer la dernière version et revenir nous dire si vous observez le même comportement.
Avatar de l’utilisateur
micmac
RespOOnsable forum
RespOOnsable forum
 
Message(s) : 7361
Inscrit le : 28 Août 2010 09:45

Re: version 2019 - Déclaration : cases restent à zéro

Messagepar OOotremer971 » 17 Oct 2019 14:29

Bonjour,
The dids a écrit:En pièce jointe, mon fichier anonymisé.

Pas vu :?

A+
En principe, toujours à jour des dernières versions dites stables
AOO
LibreOffice
Debian 10
Ubuntu 18.04.4 LTS
OpenSuse Leap
Avatar de l’utilisateur
OOotremer971
ManitOOu
ManitOOu
 
Message(s) : 2503
Inscrit le : 16 Avr 2010 14:31

Re: version 2019 - Déclaration : cases restent à zéro

Messagepar The dids » 17 Oct 2019 19:09

micmac a écrit:Bonjour,

Dans votre signature il y a écrit:LibreOffice Version: 5.4.6.2
The dids a écrit:signature à jour
Afin de profiter des dernières améliorations, il est fortement recommandé d'être à jour de la dernière version stable 6.2.7.

Vous devriez essayer la dernière version et revenir nous dire si vous observez le même comportement.


Je n'était pas au courant. J'ai du mal à comprendre comment le fait d'utiliser une version datée peut influencer le fonctionnement de l'AEfacturier, mais je vais tester cela.

[edit] testé, aucun changement.

merci pour l'information :)
Dernière édition par The dids le 17 Oct 2019 21:52, édité 1 fois.
LibreOffice Version: 5.4.6.2
Build ID: 1:5.4.6-0ubuntu0.17.10.1
CPU threads: 2; OS: Linux 4.13; UI render: default; VCL: x11;
Locale: fr-FR (fr_FR.UTF-8); Calc: group

sous Lubuntu 17.10
Avatar de l’utilisateur
The dids
Membre OOrganisé
Membre OOrganisé
 
Message(s) : 53
Inscrit le : 06 Mai 2018 19:28

Re: version 2019 - Déclaration : cases à zéro

Messagepar jeanmimi » 17 Oct 2019 21:09

Bonjour,
The dids a écrit:je suis dans le même cas de figure

Je ne reproduis pas, l'onglet Déclarations est bien documenté.
Pièces jointes
Onglet Déclarations.jpg
LibreOffice : Version : 7.1.0 (x64)(5 février 2021)
Adoptopen JRE ou Oracle JRE (x64) 1.8.0_xxx, Windows 10, Thunderbird, Firefox
Avatar de l’utilisateur
jeanmimi
Grand Maître de l'OOffice
Grand Maître de l'OOffice
 
Message(s) : 15778
Inscrit le : 03 Mars 2006 17:02
Localisation : Venise verte

Re: version 2019 - Déclaration : cases à zéro

Messagepar OOotremer971 » 17 Oct 2019 21:21

Bonjour,
C'est malin d'ajouter après coup le fichier dans le premier message et de pas le signaler. T’aurais pu attendre longtemps une réponse à ta question :?

Dans ton fichier, tu as "cassé" les formules des cellules K46, K47, K48, K49 de la feuille Saisie probablement en supprimant des colonnes quelque part.
La boulette s'est produite entre le 20 et le 28/08/2019 (si ça peut t'aider à comprendre ton erreur)

K46 :
Code : Tout sélectionner   AgrandirRéduire
=SI(K40>0;SOMME.SI(F15:F39;ESTVIDE(K15:K39);K15:K39)*K43/K40 + SOMME.SI(F15:F39;#REF !;K15:K39)*K43/K40;"")

devrait-être :
Code : Tout sélectionner   AgrandirRéduire
=SI(K40>0;SOMME.SI(F15:F39;ESTVIDE(K15:K39);K15:K39)*K43/K40 + SOMME.SI(F15:F39;Paramètres.C6;K15:K39)*K43/K40;"")


K47 :
Code : Tout sélectionner   AgrandirRéduire
=SI(ET(K40>0;#REF !<>"");SOMME.SI(F15:F39;#REF !;K15:K39)*K43/K40;"")

devrait-être :
Code : Tout sélectionner   AgrandirRéduire
=SI(ET(K40>0;Paramètres.C7<>"");SOMME.SI(F15:F39;Paramètres.C7;K15:K39)*K43/K40;"")


K48 :
Code : Tout sélectionner   AgrandirRéduire
=SI(ET(K40>0;#REF !<>"");SOMME.SI(F15:F39;#REF !;K15:K39)*K43/K40;"")

devrait-être :
Code : Tout sélectionner   AgrandirRéduire
=SI(ET(K40>0;Paramètres.C8<>"");SOMME.SI(F15:F39;Paramètres.C8;K15:K39)*K43/K40;"")


Code : Tout sélectionner   AgrandirRéduire
K49 :

Code : Tout sélectionner   AgrandirRéduire
=SI(ET(K40>0;#REF !<>"");SOMME.SI(F15:F39;#REF !;K15:K39)*K43/K40;"")

devrait-être :
Code : Tout sélectionner   AgrandirRéduire
=SI(ET(K40>0;Paramètres.C9<>"");SOMME.SI(F15:F39;Paramètres.C9;K15:K39)*K43/K40;"")


Une fois corrigé, il faut déprotéger ta feuille Facture et remplir manuellement les cellules de la colonne O (O2:O21) en saisissant le montant de la colonne D de la même ligne.

Ensuite tu cliques sur le bouton MicroFacturier en bas à droite sur la feuille Saisie pour recalculer.
Micro2.png
Micro2.png (7.52 Kio) Consulté 1022 fois

Micro.png
En principe, toujours à jour des dernières versions dites stables
AOO
LibreOffice
Debian 10
Ubuntu 18.04.4 LTS
OpenSuse Leap
Avatar de l’utilisateur
OOotremer971
ManitOOu
ManitOOu
 
Message(s) : 2503
Inscrit le : 16 Avr 2010 14:31

Re: version 2019 - Déclaration : cases restent à zéro

Messagepar The dids » 17 Oct 2019 21:48

OOotremer971 a écrit:Bonjour,
The dids a écrit:En pièce jointe, mon fichier anonymisé.

Pas vu :?
A+


Oup's désolé, je voulais faire une réponse, mais j'ai reçut un appel téléphonique et puis après, j'ai perdu le fil!

Heureusement tu as vu le fichier et trouvé où se trouvait mon problème !

Un énorme merci à toi !
Dernière édition par The dids le 17 Oct 2019 22:20, édité 1 fois.
LibreOffice Version: 5.4.6.2
Build ID: 1:5.4.6-0ubuntu0.17.10.1
CPU threads: 2; OS: Linux 4.13; UI render: default; VCL: x11;
Locale: fr-FR (fr_FR.UTF-8); Calc: group

sous Lubuntu 17.10
Avatar de l’utilisateur
The dids
Membre OOrganisé
Membre OOrganisé
 
Message(s) : 53
Inscrit le : 06 Mai 2018 19:28

Re: version 2019 - Déclaration : cases à zéro

Messagepar The dids » 17 Oct 2019 21:53

jeanmimi a écrit:Bonjour,
The dids a écrit:je suis dans le même cas de figure

Je ne reproduis pas, l'onglet Déclarations est bien documenté.


hé bien si, tu reproduit !
septembre et octobre, mon ami ^^
LibreOffice Version: 5.4.6.2
Build ID: 1:5.4.6-0ubuntu0.17.10.1
CPU threads: 2; OS: Linux 4.13; UI render: default; VCL: x11;
Locale: fr-FR (fr_FR.UTF-8); Calc: group

sous Lubuntu 17.10
Avatar de l’utilisateur
The dids
Membre OOrganisé
Membre OOrganisé
 
Message(s) : 53
Inscrit le : 06 Mai 2018 19:28

Re: version 2019 - Déclaration : cases à zéro

Messagepar The dids » 17 Oct 2019 22:00

OOotremer971 a écrit:Bonjour,
C'est malin d'ajouter après coup le fichier dans le premier message et de pas le signaler. T’aurais pu attendre longtemps une réponse à ta question :?
...


OOtremer971, tu assures !

merci pour le tutoriel personalisé ^^

Comment fais tu pour savoir que la boulette à eu lieu entre le 20 et le 28 Août ? D'après les factures ?
Je vais corriger ça de suite.
LibreOffice Version: 5.4.6.2
Build ID: 1:5.4.6-0ubuntu0.17.10.1
CPU threads: 2; OS: Linux 4.13; UI render: default; VCL: x11;
Locale: fr-FR (fr_FR.UTF-8); Calc: group

sous Lubuntu 17.10
Avatar de l’utilisateur
The dids
Membre OOrganisé
Membre OOrganisé
 
Message(s) : 53
Inscrit le : 06 Mai 2018 19:28

Re: [Résolu] version 2019 - Déclaration : cases à zéro

Messagepar OOotremer971 » 17 Oct 2019 22:20

The dids a écrit:Comment fais tu pour savoir que la boulette à eu lieu entre le 20 et le 28 Août ?

Parce que la colonne O de la feuille Facture est correctement renseignée jusqu'au 20 août, l'erreur apparaît à partir du 28/08 jusqu'au 15/10.

A+
En principe, toujours à jour des dernières versions dites stables
AOO
LibreOffice
Debian 10
Ubuntu 18.04.4 LTS
OpenSuse Leap
Avatar de l’utilisateur
OOotremer971
ManitOOu
ManitOOu
 
Message(s) : 2503
Inscrit le : 16 Avr 2010 14:31

Re: [Résolu] version 2019 - Déclaration : cases à zéro

Messagepar The dids » 17 Oct 2019 22:23

Super ! :super:

Merci de m'avoir fait découvrir ça ^^ :bravo:

Maintenant, il est temps de saisir les factures !
Bonne nuit !
LibreOffice Version: 5.4.6.2
Build ID: 1:5.4.6-0ubuntu0.17.10.1
CPU threads: 2; OS: Linux 4.13; UI render: default; VCL: x11;
Locale: fr-FR (fr_FR.UTF-8); Calc: group

sous Lubuntu 17.10
Avatar de l’utilisateur
The dids
Membre OOrganisé
Membre OOrganisé
 
Message(s) : 53
Inscrit le : 06 Mai 2018 19:28


Retour vers AE Facturier ++ / MicroFacturier

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Aucun utilisateur inscrit et 1 invité