[Résolu] LibO 3.3.0 sur Ubuntu - Retour d'expérience

Les dernières nouvelles du front du libre, débats et autres informations générales sur nos suites bureautiques préférées ou sur ce site, en évitant de provoquer toute polémique (troll).
Aucun support assuré ici : posez votre question dans la section appropriée.

Modérateur: Vilains modOOs

[Résolu] LibO 3.3.0 sur Ubuntu - Retour d'expérience

Messagepar Alain de La Chaume » 01 Fév 2011 11:31

Bonjour à tous,

J'ai choisi de créer ce fil dans Nouvelles du front et Tribune libre pour plusieurs raisons :
− Je n'écris pas l'anglais. Donc l'accès à l'outil de rapport d'anomalies ne m'est pas accessible.
− Cette tribune est libre, comme notre (nos) suite favorite. :wink:
− Ayant un matériel jugé par beaucoup obsolète donc non représentatif, je ne vais pas encombrer les autres sections avec mes problèmes.

[Résolu] Extension TestFontsJTB
Dans ce fil [Writer] Afficheur de polices j'indique l'impossibilité d'installer la version 1.4.3 qui "tournait" sous OOo 3.2.1.

330_ERR_OXT_testFontsJTB_listerFonts-2.png
En revanche, la version 1.4.4 s'installe sans problème.

A Dude (viewtopic.php?f=18&t=18111#p147469) :
Non, à première vue, ce n'est pas du python :
REM ***** BASIC *****
' TestFontsJTB - Statistika fontů v dokumentu writeru
' TestFontsJTB - Statistics of used fonts in document of writer's document
'
' Autor: Tomáš Bílek – © 2007 – macrojtb@volny.cz
'

Perte des réglages et personnalisations diverses
Là, je n'apporte pas de réponse... :? Seulement quelques constatations :
Sans que j'aie pu à ce jour en déterminer la raison, il arrive que, au redémarrage de Libo :
− Mes Barres d'outils personnelles ;
− Les macros de la bibliothèque Standard de Mes macros ;
− Les options de correction de Writer, etc.
ont disparu.
A noter pour les macros : elles sont considérées comme absentes dans l'interface et ne sont pas fonctionnelles, mais...
si j'ouvre le dossier user/basic/Standard les fichiers correspondants existent bien.
Autre constat : le fichier .libreoffice/3/user/registrymodifications.xcu
a subi un "dégraissage" (de 168 Kio à 207 bytes). Normal, ou pas ?
Précision : ces désagréments, qui m'obligent à sauvegarder très régulièrement mon profil, surviennent sans que j'utilise simultanément OOo et LibO qui sont installés sur la même machine, sous le même OS.
Dernière édition par Alain de La Chaume le 07 Fév 2011 11:09, édité 1 fois.
(API-culteur et pêcheur de macros en mode loisirs occasionnels, mais toujours les pieds dans l'OO)
AOO 4.1.2 sous Linux Xubuntu Voyager 14.04 (x86_64)
Avatar de l’utilisateur
Alain de La Chaume
HédOOniste
HédOOniste
 
Message(s) : 1526
Inscrit le : 28 Sep 2008 13:56
Localisation : ʇsǝnoo,ꞁ ɐ ʇuǝɯǝʇǝꞁdɯoↃ

Re: Libo 3.3.0 sur Ubuntu - Retour d'expérience

Messagepar Ravioli » 01 Fév 2011 15:17

Bonjour Alain,

Oui, j'ai constaté que LibO parfois oublie quelques préférences du profil de OOo...
mais avec toutes les RC testées, j'avoue que perdre la couleur de la délimitation du texte est assez étonnant alors que sont conservés d'autres réglages semble-il plus difficiles à lire...

J'ai eu avec Mac quelques problèmes de stabilité entre LibO et OOo 3 définitives, heureusement résolu par une Réparation des Autorisations, entretien normal de Mac.

Je pense que cette cohabitation n'est pas souhaitable dans l'utilisation normale d'un ordinateur, Windows, Linux ou Mac...
Les 2 programmes sont trop peu différents,
finalement,
un seul devrait suffire pour créer et lire les documents ODF...

A+
AOO 4.1.1 LibO 4.4.5
Vista SP2, Win7 SP1, Win7 SP1 Pro, Win 8.1.1 Pro, Mac Intel OS X 10.10.5, Ubuntu 12.04 LTS 32 bits, OpenSuse 13.2, Debian 7
& LibO 4.0.6 pour Mac PPC 10.5.8
Avatar de l’utilisateur
Ravioli
GourOOu
GourOOu
 
Message(s) : 7610
Inscrit le : 18 Oct 2007 17:28

Re: Libo 3.3.0 sur Ubuntu - Retour d'expérience

Messagepar Josop » 01 Fév 2011 15:31

J'ai installé LibO sur 2 machines sous Ubuntu 10.10 et 10.04 (un portable et un fixe). Pas de problème d'installation avec la version officielle mais la police d'affichage est moche (baveuse) et me fait mal au crâne au bout de 10 mn. J'ai eu le même problème avec les versions de Thunderbird et Firefox non "ubuntuisées". Problème de compilation semble-t-il...

D'autre part, la version installée à partir du PPA ne s'intègre pas à mon thème (pourtant fort simple et basique).

J'ai installé aujourd'hui la 3.3.0 finale (officielle) d'OpenOffice.org et là tout est clair — si on peut parler ainsi des polices — sans bavures et flous pénibles pour les yeux. Mon thème Ubuntu est parfaitement respecté.

Quelqu'un d'autre a-t-il constaté ce désagrément sous LibreOffice ?
Josop
Membre OOrganisé
Membre OOrganisé
 
Message(s) : 96
Inscrit le : 07 Avr 2006 08:47

Re: Libo 3.3.0 sur Ubuntu - Retour d'expérience

Messagepar Vulcain » 01 Fév 2011 20:08

Je constate aussi que les polices sont un moche dans les menus de LibrOffice 3.3
InterfaceLibrO.png
Une erreur de jeunesse ?
LibreOffice 3.5.7.2 sous Ubuntu 12.04 (vient des dépôts)
--
"Un logiciel Libre est gratuit une fois qu'il a été payé" F.ELIE
Avatar de l’utilisateur
Vulcain
InconditiOOnnel
InconditiOOnnel
 
Message(s) : 989
Inscrit le : 01 Juin 2009 10:52
Localisation : Poitou

Re: Libo 3.3.0 sur Ubuntu - Retour d'expérience

Messagepar Alain de La Chaume » 01 Fév 2011 20:26

Bonsoir,

Encore perdu presque tous mes réglages... Par presque je veux dire que :
− Je n'ai pas perdu les nouvelles barres d'outils perso.
− Je n'ai pas perdu le nouveau menu perso.
− J'ai perdu l'accès aux macros de la bib Standard de Mes macros ("Basic script not be found").
Je ne les vois pas dans l'EDI. Mais je les vois en tant que fichiers dans le gestionnaire de fichiers.
Une petite image de tout ça :
BasicScriptNotFound.png
MesMacrosStd.png

− J'ai perdu les options de corrections de Writer.
− J'ai perdu le choix de non affichage de certaines barres d'outils.
− J'ai perdu... patience.
Je verrai donc cela demain. Et, comme le conseille Ravioli, en neutralisant la cohabitation.

Ravioli a écrit:j'ai constaté que LibO parfois oublie quelques préférences du profil de OOo...
Pour ce qui me concerne, ce n'est pas vraiment le cas : j'avais neutralisé en les renommant TOUS les répertoires relatifs à OOo dans mon dossier perso pour les profils, et dans /opt pour les applis. Il s'agit donc de réglages créés spécialement pour Libo, après son installation.
(API-culteur et pêcheur de macros en mode loisirs occasionnels, mais toujours les pieds dans l'OO)
AOO 4.1.2 sous Linux Xubuntu Voyager 14.04 (x86_64)
Avatar de l’utilisateur
Alain de La Chaume
HédOOniste
HédOOniste
 
Message(s) : 1526
Inscrit le : 28 Sep 2008 13:56
Localisation : ʇsǝnoo,ꞁ ɐ ʇuǝɯǝʇǝꞁdɯoↃ

Re: Libo 3.3.0 sur Ubuntu - Retour d'expérience

Messagepar Alain de La Chaume » 02 Fév 2011 01:13

Bonsoir Vulcain
Vulcain a écrit:Je constate aussi que les polices sont un moche dans les menus de LibrOffice 3.3

Il se pourrait que la vérité soit ailleurs... Car je n'ai pas de problèmes avec la police.
Nan ! Y'a pas de bavures ! :lol:
LibOmenus.png
Cliquer sur l'image pour la consulter en taille réelle.
(API-culteur et pêcheur de macros en mode loisirs occasionnels, mais toujours les pieds dans l'OO)
AOO 4.1.2 sous Linux Xubuntu Voyager 14.04 (x86_64)
Avatar de l’utilisateur
Alain de La Chaume
HédOOniste
HédOOniste
 
Message(s) : 1526
Inscrit le : 28 Sep 2008 13:56
Localisation : ʇsǝnoo,ꞁ ɐ ʇuǝɯǝʇǝꞁdɯoↃ

Re: Libo 3.3.0 sur Ubuntu - Retour d'expérience

Messagepar spYre » 02 Fév 2011 08:22

Bonjour à tous,

Mon expérience avec Ubuntu :
- postes concernés : un Ubuntu 10.04 LTS (32 bits) et un LinuxMint 10 (64 bits);
- désinstallation sans purge de OOo et installation sans souci de LibO (debs officiels);
- l'intégration dans gnome est impeccable, pas de souci d'affichage de police (chez moi différente de celle affichée chez Vulcain);
- pas de problème d'accès aux macros, quel que soit le conteneur;
- un délai à l'ouverture peut-être plus long qu'auparavant, à démontrer.

Bref une migration en douceur dans les deux cas.

Plus fort : l'extension Numbertext (codée en python) fonctionne parfaitement, ainsi que sur mes systèmes Windows (y compris W2000) :shock:.

Cordialement.
LibreOffice 3.3.4 + Report Builder
Windows 7 / Windows XP sp3
Ubuntu 11.10 / LMDE
Avatar de l’utilisateur
spYre
InconditiOOnnel
InconditiOOnnel
 
Message(s) : 888
Inscrit le : 29 Oct 2008 20:02
Localisation : Liège, Belgique

Re: Libo 3.3.0 sur Ubuntu - Retour d'expérience

Messagepar Vulcain » 02 Fév 2011 08:54

spYre a écrit:- l'intégration dans gnome est impeccable, pas de souci d'affichage de police (chez moi différente de celle affichée chez Vulcain).
J'utilise Ubuntu 10.10 et il y a une nouvelle police pour le système qui s’appelle Ubuntu et elle mise par défaut.
LibreOffice 3.5.7.2 sous Ubuntu 12.04 (vient des dépôts)
--
"Un logiciel Libre est gratuit une fois qu'il a été payé" F.ELIE
Avatar de l’utilisateur
Vulcain
InconditiOOnnel
InconditiOOnnel
 
Message(s) : 989
Inscrit le : 01 Juin 2009 10:52
Localisation : Poitou

Re: Libo 3.3.0 sur Ubuntu - Retour d'expérience

Messagepar Josop » 02 Fév 2011 09:48

Il se pourrait que la vérité soit ailleurs... Car je n'ai pas de problèmes avec la police.
Nan ! Y'a pas de bavures ! :lol:


Si, si, c'est très visible sur ta copie d'écran. :(

À comparer avec ça sous OOo 3.3.0

polices_ecran_OOo.png


Par contre, pour le reste, je pense que LibO prend une longueur d'avance sur OOo.
Plus stable, plus réactif, petits plus divers, et pour la première fois depuis que je suis sous Ubuntu (2007) je peux intégrer du son (mp3) ou de la video dans un diaporama (Impress) et ça c'est géant.
Dernière édition par Josop le 02 Fév 2011 18:48, édité 1 fois.
Josop
Membre OOrganisé
Membre OOrganisé
 
Message(s) : 96
Inscrit le : 07 Avr 2006 08:47

Re: Libo 3.3.0 sur Ubuntu - Retour d'expérience

Messagepar Alain de La Chaume » 05 Fév 2011 18:35

Bonjour,

Cela fait trois jours que j'ai renommé tous les dossiers relatifs à OOo
(v. 1.1.5, v. 2.4.2, v. 3.2.1) dans les répertoires utilisateur et du système (/opt).
Et depuis, pas de perte de réglages. Pas de disparition de macros.

Ce que j'avais constaté entre temps :
− Pour les réglages, c'est le fichier user/registrymodifications.xcu
qui se trouvait réinitialisé.
− Pour les macros Mes macros - Standard, c'est le fichier
user/basic/Standard/script.xlb qui était réinitialisé, d'où la perte,
non pas des macros, mais des références vers les modules.

Sinon, ben... que Josop trouve mon interface baveuse m'ennuie beaucoup...
...mais seulement pour lui. :lol: Pour moi, pas de problème.
(API-culteur et pêcheur de macros en mode loisirs occasionnels, mais toujours les pieds dans l'OO)
AOO 4.1.2 sous Linux Xubuntu Voyager 14.04 (x86_64)
Avatar de l’utilisateur
Alain de La Chaume
HédOOniste
HédOOniste
 
Message(s) : 1526
Inscrit le : 28 Sep 2008 13:56
Localisation : ʇsǝnoo,ꞁ ɐ ʇuǝɯǝʇǝꞁdɯoↃ

Re: Libo 3.3.0 sur Ubuntu - Retour d'expérience

Messagepar gerard24 » 05 Fév 2011 19:00

Bonsoir,
Alain de La Chaume a écrit:− Pour les réglages, c'est le fichier user/registrymodifications.xcu
qui se trouvait réinitialisé.

Il y a une issue ouverte la dessus (à priori spécifique Linux) : https://bugs.freedesktop.org/show_bug.cgi?id=33915

 Ajout : Que dis-je ? Il y a en même 2 : https://bugs.freedesktop.org/show_bug.cgi?id=33912
Le problème devrait être réglé 2 fois + vite. :lol: 
OOodidacte
LibreOffice 5.2.6 sous Windows vista SP2
pour télécharger LibreOffice
Avatar de l’utilisateur
gerard24
ManitOOu
ManitOOu
 
Message(s) : 3057
Inscrit le : 06 Juil 2008 18:08
Localisation : dans le Périgord

Re: Libo 3.3.0 sur Ubuntu - Retour d'expérience

Messagepar Alain de La Chaume » 07 Fév 2011 11:09

Bonjour à tous.

Le 6 février 2011, 11 h 17 :
Ce que je disais hier
Et depuis, pas de perte de réglages. Pas de disparition de macros.
n'est plus vrai aujourd'hui. :evil:

Merci à gerard24 pour sa trouvaille. Elle me dispense de chercher une raison spécifique à ma configuration.

Dommage ! C'est tout de même très handicapant de devoir penser à faire une sauvegarde de profil à chaque modification.
Moi qui n'utilise pas le terme bogue à tord et à travers, là je serais bien tenté...

Une des raisons (en dehors de toute considération politico-philosophique) qui me feraient préférer LibO (et là je crois que je vais en faire sursauter plus d'un :P ) c'est la possiblité de gérer chacune des branches de l'arborescence dans le navigateur de document sous Writer. Eh oui, ce qui paraît futil pour certains est important pour d'autres... (et "lycée de Versailles").

Ajout, le 7 février 2011, 11 h 10 :
Un peu agacé par ces pertes de réglages, j'ai donc installé la version officielle OOo 330...
... que j'ai abandonnée en moins de deux heures, à cause de plantages (fermeture inopinée et brutale de l'application).
Ces plantages intervenaient systématiquement lors de création ou modification de styles de paragraphes.

Conclusion : En attendant des jours meilleurs, je retourne à la version 321, et je clos ce sujet.
(API-culteur et pêcheur de macros en mode loisirs occasionnels, mais toujours les pieds dans l'OO)
AOO 4.1.2 sous Linux Xubuntu Voyager 14.04 (x86_64)
Avatar de l’utilisateur
Alain de La Chaume
HédOOniste
HédOOniste
 
Message(s) : 1526
Inscrit le : 28 Sep 2008 13:56
Localisation : ʇsǝnoo,ꞁ ɐ ʇuǝɯǝʇǝꞁdɯoↃ


Retour vers Nouvelles du front et Tribune du Libre

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Aucun utilisateur inscrit et 2 invité(s)