[Résolu] Activer le dictionnaire réforme 1990 de Grammalecte

Questions liées au programme de setup ou à l'installation ainsi que des problèmes d'ordre général qui ne sont pas liés à un module spécifique (dictionnaire, impression, etc).

Modérateur: Vilains modOOs

[Résolu] Activer le dictionnaire réforme 1990 de Grammalecte

Messagepar alicebtoklas » 25 Avr 2019 21:13

Bonjour Forum,
j'ai l'extension grammalecte (0.6.5) installée. La correction orthographique est active (mots soulignés en rouge) et la correction grammaticale aussi (mots soulignés en bleu). Je veux utiliser le dictionnaire "réforme 1990" qui devrait je pense refuser les anciennes formes orthographiques, notamment "maître", "apparaître", etc.
Pourtant grammalecte ne détecte aucune erreur, que j'écrive "maitre" avec ou sans accent circonflexe. Pire, si j'écris "gout" (nouvelle orthographe), LibreOffice me le corrige automatiquement en "goût" (ancienne orthographe).
J'ai l'impression qu'il y a comme une confusion entre la correction de LibreOffice et celle de grammalecte, mais je ne m'y retrouve pas.
Quelqu'un pour m'aider?
Merci beaucoup.
Dernière édition par alicebtoklas le 05 Mai 2019 11:12, édité 1 fois.
LibreOffice 6.1.5.2 sur Linux Mint 18.3 Sylvia
alicebtoklas
Fraîchement OOthentifié
 
Message(s) : 7
Inscrit le : 25 Avr 2019 15:11

Re: Activer le dictionnaire "réforme 1990" de Grammalecte

Messagepar Dredd » 26 Avr 2019 08:27

Salut

La version de Grammalecte que tu utilises est ancienne. Mets toi à jour:
viewtopic.php?f=18&t=30464
Propulsé par OpenOffice 4.1.6 sous Windows 10 x64
Avatar de l’utilisateur
Dredd
Membre cOOnverti
Membre cOOnverti
 
Message(s) : 341
Inscrit le : 24 Mai 2006 10:15
Localisation : Mega-City One

Re: Activer le dictionnaire "réforme 1990" de Grammalecte

Messagepar alicebtoklas » 26 Avr 2019 16:05

Merci,
mais la page de téléchargement de Grammalecte indique que c'est la version 0.6.5 qui convient pour LibreOffice 5.1...
LibreOffice 6.1.5.2 sur Linux Mint 18.3 Sylvia
alicebtoklas
Fraîchement OOthentifié
 
Message(s) : 7
Inscrit le : 25 Avr 2019 15:11

Re: Activer le dictionnaire "réforme 1990" de Grammalecte

Messagepar Dredd » 26 Avr 2019 17:00

Libre Office 5.1 est plus qu'obsolete aussi :)
Propulsé par OpenOffice 4.1.6 sous Windows 10 x64
Avatar de l’utilisateur
Dredd
Membre cOOnverti
Membre cOOnverti
 
Message(s) : 341
Inscrit le : 24 Mai 2006 10:15
Localisation : Mega-City One

Re: Activer le dictionnaire "réforme 1990" de Grammalecte

Messagepar alicebtoklas » 26 Avr 2019 18:14

Bon, je ne sais pas si tu dis ça parce que mon souci avec grammalecte vient d'une version de libreoffice trop vieille, ou parce que par principe tu penses qu'il faut avoir les dernières versions des logiciels, mais je vais voir si ça va mieux avec LO6.
Merci,
LibreOffice 6.1.5.2 sur Linux Mint 18.3 Sylvia
alicebtoklas
Fraîchement OOthentifié
 
Message(s) : 7
Inscrit le : 25 Avr 2019 15:11

Re: Activer le dictionnaire "réforme 1990" de Grammalecte

Messagepar alicebtoklas » 26 Avr 2019 21:28

Même problème avec grammalecte v1 sur LibreOffice 6.
LibreOffice 6.1.5.2 sur Linux Mint 18.3 Sylvia
alicebtoklas
Fraîchement OOthentifié
 
Message(s) : 7
Inscrit le : 25 Avr 2019 15:11

Re: Activer le dictionnaire "réforme 1990" de Grammalecte

Messagepar OlivierR » 27 Avr 2019 08:52

Bonjour,

Le problème peut venir d’un profil corrompu. Donc, purge de profil et réinstallation de l’extension peuvent aider.

Mais ça pourrait aussi venir de votre distribution. Souvent, les distributions ont modifié les logiciels comme LibreOffice pour les forcer à utiliser un système de dictionnaires commun à tous les logiciels de la distribution. Et dans ce cas, j’imagine qu’il est possible que LibreOffice ignore les réglages de Grammalecte. Alors il faudrait utiliser une version “vanilla” de LibreOffice (c’est-à-dire une version officielle et non celle de votre distribution).
LibreOffice 6.2Windows 10Grammalecte, correcteur grammatical et orthotypographique
OlivierR
SuppOOrter
SuppOOrter
 
Message(s) : 1027
Inscrit le : 24 Mai 2006 21:34
Localisation : Lorraine, France

Re: Activer le dictionnaire "réforme 1990" de Grammalecte

Messagepar alicebtoklas » 27 Avr 2019 10:00

Merci OlivierR,

j'ai déjà purgé le profil. Je viens encore de le faire et de réinstaller grammalecte.

J'ai installé LibreOffice6 en le téléchargeant depuis le site LibreOffice, donc je suppose que c'est une version vanilla?
LibreOffice 6.1.5.2 sur Linux Mint 18.3 Sylvia
alicebtoklas
Fraîchement OOthentifié
 
Message(s) : 7
Inscrit le : 25 Avr 2019 15:11

Re: Activer le dictionnaire "réforme 1990" de Grammalecte

Messagepar OlivierR » 27 Avr 2019 10:58

Oui, c’est ça.

Du coup, je sèche un peu sur la cause du problème.
Pouvez-vous lancer LO depuis une console et procéder à la modification du réglage ? Peut-être qu’une erreur apparaîtra ?
LibreOffice 6.2Windows 10Grammalecte, correcteur grammatical et orthotypographique
OlivierR
SuppOOrter
SuppOOrter
 
Message(s) : 1027
Inscrit le : 24 Mai 2006 21:34
Localisation : Lorraine, France

Re: Activer le dictionnaire "réforme 1990" de Grammalecte

Messagepar Scrat » 27 Avr 2019 11:26

Bonjour.

C'est une option d'autocorrection qui corrige automatiquement "gout" en "goût" quel que soit le dictionnaire utilisé. Ça doit être une option par défaut parce que seules les options qu'on ajoute sont dans le profil utilisateur.
Pour y accéder, menu Outils->Autocorrection->Options d'autocorrection, et supprimer l'entrée correspondante dans le premier onglet. :wink:
Voir ma copie d'écran.

Pour "maitre" et "maître", je n'ai pas d'explication. Le dictionnaire classique refuse la première orthographe, le dictionnaire réforme 1990 accepte les deux alors qu'il ne devrait accepter que la première d'après le site Grammalecte. Il semblerait que l'option "réforme 1990" soit identique à l'option "toutes variantes", ou tout au moins qu'elle active à la fois le dictionnaire classique et le dictionnaire réforme 1990. Olivier pourrait-il avoir des infos sur ce point ?

A+
Pièces jointes
Capture du 2019-04-27 13-18-44.png
Options d'autocorrection
Libre Office 6.0.7.3 Linux Mint 19.2 x64 (version des dépôts)
Utilisez l'extension de Sauvegarde incrémentale pour ne pas perdre de document !
Avatar de l’utilisateur
Scrat
HédOOniste
HédOOniste
 
Message(s) : 1870
Inscrit le : 06 Juin 2014 11:39
Localisation : Île d'Oléron

Re: Activer le dictionnaire "réforme 1990" de Grammalecte

Messagepar OlivierR » 28 Avr 2019 12:18

Chez moi, ça fonctionne comme ça devrait. Maître n’est pas reconnu comme valide par le dictionnaire réformé.
Je n’ai pas de réponse à ce problème.
LibreOffice 6.2Windows 10Grammalecte, correcteur grammatical et orthotypographique
OlivierR
SuppOOrter
SuppOOrter
 
Message(s) : 1027
Inscrit le : 24 Mai 2006 21:34
Localisation : Lorraine, France

Re: Activer le dictionnaire "réforme 1990" de Grammalecte

Messagepar Scrat » 28 Avr 2019 14:14

Bonjour Olivier.

J'ai refait mes tests et le dictionnaire "réforme 1990" donne la même chose que le dictionnaire "toutes variantes": les deux orthographes "maitre" et "maître" sont acceptées.

Par ailleurs, j'ai un peu fouillé dans le dossier d'installation de l'extension. Outre les trois dictionnaires proposés au choix dans les options, j'y ai trouvé aussi un dictionnaire "moderne". Celui-ci est-il obsolète ?

J'ai édité les trois dictionnaires proposés au choix: dans "classique" je ne trouve que l'orthographe "maître", dans "réforme 1990" je ne trouve que la nouvelle orthographe "maitre", et dans "toutes variantes" je trouve les deux. C'est donc qu'il y a un problème au moment du choix du dictionnaire qui doit toujours activer le dictionnaire "toutes variantes" si le choix est autre que "classique". Peux-tu me dire dans quel fichier se fait le choix pour que j'essaie de localiser l'erreur ?

A+
Libre Office 6.0.7.3 Linux Mint 19.2 x64 (version des dépôts)
Utilisez l'extension de Sauvegarde incrémentale pour ne pas perdre de document !
Avatar de l’utilisateur
Scrat
HédOOniste
HédOOniste
 
Message(s) : 1870
Inscrit le : 06 Juin 2014 11:39
Localisation : Île d'Oléron

Re: Activer le dictionnaire "réforme 1990" de Grammalecte

Messagepar alicebtoklas » 29 Avr 2019 20:18

Ah, je vois qu'un sujet a été ouvert sur le forum de grammalecte. Merci de vous pencher sur la question.
LibreOffice 6.1.5.2 sur Linux Mint 18.3 Sylvia
alicebtoklas
Fraîchement OOthentifié
 
Message(s) : 7
Inscrit le : 25 Avr 2019 15:11

Re: Activer le dictionnaire "réforme 1990" de Grammalecte

Messagepar Scrat » 30 Avr 2019 12:59

Bonjour.

Pour obtenir le comportement attendu par Grammalecte avec le choix du dictionnaire "réforme 1990", il faut passer par le menu Outils->Options->Paramètres linguistiques->Linguistique et désactiver l'option "vérificateur orthographique Hunspell".

Voici la copie d'écran correspondant au choix du dictionnaire "réforme 1990" dans Grammalecte et à la désactivation de Hunspell dans les options linguistiques de LibreOffice:

Capture du 2019-04-30 13-46-29.png
Désactivation de Hunspell


C'est apparemment l'activation par défaut de Hunspell qui laisse le dictionnaire classique toujours actif, même si on choisit dans Grammalecte le dictionnaire "réforme 1990". Comme Olivier n'observe pas ce comportement sur sa version LibreOffice Windows, je suppose qu'il s'agit d'un comportement des versions des dépôts Linux. Pour le vérifier, il faudrait installer une version officielle de LibreOffice sur Linux, ce que je testerai sur mon second PC dans quelques jours, mais on peut considérer dès maintenant que le problème est résolu.

Je résume les solutions au problème d'Alice:
1. désactiver Hunspell dans les préférences linguistiques
2. Suppression des options d'autocorrection non désirées.

Mais suivez la discussion sur le forum Grammalecte, parce qu'il y a des subtilités qui m'échappent. :wink:
https://grammalecte.net/thread.php?prj=fr&t=785

A+
Libre Office 6.0.7.3 Linux Mint 19.2 x64 (version des dépôts)
Utilisez l'extension de Sauvegarde incrémentale pour ne pas perdre de document !
Avatar de l’utilisateur
Scrat
HédOOniste
HédOOniste
 
Message(s) : 1870
Inscrit le : 06 Juin 2014 11:39
Localisation : Île d'Oléron

Re: Activer le dictionnaire "réforme 1990" de Grammalecte

Messagepar alicebtoklas » 05 Mai 2019 11:09

Super.
Désactiver Hunspell suffit, d'ailleurs. Il n'y a pas besoin de supprimer les options d'autocorrection liées à l'ancienne orthographe, elles sont désactivées automatiquement quand on désactive Hunspell. Par exemple, "gout" (nouvelle orthographe) est marqué comme incorrect quand Hunspell est activé et remplacé automatiquement par goût. Une fois que j'ai désactivé Hunspell, "gout" est considéré comme correct, c'est "goût" qui est marqué comme incorrect.

Dommage que l'installation de Grammalecte ne puisse pas désactiver automatiquement Hunspell...
Merci encore.
LibreOffice 6.1.5.2 sur Linux Mint 18.3 Sylvia
alicebtoklas
Fraîchement OOthentifié
 
Message(s) : 7
Inscrit le : 25 Avr 2019 15:11


Retour vers Installation et configuration

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Aucun utilisateur inscrit et 5 invité(s)