[Résolu] Sauvegarde avec des noms contenant des accents

Questions liées au programme de setup ou à l'installation ainsi que des problèmes d'ordre général qui ne sont pas liés à un module spécifique (dictionnaire, impression, etc).

Modérateur: Vilains modOOs

[Résolu] Sauvegarde avec des noms contenant des accents

Messagepar Patrice Gauvin » 14 Fév 2006 20:06

Bonjour,
J'ai besoin d'aide !

Lorsque j'enregistre un document avec des accents dans le nom du fichier, les accents sont convertit en charactères hexadécimal. Par exemple si j'enregistre un document avec le nom étoile.odt, le nom est convertit en %E9toile.odt.

C'est de l'encodage 8859_1
Char Hex
É = %E9
à = %E0
è = %E8
...

Le même problème se produit lorsque j'ouvre un document qui contient un accent dans le nom...

Example :
Si j'utiliser le dialogue d'ouverture de OOo2 pour ouvrir /home/pgauvin/Desktop/étoile.otd, j'ai un message qui dit que /home/pgauvin/Desktop/%E9toile.odt n'existe pas...

Le problème se produit autant sur la fat locale que sur la fat réseau. Je n'ais pas ce problème avec les autres éditeurs de texte.

J'utilise Mandriva 2006 avec leur rpm openoffice.org2.2-0-6mdk
Voici le résultat de la commande locale :LC_CTYPE=fr_CA
LC_NUMERIC=fr_CA
LC_TIME=fr_CA
LC_COLLATE=fr_CA
LC_MONETARY=fr_CA
LC_MESSAGES=fr_CA
LC_PAPER=fr_CA
LC_NAME=fr_CA
LC_ADDRESS=fr_CA
LC_TELEPHONE=fr_CA
LC_MEASUREMENT=fr_CA
LC_IDENTIFICATION=fr_CA
LC_ALL=

J'ai testé avec XP et Fedora Core 4 et le problème ne se produit pas....

Il y a surment une configuration à apporté à la base de registre dans les fichiers XML....

Merci
Patrice Gauvin

Technicien en Informatique
Commission Scolaire de Laval
Canada (Québec)
Patrice Gauvin
Fraîchement OOthentifié
 
Message(s) : 3
Inscrit le : 14 Fév 2006 19:28
Localisation : Canada (Québec)

Messagepar c-stefan » 15 Fév 2006 09:46

voici mon locale, sous ubuntu 5.10
locale
LANG=fr_FR.UTF-8
LC_CTYPE="fr_FR.UTF-8"
LC_NUMERIC="fr_FR.UTF-8"
LC_TIME="fr_FR.UTF-8"
LC_COLLATE="fr_FR.UTF-8"
LC_MONETARY="fr_FR.UTF-8"
LC_MESSAGES="fr_FR.UTF-8"
LC_PAPER="fr_FR.UTF-8"
LC_NAME="fr_FR.UTF-8"
LC_ADDRESS="fr_FR.UTF-8"
LC_TELEPHONE="fr_FR.UTF-8"
LC_MEASUREMENT="fr_FR.UTF-8"
LC_IDENTIFICATION="fr_FR.UTF-8"
LC_ALL=
Normalement faudrait ne plus utilisé le vieux mode d'encodage 8859_1 mais le UTF-8 ? regarde de ce côté la.
Avatar de l’utilisateur
c-stefan
Membre fOOndateur
Membre fOOndateur
 
Message(s) : 1147
Inscrit le : 16 Jan 2006 15:07
Localisation : Paris

Messagepar Patrice Gauvin » 15 Fév 2006 18:04

J'ai fait le test, j'ai changé mes variables pour fr_CA.UTF-8 mais c'est sans succès...
À mon avis, il doit y avoir une variable dans un fichier XML de la base de registre de OOO pour cela :!:
Patrice Gauvin

Technicien en Informatique
Commission Scolaire de Laval
Canada (Québec)
Patrice Gauvin
Fraîchement OOthentifié
 
Message(s) : 3
Inscrit le : 14 Fév 2006 19:28
Localisation : Canada (Québec)

Messagepar Bidouille » 16 Fév 2006 08:44

Patrice Gauvin a écrit:À mon avis, il doit y avoir une variable dans un fichier XML de la base de registre de OOO pour cela :!:

As-tu ce problème avec d'autres logiciels ?
Avatar de l’utilisateur
Bidouille
RespOOnsable forum
RespOOnsable forum
 
Message(s) : 10455
Inscrit le : 08 Nov 2005 17:23
Localisation : Brest, France

Re: Problème des sauvegarde avec des nom contenant des accen

Messagepar c-stefan » 16 Fév 2006 09:37

Patrice Gauvin a écrit:
J'ai testé avec XP et Fedora Core 4 et le problème ne se produit pas....

Il y a surment une configuration à apporté à la base de registre dans les fichiers XML....

Merci


Si tu as testé avez avec Xp et Fc 4, je pencherai plus pour une mauvaise configuration de mdv 2006.

crée un fichier sur ton bureau avec des accents pour tester ?
Avatar de l’utilisateur
c-stefan
Membre fOOndateur
Membre fOOndateur
 
Message(s) : 1147
Inscrit le : 16 Jan 2006 15:07
Localisation : Paris

Messagepar Patrice Gauvin » 16 Fév 2006 14:33

J'ai trouvé la source du problème, c'est le kde filepicker :

There is a bogue report for this in qa.mandriva.com, and sound a problem in the kde filepicker,
but the same happens into 2.0.1-1mdk but I don't have a patch (and the same bogue
seems persisting even in latest milestone m156).

Note that you can change the dialog box either from env var:

export OOO_FORCE_DESKTOP=kde

or

export OOO_FORCE_DESKTOP=gnome

before running ooffice2.0, either from menu Tools/Option/General => Use OpenOffice.org dialogs.
Patrice Gauvin

Technicien en Informatique
Commission Scolaire de Laval
Canada (Québec)
Patrice Gauvin
Fraîchement OOthentifié
 
Message(s) : 3
Inscrit le : 14 Fév 2006 19:28
Localisation : Canada (Québec)


Retour vers Installation et configuration

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Aucun utilisateur inscrit et 3 invité(s)