[RESUELTO] Funcion INDIRECTO

Discute sobre la aplicación de hojas de cálculo

[RESUELTO] Funcion INDIRECTO

Notapor yohana » Mié Nov 18, 2009 3:59 pm

Buenas tardes,

Me mandan un archivo de un proveedor en .xls, al abrirlo con calc da errores 502
Resulta ser la función INDIRECTO
Originalmente vienen las formulas asi:
=SI($B21<>"";BUSCARV($B21;INDIRECTO("'COEF."&$E$10&"'!$A:$E");3;FALSO());"")

Sin embargo si las cambio y pongo el rango "a mano" funciona bien
=SI($B20<>"";BUSCARV($B20;'COEF.ESC'.A1:E816;3;FALSO());"")

¿Algún truco o método para que funcione INDIRECTO()?
Última edición por yohana el Lun Nov 23, 2009 8:51 am, editado 1 vez en total
yohana
 
Mensajes: 66
Registrado: Mar Jun 30, 2009 2:42 pm

Re: Funcion INDIRECTO

Notapor mriosv » Mié Nov 18, 2009 8:23 pm

Prueba en una celda a ver el resultado de la parte de la función
="'COEF."&$E$10&"'!$A:$E"
creo que no da una referencia de celda válida , ni siquiera en excel.
de cualquier forma el separador ! en calc deber ser un . (punto)
Puedes usar "Subir adjunto" en Respuesta rápida - Editor Completo - Pestaña Subir adjunto
Apache OpenOffice 4, LibreOffice 5 (Win10x64)
mriosv
 
Mensajes: 2233
Registrado: Sab Dic 27, 2008 1:12 am
Ubicación: Galiza (España)

Re: Funcion INDIRECTO

Notapor yohana » Jue Nov 19, 2009 3:47 pm

Gracias por tu respuesta.

En excel si funciona pero en Calc no. He probado a cambiar ! por punto y nada.
Y sinceramente yo es que esta parte en concreto no se a que hace referencia "'COEF."&$E$10&"'!$A:$E"
:(
yohana
 
Mensajes: 66
Registrado: Mar Jun 30, 2009 2:42 pm

Re: Funcion INDIRECTO

Notapor mriosv » Jue Nov 19, 2009 11:49 pm

¿Que resultado da en excel la expresión ="'COEF."&$E$10&"'!$A:$E"?.
A mi en excel me da un error, también para
=SI($B21<>"";BUSCARV($B21;INDIRECTO("'COEF."&$E$10&"'!$A:$E");3;FALSO());"")
Puedes usar "Subir adjunto" en Respuesta rápida - Editor Completo - Pestaña Subir adjunto
Apache OpenOffice 4, LibreOffice 5 (Win10x64)
mriosv
 
Mensajes: 2233
Registrado: Sab Dic 27, 2008 1:12 am
Ubicación: Galiza (España)

Re: Funcion INDIRECTO

Notapor jose luis cuevas » Lun Nov 23, 2009 3:39 am

Hola que tal yohana:

Bueno pues revisando tu formula, te comento que en excel si puedes poner referencas solo con los nombres de las columnas:

=SI($B21<>"";BUSCARV($B21;INDIRECTO("'COEF."&$E$10&"'!$A:$E");3;FALSO());"")

Pero en calc, lo intenté y no se pudo, entonces lo que tienes hacer es ponerle las referencias completas y como dice mriosv tienes que cambiar el signo "!" por un punto ".":

=SI($B21<>"";BUSCARV($B21;INDIRECTO("'COEF."&$E$10&"'.$A1:$E60");3;FALSO());"")

Las referencias que te puse son variables, depende de cuantos datos tengas, en el ejemplo te puse del 1 al 60, pero le puedes cambiar.


Saludos

Jose Luis
Windows XP y openoffice 1.1.5 en en trabajo y 3.1 en la casa
jose luis cuevas
 
Mensajes: 17
Registrado: Mié Ago 12, 2009 1:05 pm

Re: Funcion INDIRECTO

Notapor yohana » Lun Nov 23, 2009 8:51 am

Muchas gracias Jose Luis parece que así funciona.

Saludos, Yohana
yohana
 
Mensajes: 66
Registrado: Mar Jun 30, 2009 2:42 pm


Volver a Calc

¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 6 invitados