fórmula

Discute sobre la aplicación de hojas de cálculo

fórmula

Notapor erncalcopof » Jue Dic 11, 2008 5:29 pm

estimados Señores OpenOffice.Org Calc.
Usando OpenOffice Calc 3.0, no he podido usar la función =POTENCIA(A1;1/3), PARA VALORES NEGATIVOS.
Me estoy refiriendo a potencias con exponente fraccionario, que es lo mismo que decir: raíz de índice impar, por ejemplo raíz cúbica.
en Microsoft Excel ésta función resulta, pero en OpenOffice Calc 3.0 no.
Que puede estar mal.
Saluda Atentamente
Juan Areyuna
Profesor Computación
adjunto archivo imagen formato jpg.-
Adjuntos
ScreenShot005.JPG
(250.3 KiB) 121 veces
Última edición por erncalcopof el Lun Dic 15, 2008 2:32 am, editado 2 veces en total
erncalcopof
 
Mensajes: 2
Registrado: Jue Dic 11, 2008 5:14 pm

Re: fórmula

Notapor Campbell » Dom Dic 14, 2008 9:08 pm

MIra yo tengo el OpenOffice.org 2.4 y además está en ingles...
pero supongo que no debe de haber diferencia...
si utilizo la formula POWER puedo calcular potencias, incluso negativas.
Campbell
 
Mensajes: 3
Registrado: Dom Dic 14, 2008 8:54 pm

Re: fórmula

Notapor erncalcopof » Lun Dic 15, 2008 2:41 am

Creo que el problema está el el código fuente de Calc.
Mientras tanto resolví el problema con la función =SI(;;)
Aquí está la función y el formato:
=SI(E6*F6<0;POTENCIA(-1*E6*F6;1/3);POTENCIA(E6*F6;1/3)) Raíz cúbica de un producto x*y<0
=SI(E6<0;-POTENCIA(-1*E6;1/3);POTENCIA(E6;1/3)) Raíz cúbica de x<0.-
erncalcopof
 
Mensajes: 2
Registrado: Jue Dic 11, 2008 5:14 pm

Re: fórmula

Notapor mriosv » Sab Dic 27, 2008 2:10 am

De acuerdo con la issue 37129, según las reglas de exponentes no se pueden usar pues exponentes equivalentes pueden conducir a resultados distintos

https://issues.apache.org/ooo/show_bug.cgi?id=37129
 Editado: (RGB-es) Corregido enlace al reporte 

Issue 37129
------- Additional comments from regina Thu Feb 22 22:29:35 +0000 2007 -------

Why do you want to change it? It is dangerous to calculate like (-8)^(1/3)=-2.
Look at this:
(-8)^(1/3)=(-8)^(2/6)=((-8)^2))^(1/6)=64^(1/6)=2

If you use fractions in exponents and want to keep the rules for exponents, than
you cannot allow negative base. And ^ and POWER calculate with exponents.

There are other opinions, but then you are speaking of a cube root, which would
be a new function in Calc.
Puedes usar "Subir adjunto" en Respuesta rápida - Editor Completo - Pestaña Subir adjunto
Apache OpenOffice 4, LibreOffice 5 (Win10x64)
mriosv
 
Mensajes: 2150
Registrado: Sab Dic 27, 2008 1:12 am
Ubicación: Galiza (España)


Volver a Calc

¿Quién está conectado?

Usuarios navegando por este Foro: Google [Bot] y 7 invitados