[RESUELTO] Problema: iconos personalizados

Desarrollo de Macros y programación en UNO, usar las API, llamar programas externos...

[RESUELTO] Problema: iconos personalizados

Notapor Ambrosio » Dom Oct 14, 2018 12:00 pm

Hola,

He creado una plantilla para Writer con macros y quiero crear una Barra de Herramientas con iconos a los que asocio mis macros.
He seguido las instrucciones del Writer y he creado "iconos" de 26x26 en formato "png"
Al personalizar mi barra de herramientas, importo los iconos y, al hacerlo se ven bien en mi barra de herramientas, pero después de guardar y cerrar, al volver a abrir el documento los iconos no se ven bien:
- algun icono que he cogido de los que ofrece el Writer se ven como una mancha pixelada
- los que he creado yo en png se ven recortados, sólo se ve la 1/4 parte superior izquierda del icono
- también he probado de hacer los iconos de 16x16 y el resultado es el mismo (se ve 1/4 parte)

Hay alguna explicación para que pase esto? Cómo se pueden incorporar iconos para una nueva barra de herramientas en Writer?

Nota: utilizo la versión 5.4.5.1 del Libre Office (la versión 6.02 me dio problemas de instalación)
Última edición por Ambrosio el Vie Nov 02, 2018 6:18 pm, editado 1 vez en total
windows 7 // LibreOffice_5.4.5_Win_x86
Ambrosio
 
Mensajes: 18
Registrado: Lun Abr 23, 2018 6:33 pm

Re: Problema: iconos personalizados

Notapor mriosv » Dom Oct 14, 2018 12:32 pm

Comprueba modificando la opción Menú/Herramientas/Opciones/LibreOffice/Ver - OpenGL.
Puedes usar "Subir adjunto" en Respuesta rápida - Editor Completo - Pestaña Subir adjunto
Apache OpenOffice 4, LibreOffice 5 (Win10x64)
mriosv
 
Mensajes: 2135
Registrado: Sab Dic 27, 2008 1:12 am
Ubicación: Galiza (España)

Re: Problema: iconos personalizados

Notapor Ambrosio » Vie Nov 02, 2018 6:18 pm

Hola,

Con OpenGl no conseguia tampoco que se vieran los iconos personalizados. Finalment prové con "iconos muy grandes".
Tuve que volver a seleccionar de nuevo mis iconos de 26x26 y ahora ya se ven en la barra deherramientas que había creado. Por contra, iconos de la barras de herramientas del programa Writer ahora no se ven, se ven los textos.
Bueno, al menos veo bien mi barra de herramientas que era lo que pretendía.

Gracias de todos modos,
windows 7 // LibreOffice_5.4.5_Win_x86
Ambrosio
 
Mensajes: 18
Registrado: Lun Abr 23, 2018 6:33 pm

Re: [RESUELTO] Problema: iconos personalizados

Notapor mriosv » Sab Nov 03, 2018 2:27 pm

Por favor añade un informe de error siguiendo las instrucciones en https://es.libreoffice.org/recibe-ayuda/sugerencias/
Puedes usar "Subir adjunto" en Respuesta rápida - Editor Completo - Pestaña Subir adjunto
Apache OpenOffice 4, LibreOffice 5 (Win10x64)
mriosv
 
Mensajes: 2135
Registrado: Sab Dic 27, 2008 1:12 am
Ubicación: Galiza (España)

Re: [RESUELTO] Problema: iconos personalizados

Notapor Ambrosio » Lun Nov 12, 2018 5:25 pm

A pesar de mi limitado inglés, me parece que he podido informar de las dificultades de incorporar iconos personalizados.
Gracias por sugerirmelo
windows 7 // LibreOffice_5.4.5_Win_x86
Ambrosio
 
Mensajes: 18
Registrado: Lun Abr 23, 2018 6:33 pm


Volver a Macros y API UNO

¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 24 invitados