Insertar una formula a una celda con sentencia Si

Desarrollo de Macros y programación en UNO, usar las API, llamar programas externos...

Insertar una formula a una celda con sentencia Si

Notapor JRAVLES » Lun Jun 19, 2017 9:09 pm

Buenas tardes,
Soy nuevo en Codigo de macros de OpenOffice. He llegado a insertar formulas sencillas en una celda mediante la sentencia setformula pero no he se como insertar una formula que contenga la sentencia si,
Mi idea es insertar mediante codigo en la celda A3 la formual =SI(H8<>"";TEXTO(H8;"aaaa-mm-dd");"") pero no me coge la formula, ¿alguien me puede echar un cable?

Gracias
LibreOffice 5.3.3.2
Windows 10
JRAVLES
 
Mensajes: 4
Registrado: Lun Jun 19, 2017 9:02 pm

Re: Insertar una formula a una celda con sentencia Si

Notapor mauricio » Lun Jun 19, 2017 10:11 pm

Hola...

Prueba con:
Código: Seleccionar todo   Expandir vistaContraer vista
   cell.Formula = "=IF(H8<>"""";TEXT(H8;""aaaa-mm-dd"");"""")"

Saludos
______________________________________________
"Todo cuanto no podemos dar nos posee". - André Gide
LibreOffice 6.2 | ArchLinux | Gnome3
No respondo preguntas privadas, por favor, usa el foro
Avatar de Usuario
mauricio
 
Mensajes: 5873
Registrado: Sab Nov 22, 2008 5:36 am
Ubicación: CDMX

Re: Insertar una formula a una celda con sentencia Si

Notapor JRAVLES » Lun Jun 19, 2017 10:14 pm

Ok,
Gracias
LibreOffice 5.3.3.2
Windows 10
JRAVLES
 
Mensajes: 4
Registrado: Lun Jun 19, 2017 9:02 pm

Re: Insertar una formula a una celda con sentencia Si

Notapor gustavodiaz00 » Sab Jul 15, 2017 3:53 am

Hola Proba con algo asi. Yo lo uso en una macro que me restaura las formulas de la planilla y funciona.

ThisComponent.Sheets(0).getCellByPosition(46,68).FormulaLocal = "=SI(IGUAL(E16;AT69); N16;BB79)+SI(IGUAL(E18;AT69); N18;BB79)+SI(IGUAL(E20;AT69); N20;BB79)+SI(IGUAL(E22;AT69); N22;BB79)+SI(IGUAL(E24;AT69); N24;BB79)+SI(IGUAL(E26;AT69); N26;BB79)+SI(IGUAL(E28;AT69); N28;BB79)+SI(IGUAL(E30;AT69); N30;BB79)+SI(IGUAL(E32;AT69); N32;BB79)+SI(IGUAL(E34;AT69); N34;BB79)+SI(IGUAL(E36;AT69); N36;BB79)+SI(IGUAL(E38;AT69); N38;BB79)+SI(IGUAL(E40;AT69); N40;BB79)+SI(IGUAL(E42;AT69); N42;BB79)+SI(IGUAL(E44;AT69); N44;BB79)+SI(IGUAL(E46;AT69); N46;BB79)+SI(IGUAL(E48;AT69); N48;BB79)+SI(IGUAL(E50;AT69); N50;BB79)+SI(IGUAL(E52;AT69); N52;BB79)+SI(IGUAL(E54;AT69); N54;BB79)+SI(IGUAL(E56;AT69); N56;BB79)+SI(IGUAL(E58;AT69); N58;BB79)+SI(IGUAL(E60;AT69); N60;BB79)"

Espero que te sirva.
LibreOffice 6.1 en KDE Neon
Avatar de Usuario
gustavodiaz00
 
Mensajes: 52
Registrado: Mié Abr 26, 2017 1:29 am
Ubicación: Argentina, San Nicolás de los Arroyos


Volver a Macros y API UNO

¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 3 invitados