[RESUELTO] Información del sistema

Desarrollo de Macros y programación en UNO, usar las API, llamar programas externos...

[RESUELTO] Información del sistema

Notapor mauricio » Vie Ene 08, 2016 7:23 pm

Hola a todos...

Si fueran tan amables de ayudarme a conocer un poco mejor el ecosistema de los usuarios de estos foros, me harían muy feliz. Para esto, solo tienen que abrir el archivo anexo y copiar y pegar el resultado en su respuesta. Aquí lo que obtengo en mi equipo:
Código: Seleccionar todo   Expandir vistaContraer vista
Sistema: Linux-4.2.5-1-ARCH-x86_64-with-arch

LibreOffice 4.4

Python: 3.5.1 (default, Dec  7 2015, 12:58:09)
[GCC 5.2.0]

/usr/lib/libreoffice/program
/usr/lib/python35.zip
/usr/lib/python3.5
/usr/lib/python3.5/plat-linux
/usr/lib/python3.5/lib-dynload
/usr/lib/python3.5/site-packages
/usr/lib/libreoffice/program

Con AOO obtengo:
Código: Seleccionar todo   Expandir vistaContraer vista
Sistema: Linux-4.2.5-1-ARCH-x86_64-with-glibc2.3.4

OpenOffice 4.1.2

Python: 2.7.6 (default, Oct 21 2015, 10:02:54)
[GCC 4.1.2 20080704 (Red Hat 4.1.2-55)]

/opt/openoffice4/program/python-core-2.7.6/lib
/opt/openoffice4/program/python-core-2.7.6/lib/lib-dynload
/opt/openoffice4/program/python-core-2.7.6/lib/lib-tk
/opt/openoffice4/program/python-core-2.7.6/lib/site-packages
/opt/openoffice4/program
/home/mau
/opt/openoffice4/program/python-core-2.7.6/lib/python27.zip
/opt/openoffice4/program/python-core-2.7.6/lib/python2.7
/opt/openoffice4/program/python-core-2.7.6/lib/python2.7/plat-linux2
/opt/openoffice4/program/python-core-2.7.6/lib/python2.7/lib-tk
/opt/openoffice4/program/python-core-2.7.6/lib/python2.7/lib-old
/opt/openoffice4/program/python-core-2.7.6/lib/python2.7/lib-dynload

Un abrazo y gracias por adelantado.
Adjuntos
Obtener Informacion.odt
(9.26 KiB) 129 veces
______________________________________________
"Todo cuanto no podemos dar nos posee". - André Gide
AOO 4.1 | LibO 6.1.5 | ArchLinux | Gnome3
No respondo preguntas privadas, por favor, usa el foro
Avatar de Usuario
mauricio
 
Mensajes: 5792
Registrado: Sab Nov 22, 2008 5:36 am
Ubicación: México, D.F.

Re: Información del sistema

Notapor RMG » Vie Ene 08, 2016 7:36 pm

Hola Mauricio, esto sale.

Código: Seleccionar todo   Expandir vistaContraer vista
Sistema: Windows-8-6.2.9200

OpenOffice 4.1.2

Python: 2.7.6 (default, Oct 21 2015, 09:27:24) [MSC v.1500 32 bit (Intel)]

C:\Program Files (x86)\OpenOffice 4\program\python-core-2.7.6\lib
C:\Program Files (x86)\OpenOffice 4\program\python-core-2.7.6\lib\site-packages
C:\Program Files (x86)\OpenOffice 4\program
C:\Program Files (x86)\OpenOffice 4\program\python27.zip
C:\Program Files (x86)\OpenOffice 4\program\python-core-2.7.6\DLLs
C:\Program Files (x86)\OpenOffice 4\program\python-core-2.7.6\lib\plat-win
C:\Program Files (x86)\OpenOffice 4\program\python-core-2.7.6\lib\lib-tk
C:\Program Files (x86)\OpenOffice 4\program\python-core-2.7.6
OpenOffice 4.1.6 y LibreOffice 5.4.5.1 en W-10, y LibreOffice 4.1.6.2 en Open Suse 13.1(VirtualBox)
RMG
 
Mensajes: 3496
Registrado: Mar Nov 17, 2009 6:59 am
Ubicación: Valencia - España

Re: Información del sistema

Notapor SLV-es » Vie Ene 08, 2016 8:49 pm

Me sale justo lo mismo que a RMG
+info en la web "no oficial" dedicada a OpenOffice en Español
AOO 4.1.2 y LibO 4.4.6 en W10 y en Lliurex
No respondo mensajes privados sobre AOO, por favor, utiliza el foro para tus preguntas
Avatar de Usuario
SLV-es
 
Mensajes: 4894
Registrado: Jue Ago 26, 2010 1:25 am
Ubicación: España

Re: Información del sistema

Notapor RASAPA » Vie Ene 08, 2016 10:56 pm

Buenos dias a todos,

Con un ordenador recien estrenado (lo han traido los Reyes, je, je, je....) :lol: :lol: en Linux Mint 17.3 Rosa

Saludos.


Código: Seleccionar todo   Expandir vistaContraer vista
Sistema: Linux-3.19.0-32-generic-x86_64-with-LinuxMint-17.3-rosa

LibreOffice 5.0

Python: 3.4.3 (default, Oct 14 2015, 20:31:36)
[GCC 4.8.4]

/usr/lib/libreoffice/program
/home/ramon
/usr/lib/python3.4
/usr/lib/python3.4/plat-x86_64-linux-gnu
/usr/lib/python3.4/lib-dynload
/usr/local/lib/python3.4/dist-packages
/usr/lib/python3/dist-packages
/usr/lib/libreoffice/program
LibreOffice 5.2.6.2
Linux Mint 17.3
RASAPA
 
Mensajes: 222
Registrado: Mar Mar 16, 2010 10:41 pm

Re: Información del sistema

Notapor fornelasa » Vie Ene 08, 2016 11:15 pm

Yo obtengo estos datos (pc de mi trabajo):
Sistema: Windows-7-6.1.7100

OpenOffice 4.1.2

Python: 2.7.6 (default, Oct 21 2015, 09:27:24) [MSC v.1500 32 bit (Intel)]

C:\Program Files\OpenOffice 4\program\python-core-2.7.6\lib
C:\Program Files\OpenOffice 4\program\python-core-2.7.6\lib\site-packages
C:\Program Files\OpenOffice 4\program
C:\Program Files\OpenOffice 4\program\python27.zip
C:\Program Files\OpenOffice 4\program\python-core-2.7.6\DLLs
C:\Program Files\OpenOffice 4\program\python-core-2.7.6\lib\plat-win
C:\Program Files\OpenOffice 4\program\python-core-2.7.6\lib\lib-tk
C:\Program Files\OpenOffice 4\program\python-core-2.7.6


'------------------------------------------------------------------------------------------------------------------
Sistema: Windows-7-6.1.7100

LibreOffice 4.4

Python: 3.3.5 (default, Nov 27 2015, 17:55:27) [MSC v.1700 32 bit (Intel)]

C:\Program Files\LibreOffice 4\program\python-core-3.3.3\lib
C:\Program Files\LibreOffice 4\program\python-core-3.3.3\lib\site-packages
C:\Program Files\LibreOffice 4\program
C:\Program Files\LibreOffice 4\program\python33.zip
C:\Program Files\LibreOffice 4\program\python-core-3.3.3\DLLs
C:\Program Files\LibreOffice 4\program\python-core-3.3.3


Saludos.
lo 6.1.2 | aoo 4.1.6 | win 7/10
¡Un aplauso para todos los que luchan por proteger y promover la Web abierta!
Avatar de Usuario
fornelasa
 
Mensajes: 3181
Registrado: Jue Feb 17, 2011 8:30 pm
Ubicación: Estado de México, México.

Re: Información del sistema

Notapor fornelasa » Vie Ene 08, 2016 11:33 pm

Con respecto a mi mensaje anterior, lo más chistoso es que no tengo instalado Python: 3.3.5 en la maquina de mi "chamba".
Tal vez alguna vez lo instalé y despues lo borré y se quedarón residuos del programa.
El que si tengo instalado es el Python: 2.7.6

Saludos, Federico.
Última edición por fornelasa el Vie Ene 08, 2016 11:35 pm, editado 1 vez en total
lo 6.1.2 | aoo 4.1.6 | win 7/10
¡Un aplauso para todos los que luchan por proteger y promover la Web abierta!
Avatar de Usuario
fornelasa
 
Mensajes: 3181
Registrado: Jue Feb 17, 2011 8:30 pm
Ubicación: Estado de México, México.

Re: Información del sistema

Notapor mauricio » Vie Ene 08, 2016 11:35 pm

Gracias a todos por sus pruebas...

No, el python que ves ahí, es el que incorpora LibreOffice, se ve claramente en las rutas, en Windows, por ahora, siempre toma el python del programa, aunque lo tuvieras instalado no "lo vería"...

Saludos
______________________________________________
"Todo cuanto no podemos dar nos posee". - André Gide
AOO 4.1 | LibO 6.1.5 | ArchLinux | Gnome3
No respondo preguntas privadas, por favor, usa el foro
Avatar de Usuario
mauricio
 
Mensajes: 5792
Registrado: Sab Nov 22, 2008 5:36 am
Ubicación: México, D.F.

Re: Información del sistema

Notapor fornelasa » Vie Ene 08, 2016 11:36 pm

¡ahhhhhh! :o ok bien.
 Editado: En realidad el que tengo instalado es el Python: 2.7.11 

Mi no entender .... en fin.
Saludos; federico.
lo 6.1.2 | aoo 4.1.6 | win 7/10
¡Un aplauso para todos los que luchan por proteger y promover la Web abierta!
Avatar de Usuario
fornelasa
 
Mensajes: 3181
Registrado: Jue Feb 17, 2011 8:30 pm
Ubicación: Estado de México, México.

Re: Información del sistema

Notapor RMG » Sab Ene 09, 2016 7:13 pm

Otro.

Código: Seleccionar todo   Expandir vistaContraer vista
Sistema: Windows-8-6.2.9200

LibreOffice 4.2

Python: 3.3.3 (default, Oct 16 2014, 05:25:01) [MSC v.1600 32 bit (Intel)]

C:\Program Files (x86)\LibreOffice 4\program\python-core-3.3.3\lib
C:\Program Files (x86)\LibreOffice 4\program\python-core-3.3.3\lib\site-packages
C:\Program Files (x86)\LibreOffice 4\program
C:\Program Files (x86)\LibreOffice 4\program\python33.zip
C:\Program Files (x86)\LibreOffice 4\program\python-core-3.3.3\DLLs
C:\Program Files (x86)\LibreOffice 4\program\python-core-3.3.3
C:\Program Files (x86)\LibreOffice 4\share\extensions\dict-en\pythonpath
OpenOffice 4.1.6 y LibreOffice 5.4.5.1 en W-10, y LibreOffice 4.1.6.2 en Open Suse 13.1(VirtualBox)
RMG
 
Mensajes: 3496
Registrado: Mar Nov 17, 2009 6:59 am
Ubicación: Valencia - España

Re: Información del sistema

Notapor xiseme » Dom Ene 10, 2016 4:36 pm

Más vale tarde que nunca :mrgreen: :oops:
Código: Seleccionar todo   Expandir vistaContraer vista
Sistema: Linux-4.3.3-5-default-x86_64-with-SuSE-20160108-x86_64

LibreOffice 5.0

Python: 3.4.3 (default, Mar 27 2015, 02:30:53) [GCC]

/usr/lib64/libreoffice/program
/usr/lib/python34.zip
/usr/lib64/python3.4
/usr/lib64/python3.4/plat-linux
/usr/lib64/python3.4/lib-dynload
/usr/lib64/python3.4/site-packages
/usr/lib64/python3.4/_import_failed
/usr/lib/python3.4/site-packages
/usr/lib64/libreoffice/program
_____   _____   _____   _____   _____   _____   _____   _____

en el mismo sistema (openSUSE-TW)
~> python -V
Python 2.7.10


AOO412m3(Build:9782)  -  Rev. 1709696 2015-10-21 09:51 - Linux x86_64
Ruta de instalación: /opt/openoffice4/

Se ha producido un error de macro de programación al ejecutar el comando mismacros.py$info escrito en Python.

Mensaje: El lenguaje de script Python no es compatible con este programa.

____________________________________________________________

Sistema: Linux-3.18.25-1-MANJARO-x86_64-with-glibc2.3.4

LibreOffice 5.0

Python: 3.5.1 (default, Dec  7 2015, 12:58:09)
[GCC 5.2.0]

/usr/lib/libreoffice/program
/usr/lib/python35.zip
/usr/lib/python3.5
/usr/lib/python3.5/plat-linux
/usr/lib/python3.5/lib-dynload
/usr/lib/python3.5/site-packages
/usr/lib/libreoffice/program

____________________________________________________________

Sistema: Linux-4.2.6-1-x86_64-with-glibc2.3.4

LibreOffice 5.0

Python: 3.5.1 (default, Dec 7 2015, 16:46:03)
[GCC 4.9.3]

/usr/lib/libreoffice/program
/home/xkaos/Descargas
/usr/lib/python35.zip
/usr/lib/python3.5
/usr/lib/python3.5/plat-linux
/usr/lib/python3.5/lib-dynload
/usr/lib/python3.5/site-packages

____________________________________________________________

elementaryOS
Se produjo un error de entorno al ejecutar la secuencia de órdenes mismacros.py$info escrita en Python.

Mensaje: El lenguaje de script Python no es compatible.
Todo es mejorable, estamos dispuestos a mejorar. ¿Yo? ... poco a poco.
Nunca hay acritud en mis comentarios, si lo pareciera, seguro que me he expresado mal.
xiseme
 
Mensajes: 1888
Registrado: Lun Nov 24, 2008 1:13 pm

Re: Información del sistema

Notapor mauricio » Lun Ene 11, 2016 6:02 am

Donde te da error, es probable que no tengas instalado el soporte para macros python...

Gracias por sus pruebas e información...
______________________________________________
"Todo cuanto no podemos dar nos posee". - André Gide
AOO 4.1 | LibO 6.1.5 | ArchLinux | Gnome3
No respondo preguntas privadas, por favor, usa el foro
Avatar de Usuario
mauricio
 
Mensajes: 5792
Registrado: Sab Nov 22, 2008 5:36 am
Ubicación: México, D.F.

Re: [RESUELTO] Información del sistema

Notapor Rdp.jodra » Vie Sep 08, 2017 4:05 pm

Sistema: Linux-4.4.0-93-generic-x86_64-with-Ubuntu-16.04-xenial

LibreOffice 5.1

Python: 3.5.2 (default, Nov 17 2016, 17:05:23)
[GCC 5.4.0 20160609]

/usr/lib/libreoffice/program
/home/ruben/Descargas
/usr/lib/python35.zip
/usr/lib/python3.5
/usr/lib/python3.5/plat-x86_64-linux-gnu
/usr/lib/python3.5/lib-dynload
/usr/local/lib/python3.5/dist-packages
/usr/lib/python3/dist-packages
/usr/lib/libreoffice/program
Libreoffice 5 Ubuntu 16.04 y Bodhi 2.3
Rdp.jodra
 
Mensajes: 12
Registrado: Dom Mar 02, 2014 8:34 am


Volver a Macros y API UNO

¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 1 invitado