Página 1 de 1

Macros en boton no funcionan en modo presentación

NotaPublicado: Vie Nov 27, 2015 12:41 pm
por culebrasx
Hola,
he creado dos botones que muestran una imagen con el acontecimiento "ratón dentro" y con el acontecimiento "ratón fuera" ejecutan una macro que esconde las imagenes.
el caso es que cuando estoy editando las paginas, si que funciona como yo espero; pero cuando lo pongo en modo presentación no funcionan los botones, o las macros, no lo sé, el resultado es que no se produce el efecto de mostrar la imagen.

Tengo el nivel de seguridad de las macros en 'bajo', y el puntero del ratón visible en la configuración de la presentación, no se si tengo que hacer algo más, o añadir algo especial en el codigo para que funciones en modo presentación,
este el cógido que muestra la imagen
Código: Seleccionar todo   Expandir vistaContraer vista
Sub muestra_barras
Dim Doc As Object
Dim Page As Object
dim ob AS object

Doc = ThisComponent
Page = Doc.DrawPages.getByName("seguridades_2")
PAge.GetLinks.GetByName("barras").Visible = true
PAge.GetLinks.GetByName("bumper").Visible = false
End Sub


muchas gracias a todos/as por sus sabios consejos... ;)

Re: Macros en boton no funcionan en modo presentación

NotaPublicado: Vie Nov 27, 2015 6:46 pm
por fornelasa
Mira en este archivo/ejemplo y pulsa la carita :mrgreen:
Miremos como la macro aqui si funciona en modo presentación.
Parece que en este modo Impress no permite modificar con macros imagenes/Dibujos/Objetos.
Desafortunadamente hay poca lectura o información al respecto para conocer este programa más a fondo.
Creo que todos sabemos que Impress no es el "hijo consentido" de la suite AOO como lo es Calc, tal vez por eso a Impress le falte mejorar en algunas cosas.

Ojala alguien más de la comunidad nos de luz al respecto

Tambien parece que aqui https://forum.openoffice.org/en/forum/v ... 0&p=249564 hubo el mismo inconveniente pero no se alcanza a ver como se resolvió (en caso de que haya sido resuelto).

Saludos, Federico.

Re: Macros en boton no funcionan en modo presentación

NotaPublicado: Sab Nov 28, 2015 7:31 pm
por culebrasx
:? :? :? ...
ok, la verdad es que es una lastima,
bueno, sigo leyendo y aprendiendo mucho de toda la comunidad,
gracias de nuevo por sus consejos!!! :super: :super: :bravo: :bravo: