[RESUELTO]base de datos anda lentisimo / problema de instala

Discute sobre las herramientas de la base de datos

[RESUELTO]base de datos anda lentisimo / problema de instala

Notapor winniem » Mar Ene 11, 2011 1:11 pm

Hola,

estaba averiguando en otros foros ya, hasta ahora no me han dado ninguna respuesta útil:

Mi base de datos anda lentisimo - en mi ordenador (y en varios otros también, pero no en todos). Es que lleva varias tablas, una de ellas un poco grande pero nada realmente dificil.
La primera vez que la trabajaba salio todo bien, la segunda ya no - abre muy lento, así que no es posible trabajarla más. He intentado varias cosas, incluso reinstalar no solo open-office.org-base sino también open-office.org en total hasta reinstalar mi ordenador entero. Es que creo que es un problema de la instalacion porque en un ordenador de un compañero anda bien. Ahora creo más que antes que a lo mejor es un problema de la combinación con java, en otro foro se hablaba de la importancia de instalar uno tras otro -
pero bueno, ya me gustaría bastante trabajar en la base misma - de hecho es profesionalmente importante resolver esto cuanto antes. Agredecería mucho cualquier aviso de apoyo -

winniem :knock:

Editado por el administrador (RGB-es): el ícono de la llama sirve para identificar temas con enlaces a reportes de error. Si no lo has hecho aún por favor lee la Guía de supervivencia
Última edición por RGB-es el Vie Ene 21, 2011 1:25 am, editado 1 vez en total
Razón: Marcar como resuelto
OpenOffice 3.2.1 en Ubuntu 10.04
winniem
 
Mensajes: 3
Registrado: Mar Ene 11, 2011 12:41 pm

Re: base de datos anda lentisimo / problema de instalacion?

Notapor aventis » Mar Ene 11, 2011 2:22 pm

Pues si en el ordenador de un compañero anda bien, está claro que el problema está en tu ordenador, seguramente en la instalación. No es un problema de las tablas.

Desinstala, reinicia y usa un limpiador del registro. Después bájate e instala la última versión, que si es un bug, seguramente se habrá corregido.
OpenOffice 3.2 - Windows XP.
Avatar de Usuario
aventis
 
Mensajes: 74
Registrado: Vie Nov 12, 2010 8:10 pm

Re: base de datos anda lentisimo / problema de instalacion?

Notapor winniem » Mar Ene 11, 2011 5:08 pm

Hola,

gracias por la respuesta.

¿Qué es un limpiador del registro? ¿Dónde lo consigo?

¿Dónde consigo la última version de Openoffice (-base)? Porque he intentado reinstallar a través de los paquetes normales de Ubuntu ya...


Saludos,
winniem
OpenOffice 3.2.1 en Ubuntu 10.04
winniem
 
Mensajes: 3
Registrado: Mar Ene 11, 2011 12:41 pm

Re: base de datos anda lentisimo / problema de instalacion?

Notapor RGB-es » Mar Ene 11, 2011 6:01 pm

El registro es algo de windoze, por lo que no lo necesitas... ;)
Puedes probar a reiniciar el perfil de usuario siguiendo la tercer entrada de esta guía: el perfil de usuario de OOo
La versión de OOo que viene en ubuntu está bastante modificada, agregando algunas características extra pero también muchos errores propios. Te recomiendo instalar la versión oficial. Para saber cómo reemplazar la versión de OOo, mira ésta guía: Instalando la versión «oficial» de OOo en Linux
No respondo mensajes privados sobre AOO, por favor, utilice el foro para sus preguntas

AOO/LibO en openSUSE con escritorio Plasma
---
Existen dos clases de personas: las que dicen que existen dos clases de personas y las que no.
Avatar de Usuario
RGB-es
 
Mensajes: 4738
Registrado: Lun Nov 24, 2008 10:46 am

Re: base de datos anda lentisimo / problema de instalacion?

Notapor Cascabel » Jue Ene 13, 2011 7:38 pm

Tengo el mismo problema en Ubuntu 10.10 desde que lo instalé en un HDD de 250GB. Antes lo tenía en uno de 20GB y marchaba bien. Quité la versión de OOo que venía con la distro e instalé la oficial (3.3-rc8) en ambos casos, pero va muy lento. Si encuentro solución, comentaré.
OOo 3.3.0: OOO330m20 (Build:9567) en WXP+SP3 y en Ubuntu 10.10
Cascabel
 
Mensajes: 283
Registrado: Mié Nov 11, 2009 10:53 am

Re: base de datos anda lentisimo / problema de instalacion?

Notapor winniem » Jue Ene 20, 2011 7:37 pm

Hola,

estoy contento: después de dos meses encontraba la solución - :D
gracias a los enlaces siguientes:

http://ubuntuforums.org/showthread.php?t=1642858

http://www.unixmen.com/linux-distributions/4-ubuntu/1266-how-to-install-latest-java-version-in-ubuntu-1010-maverick-meerkat-via-ppa.

Es un problema de Java, ya lo sospechaba, pero después de haber instalado de nuevo (quiero comentar: es bastante difícil conseguir paquetes de openoffice, descargas lentisimos y no es posible obtener versiones anteriores) en realidad no había otro remedio que seguir buscanda. Y encontraba la solución en el gran Ubuntuforo en inglés.

Bueno, son los siguientes pasos:

1. Activar canonical partners en Orígenes de Software.
2. Abrir un terminal, teclar:
Código: Seleccionar todo   Expandir vistaContraer vista
sudo apt-get install sun-java6-jre sun-java6-plugin

3. Teclar:
Código: Seleccionar todo   Expandir vistaContraer vista
sudo update-alternatives --config java

4. Elegir la versión JRE.
5. Abrir Openoffice, ir a Herramientas/Opciones/Java, donde hay dos versiones: 1.6.0_22 y 1.6.0_20. Eligir 1.6.0_22.
6. Cerrar Openoffice.
7. Abrirlo de nuevo - tendría que andar bien la base de datos.


Bueno, aprovecho el momento para expresar mi respeto a este foro que segùn mi experiencia ofrece muy buena atención. En otros foros de openoffice tu ves un montón de preguntas pero casí ninguna respuesta.
Gracias a vosotr@s.
OpenOffice 3.2.1 en Ubuntu 10.04
winniem
 
Mensajes: 3
Registrado: Mar Ene 11, 2011 12:41 pm

Re: [RESUELTO]base de datos anda lentisimo / problema de ins

Notapor Cascabel » Sab Ene 22, 2011 10:03 pm

Gracias, winniem. Tu solución me resolvió todo.
OOo 3.3.0: OOO330m20 (Build:9567) en WXP+SP3 y en Ubuntu 10.10
Cascabel
 
Mensajes: 283
Registrado: Mié Nov 11, 2009 10:53 am

Re: [RESUELTO]base de datos anda lentisimo / problema de ins

Notapor Pepe Wasquez » Jue Mar 03, 2011 6:13 pm

Gracias a todos por la solucion, era uno de los que tenia problemas debido a la lentitud de las consultas y las tablas,uso ubuntu 10.10, OpenOffice.org 3.2.1
OOO320m19 (Build:9505) ooo-build 3.2.1.4, Ubuntu package 1:3.2.1-7ubuntu1.1 y la version de java era 1.6.0_20 que al actualizar pasaba directamente a la version _24 y con ambas tenia problemas de lentitud, por eso, lo que he tenido que hacer es descargar la version _22 de java (que es por lo visto con la unica que funciona correctamente)
http://cds.sun.com/is-bin/INTERSHOP.enf ... x-i586.bin
e instalarla siguiendo estas instrucciones
http://www.oracle.com/technetwork/java/ ... 42296.html
y luego elegir esta version en herramientas -->opciones --> java
Ahora funciona perfecto.
Un saludo
OpenOffice 3.2
Linux Ubuntu 10.10
Pepe Wasquez
 
Mensajes: 10
Registrado: Dom Ene 30, 2011 1:59 pm

Re: [RESUELTO]base de datos anda lentisimo / problema de ins

Notapor deserve » Jue Mar 10, 2011 10:20 pm

Hola Pepe,

Me pasa lo mismo que a ti pero tu primer vínculo no me deja descargar. Dice:
-Download limit reached for Java SE Runtime Environment 6u22. 03/10/11 13:16:18 PST. See Download FAQs.

Sabes si se puede descargar de algún otro sitio o si estará disponible más adelante?

Muchas gracias.
DESERVE
OppenOffice.org 3.2.0
Ubuntu 10.10 (maverick)
deserve
 
Mensajes: 11
Registrado: Lun Abr 12, 2010 10:37 am

Re: [RESUELTO]base de datos anda lentisimo / problema de ins

Notapor Néstor Londoño B. » Mié Mar 16, 2011 2:52 am

Saludos a todos: Yo también estaba esperando una buena solución, muchas gracias.
Entré en: http://cds.sun.com/is-bin/INTERSHOP.enf ... x-i586.bin
y con solo llenar los dos campos superiores del SO y el acuerdo con la licencia me llevó a la siguiente página de descarga y bajé el archivo en ~Descargas. Para instalarlo en /usr/lib/jvm, se instala primero en el lugar donde se baja, en mi caso:
1 - abro el terminal y escribo cd ~/Descargas [Enter]
2 - Le doy al archivo bin permiso de instalación: sudo chmod +x jre-6u22-linux-i586.bin
3 - sudo ./jre-6u22-linux-i586.bin [Enter] Le solicita su contraseña
queda instalado en Descargas, ahora como el archivo original de Java jre estaba en /usr/lib y quiero instalarlo ahí mismo (no es necesario también se puede seleccionar desde Descargas)
4 - escribo en el terminal cd [Enter]
5 - Anula direcciones antes escritas y le doy la nueva dirección: /usr/lib [Enter]
6 - Le doy a la carpeta jvm las propiedades de Propietario Root escribo en la terminal: sudo chmod a+wx jvm [Enter]
7 - Ya no vamos a usar mas la terminal, podemos cerrarla. Vamos a lugares y pulsamos Descargas para que se despliegue el contenido a la derecha. En el lado izquierdo pulsamos el tringulito negro frente Sistema de archivos y repetimos con usr, lib, ahora sin pulsar ningún archivo buscamos el jvm. Con el ratón agarramos la CARPETA jre1.6.0_22, que habíamos abierto inicialmente a la derecha y la soltamos en jvm.
8 - Abrimos ya sea una hoja de texto, de Calc o BD y en Herramientas Opciones Java escogemos jre1.6.0_22 y con esto damos por terminada la instalación.
Espero que mi nota sea tomada como una nota aclaratoria del proceso y no como una intromisión.
Néstor
S,O. Ubuntu 15 AOO_4.0.1
Néstor Londoño B.
 
Mensajes: 261
Registrado: Lun Dic 01, 2008 7:59 am
Ubicación: Pereira, Colombia

Re: [RESUELTO]base de datos anda lentisimo / problema de ins

Notapor deserve » Mié Mar 16, 2011 9:57 am

Muchas gracias Néstor,

Mi problema era que los de Oracle habían bloqueado la descarga (decía límite de descargas alcanzado o algo así). Ahora funciona otra vez, así que he instalado la versión 22 y todo solucionado.

Muchas gracias a todos!!!

Deserve
DESERVE
OppenOffice.org 3.2.0
Ubuntu 10.10 (maverick)
deserve
 
Mensajes: 11
Registrado: Lun Abr 12, 2010 10:37 am


Volver a Base

¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 2 invitados