Página 1 de 1

problema con exportación blob

NotaPublicado: Dom Nov 22, 2020 11:53 am
por James07
Hola. Tengo un problema de exportación de datos seleccionados en una tabla de base. En concreto uno de los campos tiene formato BLOB porque tiene como contenido archivos PDF. Esta tabla funciona correctamente pero cuando selecciono algunas filas para exportarlas a otra tabla (que es exactamente igual solo que sin datos) me indica el siguiente error

nPosition out of range
com.sun.star.lang.IllegalArgumentException

Se que el problema es con este campo porque cuando exporto sin marcar éste, todo va correctamente y se anexan los datos sin dificultad.
Espero vuestras ideas. :D
un saludo

Re: problema con exportación blob

NotaPublicado: Dom Nov 22, 2020 11:07 pm
por Longi
Buenas!
Por la firma supongo que está mal y estás trabajando con Libreoffice..
Por el tipo de campo (Blob) dedes estar trabajando con firebird como motor.
Con firebird no tengo experiencia, y no describes el 'método' que usas... . Un ejemplo sin datos comprometedores sería de ayuda.

Un saludo! ;)

Re: problema con exportación blob

NotaPublicado: Lun Nov 23, 2020 8:13 pm
por James07
Hola de nuevo. gracias por tu respuesta. En relación a lo que me indicas, el método utilizado es selección de las filas que me interesan de una tabla de origen y copiar en la de destino. Se activa por defecto, cuando le doy a pegar en la de destino, el protocolo de copia de base de datos con correspondencia entre los campos, le doy ok porque el nombre y configuración de los de origen y destino son iguales e inmediatamente salta el aviso que te copié antes.
En relación al programa, efectivamente trabajo en libreoffice 6.4.2
Un saludo