Página 1 de 1

[RESUELTO] Asistente de control de tablas inexistente

NotaPublicado: Lun May 09, 2016 5:49 pm
por joaquinlop
Buenas tardes de nuevo:

En mis esfuerzos por ir soltándome en el manejo de formularios y subformularios, encuentro una nueva (e inexplicable para mí) duda:
¿Por qué no se activa el asistente del control de tablas al seleccionar esa opción para un segundo o tercer subformulario? He creado en mi base de datos cuatro tablas que se relacionan en cascada en relación 1:n. A partir de esa relación intento generar un formulario que incluya subformularios también en cascada, mediante control de tablas. He comprobado que las claves, los campos, los vínculos y las actualizaciones sean correctas desde el navegador de formulario, y que cada control de tablas esté en su lugar jerárquico correspondiente. Asimismo, he comprobado que por medio de otros controles (campos formateados), los datos aparezcan al estar relacionados. Sin embargo, al seleccionar la opción de control de tablas, que es la que me interesa, a partir del segundo subformulario (es decir, a partir del primer subformulario) ni se me activa el asistente, ni al desactivar el botón de diseño se muestra nada, tan sólo la tabla en blanco.

¿Qué estoy haciendo mal? ¿Es posible que sea algún fallo del propio libreoffice? Mi versión es la 5.0.4.2 para Linux Mint 17.

Re: Asistente de control de tablas inexistente

NotaPublicado: Mar May 10, 2016 7:31 pm
por Longi
Buenas!
¿Sería posible un ejemplo sin datos comprometedores para ir probando?

Un saludo!

Re: Asistente de control de tablas inexistente

NotaPublicado: Mar May 10, 2016 9:38 pm
por joaquinlop
De acuerdo, Longi:

Te envío un adjunto con las tablas y la relación mencionada. Quité en la tabla de "tareas" unos registro previos que salieron mal (es por eso que comienzan por el número 6), y tengo que forzar la salida de base para cerrar la tabla (no se si eso puede tener que ver también) porque siempre se me bloquea. Muchas gracias por contestar.

Re: Asistente de control de tablas inexistente

NotaPublicado: Mié May 11, 2016 8:56 pm
por Longi
Buenas!

Veo en tu firma 'LibreOffice 3.5'. Considerando que hay versiones más modernosas, lo normal es que estés funcionando con LibreOffice5, que desafortunadamente tiene un bug con los controles de tabla, y no te los deja diseñar. Así, cuando en formato diseño seleccionas un control de tabla, te lo selecciona completo, y no te deja variar nada en su interior (añadir o quitar columnas, editar columnas, etc), así que si no le pusiste las columnas adecuadas al principio, no podrás hacerlo, a excepción de que te descargues el Openoffice, abras tu base de datos con él y remates el diseño deseado. Después podrás trabajar en Libre sin más problemas.
Por lo demás todo parece funcionar correctamente si introduces datos desde los controles de tabla.

Un saludo!

Re: [RESUELTO] Asistente de control de tablas inexistente

NotaPublicado: Vie May 13, 2016 3:54 pm
por joaquinlop
Efectivamente, he comprobado que no ocurre con Openoffice; LibreOffice tiene un problema importante con su bug que tendrá que corregir en el futuro.

Re: [RESUELTO] Asistente de control de tablas inexistente

NotaPublicado: Jue May 19, 2016 6:56 am
por Longi
Buenas!

En la últma versión recién salida de LibreOffice parece que ya funciona bien.

Otro saludo!