Página 1 de 1

Cálculo de la letra de un DNI

NotaPublicado: Dom Mar 11, 2012 11:09 pm
por Kirilenko
Buenas noches amigos; os comento el problema:

Tengo que calcular la letra asociada a un DNI, será necesario utilizar la función BUSCARV para localizar el RESIDUO de dividir el número
del DNI entre 23, y localizar el resultado en la tabla de la equivalencia. Cuando no se introduzca ningún DNI el resultado de dicha función
sera NADA.

Gracias por adelantado.


Saludos.

Re: Cálculo de la letra de un DNI

NotaPublicado: Lun Mar 12, 2012 12:08 am
por mauricio

Re: Cálculo de la letra de un DNI

NotaPublicado: Lun Mar 12, 2012 1:24 am
por Kirilenko
Buenas noches, Mauricio. No me sirve para la hoja de cálculo, "esas líneas son para BASIC".
Lo que tengo que hacer se hace desde las celdas con (funciones, que describí arriba: BUSCARV) .
También realizar una división, dividir el número entre 23, localizar el resultado en la tabla, y para finalizar
dicha función será nada. Todo lo descrito desde las celdas, lo otro no me sirve.

Gracias por contestar.

Saludos.

Re: Cálculo de la letra de un DNI

NotaPublicado: Lun Mar 12, 2012 3:04 am
por xiseme
Si el número a evaluar está en A1, el equivalente en una celda es ...
=MID("TRWAGMYFPDXBNJZSQVHLCKE";1+RESIDUO(A1;23);1)

BUSCARV, Tablas .¿? . :shock: . si es como ejercicio conceptual hay que "complicarlo", busca el residuo de dividir entre 23 en una tabla de dos columnas que serian de [0]1 a 23 correspondiéndose con T,R,W ... F.

Edito:
=SI(A1="";"NADA";MID("TRWAGMYFPDXBNJZSQVHLCKE";1+RESIDUO(A1;23);1))

Re: Cálculo de la letra de un DNI

NotaPublicado: Lun Mar 12, 2012 8:00 pm
por mauricio
Pues mira que si sirve...
LetraNIF.ods
(9.07 KiB) 547 veces

Re: Cálculo de la letra de un DNI

NotaPublicado: Mar Mar 13, 2012 1:57 am
por xiseme
Adjunto un ejercicio tosco, obteniendo la letra buscando en una tabla. Que es lo que entiendo pretende kirilenko y que está prácticamente implícito en su descripción.

Ya puestos, incluyo también una función que en su día empleé LetraDNI(Texto, Opción) que nos devuelve según la opción
0 : Verdadero/Falso (chequea que la letra esté correcta)
1 : la letra
2 : Nif entero con letra correcta
Admite num.Tarjeta de residente e ignora caracteres banales que a veces incrustamos en los datos (X-12.345.678-F en vez de X12345678F y similares)

Re: Cálculo de la letra de un DNI

NotaPublicado: Mié Mar 14, 2012 10:18 pm
por sagiel
Prueba esta formula

La celda A1 está el número del DNI

=ELEGIR(RESIDUO(A1;23)+1;"T";"R";"W";"A";"G";"M";"Y";"F";"P";"D";"X";"B";"N"; "J";"Z";"S";"Q";"V";"H";"L";"C";"K";"E")

saludos
sagiel

Re: Cálculo de la letra de un DNI

NotaPublicado: Dom Mar 18, 2012 4:59 pm
por Kirilenko
Hola, buenas tardes; agradeceros a todos/as vuestra ayuda:
Ya encontré la solución a mi problema; lo expongo a continuación. :super:

=SI($D$6=0;"NADA";BUSCARV(RESIDUO($D$6;23)$A$6:$B$28;2))

Gracias.


Un saludo.