Cálculo de la letra de un DNI

Discute sobre la aplicación de hojas de cálculo

Cálculo de la letra de un DNI

Notapor Kirilenko » Dom Mar 11, 2012 11:09 pm

Buenas noches amigos; os comento el problema:

Tengo que calcular la letra asociada a un DNI, será necesario utilizar la función BUSCARV para localizar el RESIDUO de dividir el número
del DNI entre 23, y localizar el resultado en la tabla de la equivalencia. Cuando no se introduzca ningún DNI el resultado de dicha función
sera NADA.

Gracias por adelantado.


Saludos.
Openoffice 3.3.0 en Windows 7 y Ubuntu 11.10. Libreoffice.
Avatar de Usuario
Kirilenko
 
Mensajes: 8
Registrado: Dom Mar 11, 2012 10:56 pm

Re: Cálculo de la letra de un DNI

Notapor mauricio » Lun Mar 12, 2012 12:08 am

______________________________________________
"Todo cuanto no podemos dar nos posee". - André Gide
AOO 4.1 | LibO 5.4 | ArchLinux | Gnome3
No respondo preguntas privadas, por favor, usa el foro
Avatar de Usuario
mauricio
 
Mensajes: 5629
Registrado: Sab Nov 22, 2008 5:36 am
Ubicación: México, D.F.

Re: Cálculo de la letra de un DNI

Notapor Kirilenko » Lun Mar 12, 2012 1:24 am

Buenas noches, Mauricio. No me sirve para la hoja de cálculo, "esas líneas son para BASIC".
Lo que tengo que hacer se hace desde las celdas con (funciones, que describí arriba: BUSCARV) .
También realizar una división, dividir el número entre 23, localizar el resultado en la tabla, y para finalizar
dicha función será nada. Todo lo descrito desde las celdas, lo otro no me sirve.

Gracias por contestar.

Saludos.
Openoffice 3.3.0 en Windows 7 y Ubuntu 11.10. Libreoffice.
Avatar de Usuario
Kirilenko
 
Mensajes: 8
Registrado: Dom Mar 11, 2012 10:56 pm

Re: Cálculo de la letra de un DNI

Notapor xiseme » Lun Mar 12, 2012 3:04 am

Si el número a evaluar está en A1, el equivalente en una celda es ...
=MID("TRWAGMYFPDXBNJZSQVHLCKE";1+RESIDUO(A1;23);1)

BUSCARV, Tablas .¿? . :shock: . si es como ejercicio conceptual hay que "complicarlo", busca el residuo de dividir entre 23 en una tabla de dos columnas que serian de [0]1 a 23 correspondiéndose con T,R,W ... F.

Edito:
=SI(A1="";"NADA";MID("TRWAGMYFPDXBNJZSQVHLCKE";1+RESIDUO(A1;23);1))
Última edición por xiseme el Mié Mar 14, 2012 10:48 pm, editado 1 vez en total
Todo es mejorable, estamos dispuestos a mejorar. ¿Yo? ... poco a poco.
Nunca hay acritud en mis comentarios, si lo pareciera, seguro que me he expresado mal.
xiseme
 
Mensajes: 1877
Registrado: Lun Nov 24, 2008 1:13 pm

Re: Cálculo de la letra de un DNI

Notapor mauricio » Lun Mar 12, 2012 8:00 pm

Pues mira que si sirve...
LetraNIF.ods
(9.07 KiB) 495 veces
______________________________________________
"Todo cuanto no podemos dar nos posee". - André Gide
AOO 4.1 | LibO 5.4 | ArchLinux | Gnome3
No respondo preguntas privadas, por favor, usa el foro
Avatar de Usuario
mauricio
 
Mensajes: 5629
Registrado: Sab Nov 22, 2008 5:36 am
Ubicación: México, D.F.

Re: Cálculo de la letra de un DNI

Notapor xiseme » Mar Mar 13, 2012 1:57 am

Adjunto un ejercicio tosco, obteniendo la letra buscando en una tabla. Que es lo que entiendo pretende kirilenko y que está prácticamente implícito en su descripción.

Ya puestos, incluyo también una función que en su día empleé LetraDNI(Texto, Opción) que nos devuelve según la opción
0 : Verdadero/Falso (chequea que la letra esté correcta)
1 : la letra
2 : Nif entero con letra correcta
Admite num.Tarjeta de residente e ignora caracteres banales que a veces incrustamos en los datos (X-12.345.678-F en vez de X12345678F y similares)
Adjuntos
LetraNIF_v2.ods
(12.84 KiB) 306 veces
Todo es mejorable, estamos dispuestos a mejorar. ¿Yo? ... poco a poco.
Nunca hay acritud en mis comentarios, si lo pareciera, seguro que me he expresado mal.
xiseme
 
Mensajes: 1877
Registrado: Lun Nov 24, 2008 1:13 pm

Re: Cálculo de la letra de un DNI

Notapor sagiel » Mié Mar 14, 2012 10:18 pm

Prueba esta formula

La celda A1 está el número del DNI

=ELEGIR(RESIDUO(A1;23)+1;"T";"R";"W";"A";"G";"M";"Y";"F";"P";"D";"X";"B";"N"; "J";"Z";"S";"Q";"V";"H";"L";"C";"K";"E")

saludos
sagiel
saludos
sagiel
OpenOffice 3.3 - Windows 7
sagiel
 
Mensajes: 64
Registrado: Lun Jul 04, 2011 1:09 am
Ubicación: Barcelona - España

Re: Cálculo de la letra de un DNI

Notapor Kirilenko » Dom Mar 18, 2012 4:59 pm

Hola, buenas tardes; agradeceros a todos/as vuestra ayuda:
Ya encontré la solución a mi problema; lo expongo a continuación. :super:

=SI($D$6=0;"NADA";BUSCARV(RESIDUO($D$6;23)$A$6:$B$28;2))

Gracias.


Un saludo.
Openoffice 3.3.0 en Windows 7 y Ubuntu 11.10. Libreoffice.
Avatar de Usuario
Kirilenko
 
Mensajes: 8
Registrado: Dom Mar 11, 2012 10:56 pm


Volver a Calc

¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 9 invitados