[RESUELTO] Mitad entre dos fechas

Discute sobre la aplicación de hojas de cálculo

[RESUELTO] Mitad entre dos fechas

Notapor Desorientado » Vie Feb 12, 2010 1:36 pm

Por favor, ayudenme. Soy administrativo y trabajo en recursos humanos. Tengo una planilla en la que hay dos columnas con fechas: las fechas de la segunda columna son posteriores a las de la primera. Necesito dos fórmulas: una que me indique qué día se cumple la mitad del tiempo transcurrido entre cada par de fechas. Y otra que me diga qué días se cumplen: el primer tercio y el segundo tercio de tiempo transcurrido entre cada par de fechas. (OpenOffice.org 3.0.1)

Y si pudieran agregar, como bonus track, una que me arroje la cantidad de años, meses y días que transcurren entre dos fechas determinadas.

Agradezco mucho la ayuda, ya que me exigen esta planilla para las licencias y permisos del personal.-

:super:
Última edición por SLV-es el Mar Oct 16, 2012 4:02 pm, editado 3 veces en total
Razón: Marcar como resuelto
OpenOffice.org 3.0.1
Desorientado
 
Mensajes: 4
Registrado: Vie Feb 12, 2010 1:24 pm

Re: MITAD ENTRE DOS FECHAS

Notapor FJCC-ES » Vie Feb 12, 2010 4:55 pm

Si las fechas están en las columnas A y B

Mitad:
Código: Seleccionar todo   Expandir vistaContraer vista
=REDONDEAR(A1+(B1-A1)/2)


Primer tercio:
Código: Seleccionar todo   Expandir vistaContraer vista
=REDONDEAR(A1+(B1-A1)/3)


segundo tercio:
Código: Seleccionar todo   Expandir vistaContraer vista
=REDONDEAR(A1+2*(B2-A1)/3)
FJCC-ES
 
Mensajes: 700
Registrado: Mié Mar 25, 2009 1:19 am
Ubicación: Colorado, USA

Re: MITAD ENTRE DOS FECHAS

Notapor mauricio » Vie Feb 12, 2010 5:29 pm

Hola...

Una pregunta por tema nos ayuda a tener foros más ordenados... si aun no lo has hecho, por favor, lee la guía de supervivencia: viewtopic.php?f=3&t=795

Para tu segunda pregunta, ya se ha respondido en estos foros: viewtopic.php?f=21&t=2316&p=7110&hilit=a%C3%B1os+dias#p7079

Verifica si es lo que quieres y si es así, por favor, editar el título de tu primer mensaje para marcarlo como [RESUELTO] de este modo tenemos foros más ordenados.

Saludos
______________________________________________
"Todo cuanto no podemos dar nos posee". - André Gide
LibreOffice 6.2 | ArchLinux | Gnome3
No respondo preguntas privadas, por favor, usa el foro
Avatar de Usuario
mauricio
 
Mensajes: 5991
Registrado: Sab Nov 22, 2008 5:36 am
Ubicación: CDMX

Re: MITAD ENTRE DOS FECHAS

Notapor Desorientado » Lun Feb 15, 2010 1:42 pm

Gracias por la respuesta y disculpa que te moleste de nuevo. Introduje las fórmulas que me diste pero me arrojan resultados incorrectos.
Paso a explicarte lo que ocurre cuando inserto la fórmula, para que puedas ver si es un error mío o estoy haciendo algo mal.
En la columna A tengo la fecha 22/01/09 y en la columba B, 04/08/15. En la columna C inserto =REDONDEAR(A1+(B1-A1)/2) para que me arroje cuándo se cumple la mitad de tiempo entre ambas fechas, y me da el número 41028. Lo cual supongo que es en días, pero los mismos totalizan 112 años siendo que entre ambas fechas hay seis años y fracción.

Desde ya, muchas gracias por tomarte tu tiempo para ayudarme.
OpenOffice.org 3.0.1
Desorientado
 
Mensajes: 4
Registrado: Vie Feb 12, 2010 1:24 pm

Re: MITAD ENTRE DOS FECHAS

Notapor FJCC-ES » Lun Feb 15, 2010 2:58 pm

Las fechas en Calc tienen el valor de días desde 30/12/1899. Si cambie el formato de la celda, verá 41028 como la fecha 29/4/2012. Puede cambiar el formato si elige Formato → Celdas → Números y escoge la categoría Fecha.
FJCC-ES
 
Mensajes: 700
Registrado: Mié Mar 25, 2009 1:19 am
Ubicación: Colorado, USA

Re: MITAD ENTRE DOS FECHAS

Notapor Desorientado » Lun Feb 15, 2010 3:22 pm

Lo encontré!!! Gracias quien quiera que seas!! Gracias por tu tiempo y por tomarte la molestia con mi pregunta. Nos han enviado a trabajar en una actividad experimental en que tenemos que desarrollar todo de cero. Si esto marcha, cuando trabaje en mi planilla siempre te tendré presente por haberme ayudado. :super: :bravo:
OpenOffice.org 3.0.1
Desorientado
 
Mensajes: 4
Registrado: Vie Feb 12, 2010 1:24 pm


Volver a Calc

¿Quién está conectado?

Usuarios navegando por este Foro: Google [Bot] y 17 invitados