[RESUELTO] Contar el número de apariciones (fechas)

Discute sobre la aplicación de hojas de cálculo

[RESUELTO] Contar el número de apariciones (fechas)

Notapor yakichan » Jue Ene 21, 2010 10:11 pm

Hola a todos!

Soy nuevo en esto de OpenOffice, y estoy trasteando un poco con el Calc. Me he encontrado con un problema que no se como resolver.

Tengo un listado largo de fechas en una columna del tipo:
2009-09-14 16:36:12
2009-09-14 11:23:34
2009-09-15 21:22:10
2009-09-15 20:02:01
2009-09-15 02:42:44
2009-09-17 01:52:51
...

Necesito saber cuantas apariciones hay de cada fecha para luego hacer una gráfica. Siguiendo el ejemplo anterior el resultado sería:
14-09-14 -> 2
15-09-15 -> 3
17-09-17 -> 1

Si alguien puede echarme una mano se lo agradecería

Un saludo!
Última edición por mauricio el Vie Ene 22, 2010 6:01 pm, editado 1 vez en total
Razón: Marcar como resuelto
OpenOffice 3.1 en Windows XP
yakichan
 
Mensajes: 2
Registrado: Jue Ene 21, 2010 10:06 pm

Re: Contar el número de apariciones (fechas)

Notapor mriosv » Jue Ene 21, 2010 11:46 pm

¿En que formato tienes las fechas en las celdas?
Como texto o como fecha.
Lo mas fácil sería usar la funcion CONTAR.SI(), te adjunto el texto de la ayuda del programa (F1).
CONTAR.SI
Devuelve el número de celdas que cumplen determinados criterios.
La función de búsqueda admite expresiones regulares. Puede escribir "tod.*", por ejemplo, para buscar la primera aparición de "tod" seguido de cualquier carácter. Si desea buscar texto que también sea una expresión regular, cada carácter debe ir precedido de una doble barra inversa (\). Puede activar y desactivar la evaluación automática de expresión regular en Herramientas - Opciones - OpenOffice.org Calc - Calcular.
Sintaxis
CONTAR.SI(Rango; Criterio)
Área es el área donde deben aplicarse los criterios.
Criterio indica el criterio en el formato de un número, una expresión o una cadena de caracteres. Este criterio determina que celdas son contadas. Así mismo, puede introducir el texto de búsqueda en la forma de una expresión regular, por ejemplo, b.* para todas las palabras que comienzan con b. Puede también indicar un rango de fecha que contenga el criterio de búsqueda. Si busca literalmente, coloque el texto entre comillas dobles.
Ejemplo
A1:A10 es un rango de celda que contienen los números 2000 a 2009. Celda B1 contiene el número 2006. En la celda B2, ingresa una fórmula:
=CONTAR.SI(A1:A10;2006) - este devuelve 1
=CONTAR.SI(A1:A10;B1) - este devuelve 1
=CONTAR.SI(A1:A10;">=2006") - este devuelve 3
=CONTAR.SI(A1:A10;"<"&B1) - cuando B1 contiene 2006, este devuelve 6
=CONTAR.SI(A1:A10;C2) donde la celda C2 contiene el texto >2006 cuenta el número de celdas en el rango A1:A10 que son >2006
Para contar solamente números negativos: =CONTAR.SI(A1:A10;"<0")
Puedes usar "Subir adjunto" en Respuesta rápida - Editor Completo - Pestaña Subir adjunto
Apache OpenOffice 4, LibreOffice 5 (Win10x64)
mriosv
 
Mensajes: 2212
Registrado: Sab Dic 27, 2008 1:12 am
Ubicación: Galiza (España)

Re: Contar el número de apariciones (fechas)

Notapor yakichan » Vie Ene 22, 2010 3:41 pm

Solucionado: ;)

He eliminado la hora con la función =IZQUIERDA(A1;10) en 2 columnas nuevas (B y C). Después he aplicado un filtro a B sin criterios, pero "eliminando los duplicados". Sin datos duplicados, en la columna D he utilizado la función CONTAR.SI utilizando C como criterio de búsqueda en todo B.

=CONTAR.SI($B$1:$B$6000;C1)

Lo de crear B y C identicas se debe a que no he conseguido hacer funcionar CONTAR.SI sobre la columna A (que lleva incluida la hora) :?

Un saludo y muchas gracias


Editado por el moderador mauricio, dado que el usuario manifiesta que esta solucionado, marco como [RESUELTO] el tema, por favor, procura hacerlo tu en futuras ocasiones, gracias
OpenOffice 3.1 en Windows XP
yakichan
 
Mensajes: 2
Registrado: Jue Ene 21, 2010 10:06 pm

Re: [RESUELTO] Contar el número de apariciones (fechas)

Notapor mriosv » Sab Ene 23, 2010 1:26 am

Creo que podrías contar sobre la columna sin eliminar la hora utilizando un comodín (expresiones regulares) en la busqueda.
Debés tener activado el uso de expresiones regulares en Herramientas/Opciones/Calc/Calcular (ten cuidado se desactiva automáticamente al cargar un fichero excell xls)

=CONTAR.SI($B$1:$B$6000;C1&".*")
Puedes usar "Subir adjunto" en Respuesta rápida - Editor Completo - Pestaña Subir adjunto
Apache OpenOffice 4, LibreOffice 5 (Win10x64)
mriosv
 
Mensajes: 2212
Registrado: Sab Dic 27, 2008 1:12 am
Ubicación: Galiza (España)

Re: [RESUELTO] Contar el número de apariciones (fechas)

Notapor jose luis cuevas » Sab Ene 23, 2010 7:32 pm

Hola a todos:

Ya vi que esta resuelto, pero se me ocurre que podrias resolverlo de otra forma:

podrías poner una columna donde redondees la fecha, de esta manera le quitas la hora y solo dejas la fecha, despues, con el piloto de datos le pides que te haga una tabla dinámica de tu listado y pones en la parte de filas las fechas redondeadas y en los datos las fechas largas cambiando la operación a contar en lugar de sumar.

Te anexo un ejemplo.

Saludos

José Luis Cuevas Mac
Adjuntos
fechas.ods
(11.94 KiB) 1454 veces
Windows XP y openoffice 1.1.5 en en trabajo y 3.1 en la casa
jose luis cuevas
 
Mensajes: 17
Registrado: Mié Ago 12, 2009 1:05 pm


Volver a Calc

¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 29 invitados