Problema al proteger hoja de trabajo

Discute sobre la aplicación de hojas de cálculo

Problema al proteger hoja de trabajo

Notapor verdeneruda » Lun Dic 21, 2009 4:14 pm

Respetados colegas OpenOffice, en este momento tengo problemas con un archivo de oCalc el cual funciona correctamente, pero al momento de proteger el libro de trabajo este bloquea las formulas insertadas en las celdas y no las actualiza.

Mi pregunta es como hago para que al proteger el libro se sigan actualizando las formulas?

Dejo un ejemplo de lo que me ocurre:

=SI(C12="";BUSCARV(F12;Fasecolda.B2:R5500;
SI(C17=2;16;SI(C17=3;15;SI(C17=1;17;SI(C17=4;14;SI(C17=5;13;SI(C17=6;12;
SI(C17=7;11;SI(C17=8;10;SI(C17=9;9;SI(C17=10;8;SI(C17=11;7)))))))))));0);
BUSCARV(C12;Fasecolda.C2:R5500;SI(C17=1;16;SI(C17=2;15;SI(C17=3;14;
SI(C17=4;13;SI(C17=5;12;SI(C17=6;11;SI(C17=7;10;SI(C17=8;9;SI(C17=9;8;
SI(C17=10;7;SI(C17=11;6)))))))))));0))


Con esta función actualizo un valor de acuerdo al contenido de otra celda para que traiga una cantidad determinada, la celda de la que traigo el valor se carga con un lista desplegable, lo mismo pasa para otras formulas en otras celdas en la imagen adjunta al bloquear el libro no puedo actualizar los valores Comercial, Total y Nuevo.
Adjuntos
Error al proteger oCalc.JPG
Error al proteger oCalc.JPG (20.31 KiB) Visto 925 veces
Última edición por mauricio el Dom Ene 03, 2010 5:12 am, editado 1 vez en total
Razón: Cambiar titulo a minúsculas
JULIO JIMENEZ
OpenOffice 2.4 en Windows Xp
verdeneruda
 
Mensajes: 9
Registrado: Jue Dic 10, 2009 6:39 pm

Re: PROBLEMA AL PROTEGER HOJA DE TRABAJO

Notapor mauricio » Lun Dic 21, 2009 6:09 pm

Hola:

Las celdas, de forma predeterminada, estan "todas" protegidas, por lo que si vas al menú Herramientas | Proteger documento | Hoja..., y activas la protección, TODAS las celdas quedan protegidas. "Antes" de proteger la hoja, selecciona las celdas que SI se podran editar, ve al menú Formato | Celdas, en la ficha Protección de Celda, desactiva la casilla de verificación Protegido. Ahora si, protege la hoja, verifica que puedes cambiar los valores de las celdas desprotegidas. Las celdas que contengan formulas, aun y cuando estan protegidas, "deberían" actualizarse sin problemas cuando cambien sus celdas fuente.

Por favor, verificalo y si esto responde tu pregunta, edita el titulo del primer mensaje de este hilo para marcarlo como [RESUELTO].

Saludos
______________________________________________
"Todo cuanto no podemos dar nos posee". - André Gide
LibreOffice 6.2 | ArchLinux | Gnome3
No respondo preguntas privadas, por favor, usa el foro
Avatar de Usuario
mauricio
 
Mensajes: 6020
Registrado: Sab Nov 22, 2008 5:36 am
Ubicación: CDMX


Volver a Calc

¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 1 invitado