multiplicar dependiendo de la celda

Discute sobre la aplicación de hojas de cálculo

multiplicar dependiendo de la celda

Notapor elenitaex5 » Vie Dic 11, 2009 1:16 pm

buenas, tengo un problema, me gustaría saber si hay alguna manera de hacer el producto de varias celdas dependiendo de lo que venga dentro de ellas, es decir semejante a la fórmula de =SUMAR.SI(), pero para una multiplicación.
gracias
Openoffice 3.3.0
Sistema operativo Windows
elenitaex5
 
Mensajes: 56
Registrado: Sab Nov 28, 2009 2:49 pm
Ubicación: Madrid, España

Re: multiplicar dependiendo de la celda

Notapor FJCC-ES » Sab Dic 12, 2009 3:34 am

Si quiere multiplicar las celdas en B1:B13 que tienen valor igual a D13, la fórmula es
Código: Seleccionar todo   Expandir vistaContraer vista
=PRODUCTO(SI(B1:B13=$D$1;B1:B13;1))


Esta es una fórmula de matriz y es necesario confirmar la usando la combinación de teclas CTRL+SHIFT+ENTER

Es posible multiplicar celdas dependiendo del valor en otra columna.

Código: Seleccionar todo   Expandir vistaContraer vista
=PRODUCTO(SI(A1:A13="a";B1:B13;1))
FJCC-ES
 
Mensajes: 709
Registrado: Mié Mar 25, 2009 1:19 am
Ubicación: Colorado, USA

Re: multiplicar dependiendo de la celda

Notapor elenitaex5 » Lun Dic 14, 2009 3:34 pm

he intentado la fórmula pero no me hace nada y lo único que me pone es #VALOR! no se que he hecho mal. he comprobado que las celdas donde pongo los valores son los correctos, pero no me hace nada en ningún momento. alguien sabe a que puede ser debido??
Openoffice 3.3.0
Sistema operativo Windows
elenitaex5
 
Mensajes: 56
Registrado: Sab Nov 28, 2009 2:49 pm
Ubicación: Madrid, España

Re: multiplicar dependiendo de la celda

Notapor FJCC-ES » Lun Dic 14, 2009 7:15 pm

¿Puede subir un fichero? En publicar una respuesta, la pestaña Subir Adjunto está abajo.
FJCC-ES
 
Mensajes: 709
Registrado: Mié Mar 25, 2009 1:19 am
Ubicación: Colorado, USA

Re: multiplicar dependiendo de la celda

Notapor elenitaex5 » Mar Dic 15, 2009 2:54 pm

lo he vuelto a intentar varias veces y ya no me da el error. si vuelvo a tener problemas vuelvo a postear.
sin embargo ocurre una cosa rara. si la primera celda es igual a la otra celda, en el ejemplo que me has puesto D13, me multiplica TODAS las celdas. sin embargo si la primera celda es diferente, sólo me pone uno. No me multiplica sólo las celdas con el número determinado...
gracias por la ayuda :)
Openoffice 3.3.0
Sistema operativo Windows
elenitaex5
 
Mensajes: 56
Registrado: Sab Nov 28, 2009 2:49 pm
Ubicación: Madrid, España

Re: multiplicar dependiendo de la celda

Notapor FJCC-ES » Mié Dic 16, 2009 5:44 am

Es importante confirmar la fórmula usando la combinación de teclas CTRL+SHIFT+ENTER y no solamente ENTER
FJCC-ES
 
Mensajes: 709
Registrado: Mié Mar 25, 2009 1:19 am
Ubicación: Colorado, USA


Volver a Calc

¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 6 invitados