Página 1 de 1

Dejó de funcionar la función BUSCAR?

NotaPublicado: Mié Nov 04, 2009 2:10 am
por juan carlos saucedo
Tengo todo un sistema creado en OpenCalc y al migrar a la versión 9.10 de Ubuntu, la función BUSCAR dejó de funcionar, valga la redundancia, ej:=SI($B$2=0;" ";SI(BUSCAR($B$2;''#$clientes.A$2:A$300)=$B$2;BUSCAR($B$2;''#$clientes.A$2:A$300;''#$clientes.B$2:B$300);"no existe")), resultado: no existe. Me ha dejado sorprendido, probe con lookup en Gnumeric y anda bárbaro. Lo raro es que antes de migrar la formula andaba espléndida; al igual que presiono CTRL+B para buscar dentro de la hoja de cálculo y lo que hace en poner en negrita la celda donde estoy parado...

Re: Dejó de funcionar la función BUSCAR?

NotaPublicado: Mié Nov 04, 2009 9:20 pm
por mriosv
Por lo que se refiere a los atajos de teclado, seguramente te están funcionando los de idioma inglés Ctrl-B es Black (negrita)

para la formula prueba en lugar de (sobran las comillas " y almohadillas #):
=SI($B$2=0;" ";SI(BUSCAR($B$2;''#$clientes.A$2:A$300)=$B$2;BUSCAR($B$2;''#$clientes.A$2:A$300;''#$clientes.B$2:B$300);"no existe"))
la siguiente:
=SI($B$2=0;" ";SI(BUSCAR($B$2;$clientes.A$2:A$300)=$B$2;BUSCAR($B$2;$clientes.A$2:A$300;$clientes.B$2:B$300);"no existe"))