Problemas con INDIRECTO y SUMA

Discute sobre la aplicación de hojas de cálculo

Problemas con INDIRECTO y SUMA

Notapor forzasec » Mar Ago 25, 2009 10:41 am

¿Por qué esta fórmula no funciona?

=SUMA(f13:indirecto("F"&$B$8))

y sin embargo, si cambio el orden de los parámetros ¿si?

=SUMA(INDIRECTO("F"&$B$8):F13)

gracias.
forzasec
 
Mensajes: 3
Registrado: Mar Ago 25, 2009 10:36 am

Re: Problemas con INDIRECTO y SUMA

Notapor mriosv » Mar Ago 25, 2009 11:50 pm

Creo que INDIRECTO() debe entregar la referencia completa.
Probablemente en el segundo caso funciona porque está al principio y lo primero que se encuentra al interpretar la formula es la referencia que devuelve indirecto, mientras que en el primer caso lo que encuentra después de los dos puntos es la palabra indirecto que no es una referencia valida, no resolviendo funciones después de los dos puntos.
Puedes usar "Subir adjunto" en Respuesta rápida - Editor Completo - Pestaña Subir adjunto
Apache OpenOffice 4, LibreOffice 5 (Win10x64)
mriosv
 
Mensajes: 2239
Registrado: Sab Dic 27, 2008 1:12 am
Ubicación: Galiza (España)

Re: Problemas con INDIRECTO y SUMA

Notapor forzasec » Mié Ago 26, 2009 3:16 pm

O sea ¿que después de los 2 puntos oo nunca resuelve funciones?

La historia es que no me apetece poner una fórmula de ese modo. Me gustaría poner un sumatorio en el que el primer elemento sea el incial y el segundo el final, y en mi caso como el final es variable (de ahí INDIRECTO) pues como que parece ser que no se puede. Me toca hacer un sumatorio desde un final hasta un inicio.

Gracias por la respuesta, pero es que como que no me convence del todo, ¿viene descrito eso en algún sitio de esa manera? ¿es un bug?

Gracias
OpenOffice 3.1 en Windows
forzasec
 
Mensajes: 3
Registrado: Mar Ago 25, 2009 10:36 am

Re: Problemas con INDIRECTO y SUMA

Notapor mriosv » Mié Ago 26, 2009 3:22 pm

Puedes incluir dentro de indirecto la referencia completa.
Puedes usar "Subir adjunto" en Respuesta rápida - Editor Completo - Pestaña Subir adjunto
Apache OpenOffice 4, LibreOffice 5 (Win10x64)
mriosv
 
Mensajes: 2239
Registrado: Sab Dic 27, 2008 1:12 am
Ubicación: Galiza (España)

Re: Problemas con INDIRECTO y SUMA

Notapor mauricio » Jue Ago 27, 2009 1:47 am

Hola...

La ventaja del software libre, es que puedes modificarlo a tu gusto, si no te apetece poner las formulas y funciones de Calc, como están programadas, estructuradas y con las reglas especificadas, puedes bajar y modificar el código fuente y ponerlas a tu gusto, si por otra parte, te apetece, "adaptarte" a la forma como esta ahora, entonces, te sugiero consultar la ayuda acerca de funciones, ya que estas un poco perdido en ellas, los argumentos que usan, los tipos de estos y sobre todo los valores que devuelven, como es un tema muy amplio (el manejo de funciones) para enseñártelo aquí, anexo simplemente un ejemplo para establecer un rango dinámico, más o menos en el rango que mencionas, pero del cual, no das más detalles, pues podría haber más de una solución...

Por favor, revisalo, y si esto resuelve tu duda, por favor, marca este hilo como resuelto.

Gracias

Mauricio
Adjuntos
Ejemplo de rangos dinamicos.ods
Uso de rangos dinámicos
(8.64 KiB) 153 veces
______________________________________________
"Todo cuanto no podemos dar nos posee". - André Gide
LibreOffice 6.2 | ArchLinux | Gnome3
No respondo preguntas privadas, por favor, usa el foro
Avatar de Usuario
mauricio
 
Mensajes: 6083
Registrado: Sab Nov 22, 2008 5:36 am
Ubicación: CDMX

Re: Problemas con INDIRECTO y SUMA

Notapor forzasec » Vie Ago 28, 2009 12:05 pm

Jesús Mauricio!

un poco gratuitas tus descalificaciones: no conozco el software libre, su filosofía, no sé de fórmulas, etc. Encima me sugieres y me juzgas!. No sé quién te crées que eres para andar así por la vida chaval, pero vamos... no entro, no es mi estilo.

Si no te has dado cuenta, el hilo estaba solucionado desde el primer post (y sin tu fichero de ayuda), es decir, una fórmula de una manera no funciona y de la otra sí, punto! A partir de ahí, mi curiosidad, por tener que incluir de alguna manera "especial"o fija funciones en una función SUMA.

Me quedo con la aportación de "otra manera para resolverlo", meterlo todo en INDIRECTO, se ajusta mejor a lo que querría. Pero no he tenido, y menos por tu parte, ninguna respuesta a mi pregunta, ¿será por desconocimiento?

un saludo.
OpenOffice 3.1 en Windows
forzasec
 
Mensajes: 3
Registrado: Mar Ago 25, 2009 10:36 am

Re: Problemas con INDIRECTO y SUMA

Notapor RGB-es » Vie Ago 28, 2009 12:33 pm

Antes que nada ¡paz! La Guía de supervivencia es clara sobre esto: no se permiten discusiones personales.
forzasec, te recomiendo releer tus propios mensajes: frases como "no me apetece", "me gustaría", "no me convence" y "¿es un bug?" sobre algo que funciona perfectamente son las que, me parece, llevaron a Mauricio a decirte "Calc trabaja en forma diferente, solo queda adaptarse a esa forma de trabajar o modificarlo".
De modo que a seguir trabajando, nada ha sucedido aquí.
No respondo mensajes privados sobre AOO, por favor, utilice el foro para sus preguntas

AOO/LibO en openSUSE con escritorio Plasma
---
Existen dos clases de personas: las que dicen que existen dos clases de personas y las que no.
Avatar de Usuario
RGB-es
 
Mensajes: 4738
Registrado: Lun Nov 24, 2008 10:46 am

Re: Problemas con INDIRECTO y SUMA

Notapor mauricio » Vie Ago 28, 2009 8:27 pm

Sin comentarios
______________________________________________
"Todo cuanto no podemos dar nos posee". - André Gide
LibreOffice 6.2 | ArchLinux | Gnome3
No respondo preguntas privadas, por favor, usa el foro
Avatar de Usuario
mauricio
 
Mensajes: 6083
Registrado: Sab Nov 22, 2008 5:36 am
Ubicación: CDMX


Volver a Calc

¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 2 invitados