Página 1 de 1

fórmula

NotaPublicado: Jue Dic 11, 2008 5:29 pm
por erncalcopof
estimados Señores OpenOffice.Org Calc.
Usando OpenOffice Calc 3.0, no he podido usar la función =POTENCIA(A1;1/3), PARA VALORES NEGATIVOS.
Me estoy refiriendo a potencias con exponente fraccionario, que es lo mismo que decir: raíz de índice impar, por ejemplo raíz cúbica.
en Microsoft Excel ésta función resulta, pero en OpenOffice Calc 3.0 no.
Que puede estar mal.
Saluda Atentamente
Juan Areyuna
Profesor Computación
adjunto archivo imagen formato jpg.-

Re: fórmula

NotaPublicado: Dom Dic 14, 2008 9:08 pm
por Campbell
MIra yo tengo el OpenOffice.org 2.4 y además está en ingles...
pero supongo que no debe de haber diferencia...
si utilizo la formula POWER puedo calcular potencias, incluso negativas.

Re: fórmula

NotaPublicado: Lun Dic 15, 2008 2:41 am
por erncalcopof
Creo que el problema está el el código fuente de Calc.
Mientras tanto resolví el problema con la función =SI(;;)
Aquí está la función y el formato:
=SI(E6*F6<0;POTENCIA(-1*E6*F6;1/3);POTENCIA(E6*F6;1/3)) Raíz cúbica de un producto x*y<0
=SI(E6<0;-POTENCIA(-1*E6;1/3);POTENCIA(E6;1/3)) Raíz cúbica de x<0.-

Re: fórmula

NotaPublicado: Sab Dic 27, 2008 2:10 am
por mriosv
De acuerdo con la issue 37129, según las reglas de exponentes no se pueden usar pues exponentes equivalentes pueden conducir a resultados distintos

https://issues.apache.org/ooo/show_bug.cgi?id=37129
 Editado: (RGB-es) Corregido enlace al reporte 

Issue 37129
------- Additional comments from regina Thu Feb 22 22:29:35 +0000 2007 -------

Why do you want to change it? It is dangerous to calculate like (-8)^(1/3)=-2.
Look at this:
(-8)^(1/3)=(-8)^(2/6)=((-8)^2))^(1/6)=64^(1/6)=2

If you use fractions in exponents and want to keep the rules for exponents, than
you cannot allow negative base. And ^ and POWER calculate with exponents.

There are other opinions, but then you are speaking of a cube root, which would
be a new function in Calc.