Página 1 de 1

Formato sólo para una parte de una celda

NotaPublicado: Dom Oct 28, 2018 11:54 am
por hendismurf
Hola comunidad

Utilizo libreoffice (6.0.6) y en calca me ha surgido un problema que no soy capaz de resolver.
Tengo dos celdas, pongamos a1 y j1.
En la celda j1 inserto un valor número y le aplico mi formato de número 000000;#
Ahora en la celda a1 introduzco lo siguiente ="factura "&j1. El resultado de a1 es factura 1. Quiero que el resultado sea factura 000001 y que el color de 000001 sea rojo, sólo el color del número 000001.

¿Cómo puedo hacerlo?.

Gracias de antemano por la ayuda.

Saludos,

Re: formato sólo para una parte de una celda -- libreoffice

NotaPublicado: Dom Oct 28, 2018 3:14 pm
por xiseme
1.- En A1 = "factura: "&TEXTO(J1;"000000")
2.- ... dos colores en una misma celda ... uff .. tal vez con macros.
Sin entender el porqué así lo quieres ... ocurrencia (un poco tonta) emplear dos celdas contiguas digamos A1 y B1
En A1 =SI(B1="";"";"factura:")
En B2 =J1 con formato de número [RED]000000

Re: formato sólo para una parte de una celda -- libreoffice

NotaPublicado: Dom Oct 28, 2018 3:22 pm
por FJCC-ES
En el archivo adjunto, muestro dos soluciones. En la celda A1, usé una fórmula y en en la celda A2 cambié el formato con el menú Formato → Celdas. El formato de la celda J1 es irrelevante. No sé cómo controlar el color solamente del número.

Re: formato sólo para una parte de una celda -- libreoffice

NotaPublicado: Dom Oct 28, 2018 6:38 pm
por hendismurf
xiseme escribió:1.- En A1 = "factura: "&TEXTO(J1;"000000")
2.- ... dos colores en una misma celda ... uff .. tal vez con macros.
Sin entender el porqué así lo quieres ... ocurrencia (un poco tonta) emplear dos celdas contiguas digamos A1 y B1
En A1 =SI(B1="";"";"factura:")
En B2 =J1 con formato de número [RED]000000


Gracias xiseme, es justo lo que buscaba. En cuanto al color la sugerencia la probaré, sobre todo por los dos colores. Es una simple cuestión de formato visual.

Re: formato sólo para una parte de una celda -- libreoffice

NotaPublicado: Dom Oct 28, 2018 6:41 pm
por hendismurf
FJCC-ES escribió:En el archivo adjunto, muestro dos soluciones. En la celda A1, usé una fórmula y en en la celda A2 cambié el formato con el menú Formato → Celdas. El formato de la celda J1 es irrelevante. No sé cómo controlar el color solamente del número.

Muchas gracias FJCC, esto es lo que estaba buscando, que no daba con la la función texto. La probé pero no di con la solución. Lo único que queda es ver como se le puede dar color sólo al número generado. Que ya sería el remate definitivo.

Re: formato sólo para una parte de una celda -- libreoffice

NotaPublicado: Lun Oct 29, 2018 11:18 pm
por fornelasa
hendismurf escribió:Lo único que queda es ver como se le puede dar color sólo al número generado. Que ya sería el remate definitivo.
Hasta donde yo recuerdo no es posible hacerlo de un modo natural por la formula que la celda contiene.
Tal vez pudiera hacerse una macro, pero el esfuerzo invertido en la macro no creo que arroje un mejor resultado que esto:
xiseme escribió:1.- En A1 = "factura: "&TEXTO(J1;"000000")2.- ... dos colores en una misma celda ... uff .. tal vez con macros. Sin entender el porqué así lo quieres ... ocurrencia (un poco tonta) emplear dos celdas contiguas digamos A1 y B1En A1 =SI(B1="";"";"factura:")En B2 =J1 con formato de número [RED]000000
considero que la propuesta de xiseme es fácil de aplicar, sencilla y optima.

Saludos, Federico