Contador de palabras en Libreoffice Calc

Discute sobre la aplicación de hojas de cálculo

Contador de palabras en Libreoffice Calc

Notapor Maslibrequenunca » Dom Sep 30, 2018 9:55 am

Hola a todos.
Este es mi primer post.
Estoy utilizando Libreoffice Calc.
Necesito contar el número de palabras que contiene cada celda.
Cómo puedo hacer esto?
Gracias.
Libreoffice 6.0.0.3 en Windows 10
Maslibrequenunca
 
Mensajes: 1
Registrado: Dom Sep 30, 2018 9:50 am

Re: Contador de palabras en Libreoffice Calc

Notapor mriosv » Lun Oct 01, 2018 1:20 am

Una forma sencilla, si es aplicable, es eliminar los espacios que teóricamente son igual al número de palabras menos 1, descontar el número de letras tras las eliminación de los espacios del número de letras totales, y sumarle 1.

Suponiendo que queremos contar la celda A1
Código: Seleccionar todo   Expandir vistaContraer vista
=LARGO(A1)-LARGO(SUSTITUIR(A1;" ";""))+1
Puedes usar "Subir adjunto" en Respuesta rápida - Editor Completo - Pestaña Subir adjunto
Apache OpenOffice 4, LibreOffice 5 (Win10x64)
mriosv
 
Mensajes: 2165
Registrado: Sab Dic 27, 2008 1:12 am
Ubicación: Galiza (España)

Re: Contador de palabras en Libreoffice Calc

Notapor PepeOooSevilla » Lun Oct 01, 2018 3:56 pm

Hola.
Basándonos en la fórmula aportada por nuestro compañero mriosv, eliminamos los espacios sobrantes en la celda correspondiente...

Código: Seleccionar todo   Expandir vistaContraer vista
=SI(LARGO(ESPACIOS(A2))>0;LARGO(ESPACIOS(A2))-LARGO(SUSTITUIR(ESPACIOS(A2);" ";""))+1;0)

'Dependiendo de la versión la función ESPACIOS() se denomina COMPACTAR()

Saludos cordiales.
LibreOffice 6.1.5 en Windows 7 / 10
Por favor, utiliza el Foro para tus consultas, no los mensajes privados
Avatar de Usuario
PepeOooSevilla
 
Mensajes: 1066
Registrado: Sab Abr 04, 2009 6:10 pm
Ubicación: Sevilla (España)

Re: Contador de palabras en Libreoffice Calc

Notapor fornelasa » Mar Oct 02, 2018 12:07 am

Aquí otra tal vez posible opción:
Código: Seleccionar todo   Expandir vistaContraer vista
=SI(A2="";0;LARGO(REDUCIR(A2))-LARGO(SUSTITUIR(REDUCIR(A2);" ";""))+1)

En LibreOffice seria ESPACIOS en lugar de REDUCIR
lo 6.1.2 | aoo 4.1.6 | win 7/10
¡Un aplauso para todos los que luchan por proteger y promover la Web abierta!
Avatar de Usuario
fornelasa
 
Mensajes: 3174
Registrado: Jue Feb 17, 2011 8:30 pm
Ubicación: Estado de México, México.


Volver a Calc

¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 108 invitados