Página 1 de 1

Duplicados en varias hojas con misma formula

NotaPublicado: Jue May 31, 2018 11:42 pm
por Rehen86
Buenas, buenas...
Estoy tratando de detectar cuando existen valores en la columna A que estén duplicados ya sea en la misma hoja o en alguna de las demás si para la misma fila, columna J, hay un valor mayor a cero (el valor en J puede variar entre vacío, 1 o 2). El resultado deseado seria "Repetido en Hoja..."
Por el momento, lo estoy haciendo asi:
Código: Seleccionar todo   Expandir vistaContraer vista
=SI($J2<>"";SI(CONTAR.SIS($Hoja1.$A$2:$A$13;$A2;$Hoja1.$J$2:$J$13;">"&0)>1;"Repetido en Hoja1";SI(CONTAR.SIS($Hoja2.$A$2:$A$13;$A2;$Hoja2.$J$2:$J$13;">"&0)>0;"Repetido en Hoja2";SI(CONTAR.SIS($Hoja3.$A$2:$A$13;$A2;$Hoja3.$J$2:$J$13;">"&0)>0;"Repetido en Hoja3";"")));"")

La cosa es que para el CONTAR.SIS de la misma hoja, la prueba lógica debe ser ">1" mientras que para las demás ">0" por lo que (actualmente) debo cambiar en cada hoja tal comprobación... motivo por el que estoy en busca de una misma formula única (ademas que la cantidad de hojas y los rangos son mayores).
CREO (o al menos intente) haber sido bastante claro... sino me chiflan.
Desde ya, muchas gracias.

Re: Duplicados en varias hojas con misma formula

NotaPublicado: Jue Jun 07, 2018 6:36 pm
por fornelasa
Considero que la consulta no es entendible al 100%, para tal vez darnos una idea de como hacerlo aquí un ejemplo pero sin considerar todas tus variables.
Saludos, Federico.

Re: Duplicados en varias hojas con misma formula

NotaPublicado: Vie Jun 08, 2018 10:54 pm
por Rehen86
Gracias por el intento. Interesante el resultado de ver todas las hojas en que se repite, pero no es necesario para mi caso.
Como ya dije, para evaluar si el valor de la columna A se repite, también se debe evaluar si hay algún valor (distinto que vacío) en la columna J y a lo que trato de llegar es a una misma formula para todas las hojas para no tener que cambiar la comprobación de ">1" ó ">0" dependiendo de si es la hoja en la que se encuentra la formula o no (de la misma manera que en la respuesta del compañero donde utiliza ">1" para la hoja actual y ">=1" para las demás hojas).
Espero me haya acercado un poco mas 100%...
Desde ya, muchas gracias.
Sds!