Página 1 de 1

[RESUELTO] Referencia a nombre de hoja en funcion Indirecto

NotaPublicado: Dom May 27, 2018 7:11 pm
por ribeirego
Buenas tardes, he cogido esta formula matricial de un hilo del foro que ha dado solucion a mi problema ... sin embargo a continuacion cuando he intentado agregarle otro nombre de hoja para recabar los datos en mi hoja de trabajo no funciona .... esta claro que el problema es hacer referencia a la Hoja3. He consultado otra vez la ayuda de la funcion Indirecto y no veo el fallo.

Esta funciona correctamente en la misma hoja en que estan los datos
=SI(ESERROR(INDIRECTO("a"&K.ESIMO.MENOR(SI(L$2=$D$3:$D$15;FILA($D$3:$D$15);"");$A3)));"";INDIRECTO("a"&K.ESIMO.MENOR(SI(L$2=$D$3:$D$15;FILA($D$3:$D$15);"");$A3)))

En esta cuando hago referencia a "Hoja3.A"&K.ESIMO..... etc no me da el dato esperado... la celda se queda en blanco ...
=SI(ESERROR(INDIRECTO("Hoja3.A"&K.ESIMO.MENOR(SI(Hoja3.L$2=Hoja3.$D$3:$D$15;FILA(Hoja3.$D$3:$D$15);"");Hoja3.$A3)));"";INDIRECTO("Hoja3.a"&K.ESIMO.MENOR(SI(Hoja3.L$2=Hoja3.$D$3:$D$15;FILA(Hoja3.$D$3:$D$15);"");Hoja3.$A3)))