[RESUELTO] Referencia a nombre de hoja en funcion Indirecto

Discute sobre la aplicación de hojas de cálculo

[RESUELTO] Referencia a nombre de hoja en funcion Indirecto

Notapor ribeirego » Dom May 27, 2018 7:11 pm

Buenas tardes, he cogido esta formula matricial de un hilo del foro que ha dado solucion a mi problema ... sin embargo a continuacion cuando he intentado agregarle otro nombre de hoja para recabar los datos en mi hoja de trabajo no funciona .... esta claro que el problema es hacer referencia a la Hoja3. He consultado otra vez la ayuda de la funcion Indirecto y no veo el fallo.

Esta funciona correctamente en la misma hoja en que estan los datos
=SI(ESERROR(INDIRECTO("a"&K.ESIMO.MENOR(SI(L$2=$D$3:$D$15;FILA($D$3:$D$15);"");$A3)));"";INDIRECTO("a"&K.ESIMO.MENOR(SI(L$2=$D$3:$D$15;FILA($D$3:$D$15);"");$A3)))

En esta cuando hago referencia a "Hoja3.A"&K.ESIMO..... etc no me da el dato esperado... la celda se queda en blanco ...
=SI(ESERROR(INDIRECTO("Hoja3.A"&K.ESIMO.MENOR(SI(Hoja3.L$2=Hoja3.$D$3:$D$15;FILA(Hoja3.$D$3:$D$15);"");Hoja3.$A3)));"";INDIRECTO("Hoja3.a"&K.ESIMO.MENOR(SI(Hoja3.L$2=Hoja3.$D$3:$D$15;FILA(Hoja3.$D$3:$D$15);"");Hoja3.$A3)))
OpenOffice 3.2 - Ubuntu 10.04 - LTS
LibreOffice 3.6 - Slitaz 4.0
ribeirego
 
Mensajes: 16
Registrado: Mar Mar 02, 2010 11:11 pm

Volver a Calc

¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 4 invitados