Página 1 de 1

Funcion BUSCARV() matriz fuera de formula

NotaPublicado: Mié Mar 28, 2018 12:15 am
por thecloudff7
Hola buenas,

Mi consulta era que, quiero intentar sacar la matriz de la función BUSCARV() en una celda aparte. Pongo un ejemplo:

Código: Seleccionar todo   Expandir vistaContraer vista
BUSCARV(B3;'file:///C:/Users/claud/Desktop/231/PRUEBA2.ods'#$Hoja1.B3:P5;SUMA(D3;1);0)


Quiero intentar sacar la matriz en este caso
Código: Seleccionar todo   Expandir vistaContraer vista
'file:///C:/Users/claud/Desktop/231/PRUEBA2.ods'#$Hoja1.B3:P5
que este en una casilla a parte (ejemplo. X2) y la función quede algo así
Código: Seleccionar todo   Expandir vistaContraer vista
BUSCARV(B3;X2;SUMA(D3;1);0)


De esta forma puedo hacer varios buscarv, y si cambio la ruta del archivo no tengo que ir cambiando uno a uno el buscarv.

Gracias!

Re: Funcion BUSCARV() matriz fuera de formula

NotaPublicado: Mié Mar 28, 2018 2:12 am
por fornelasa
Suponiendo que hubiera entendido bien:
Código: Seleccionar todo   Expandir vistaContraer vista
BUSCARV(B3;INDIRECTO(X2);SUMA(D3;1);0)

Saludos.

Re: Funcion BUSCARV() matriz fuera de formula

NotaPublicado: Mié Mar 28, 2018 11:25 am
por thecloudff7
fornelasa escribió:Suponiendo que hubiera entendido bien:
Código: Seleccionar todo   Expandir vistaContraer vista
BUSCARV(B3;INDIRECTO(X2);SUMA(D3;1);0)

Saludos.



Creo que si me has entendido, pero pongo la ruta en la celda X2 y pongo indirecto, pero no funciona. Cunado lo hago asi me sale #N/D y cuando lo dejo dentro si funciona la funcion...

Ayuda!

Re: Funcion BUSCARV() matriz fuera de formula

NotaPublicado: Mié Mar 28, 2018 12:32 pm
por PepeOooSevilla
Hola.
He hecho pruebas y funciona correctamente como dice nuestro compañero fornelasa.

En mi caso, la celda D1 contiene 'file:///K:/PEPE_16GB/FORO OOO/FORO CALC/PRUEBAS/TABLAS DATOS.ods'#$Hoja1.$A$2:$B$8

La función:
Código: Seleccionar todo   Expandir vistaContraer vista
=BUSCARV(B1;INDIRECTO(D1);2;FALSO())

Me devuelve el resultado esperado.

Comprueba que el primer carácter de la ruta sea un apóstrofo y que la referencia al rango de celdas sea una referencia absoluta.
Saludos cordiales.

Re: Funcion BUSCARV() matriz fuera de formula

NotaPublicado: Mié Mar 28, 2018 5:49 pm
por fornelasa
Así es, como comenta PepeOooSevilla, debemos poner correctamente la ruta, no es un texto común y corriente, es decir, bueno si lo es, es un texto ...... ummmm , mejor mira la imagen y nota el color que se forma en B1 cuando el vinculo se activa correctamente.

En la imagen no hay referencias absolutas pero efectivamente debemos usarlas, es básico.

Imagen

Saludos.