Añadir Texto en Celdas con Contenido

Discute sobre la aplicación de hojas de cálculo

Añadir Texto en Celdas con Contenido

Notapor ELMAKY » Jue Ago 24, 2017 5:48 pm

Buenas tardes,

Aunque para algunos sea sencillo, yo llevo un buen rato intentando conseguir algo que con funciones es bastante sencillo =SI(D3<>0;D3&" JUAN";""). Necesito esto pero con una macro en la que pueda elegir el rango de celdas de la columna donde aplicar esto.

Otra pregunta sobre esto es, ¿hay alguna forma sencilla de parametrizar para poder usar con macros todas las funciones de CALC (suma, concatenar, buscar, etc.)?

Adjunto archivo con ejemplo.

Muchas gracias por adelantado.

Un saludo
Adjuntos
Añadir Texto con Macro.ods
(9.67 KiB) 18 veces
OpenOffice 3.1 en Windwos Vista
ELMAKY
 
Mensajes: 17
Registrado: Jue Jul 06, 2017 12:00 pm

Re: Añadir Texto en Celdas con Contenido

Notapor fornelasa » Jue Ago 24, 2017 6:45 pm

Yo no entendí la consulta.

Por ejemplo, si tenemos en G3 la formula
Código: Seleccionar todo   Expandir vistaContraer vista
=SI(D3<>0,D3&" DON","")
y después elegimos las celdas G18 y G20 ¿debería aparecer en dichas celdas las formulas
Código: Seleccionar todo   Expandir vistaContraer vista
=SI(D18<>0,D18&" DON","")
Código: Seleccionar todo   Expandir vistaContraer vista
=SI(D20<>0,D20&" DON","")
respectivamente?

Esta parte definitivamente no la entendí
Otra pregunta sobre esto es, ¿hay alguna forma sencilla de parametrizar para poder usar con macros todas las funciones de CALC (suma, concatenar, buscar, etc.)?

Recordemos que de acuerdo a las normas del foro debemos realizar una pregunta por tema.

Saludos, Federico.
lo 5.3.7 | aoo 4.1.4 | win 7/10
¡Un aplauso para todos los que luchan por proteger y promover la Web abierta!
Avatar de Usuario
fornelasa
 
Mensajes: 2790
Registrado: Jue Feb 17, 2011 8:30 pm
Ubicación: Estado de México, México.

Re: Añadir Texto en Celdas con Contenido

Notapor ELMAKY » Jue Ago 24, 2017 9:19 pm

Buenas tardes,

Veo que no me he explicado correctamente. Los datos de ejemplo están en las celdas D3:D7 y el resultado con función en G3:G7. El resto son textos y flechas explicativos del caso.

Lo que yo necesito es una macro que haga esto mismo, usando funciones en su desarrollo.

Espero haberlo dejado más claro ahora.

Un saludo y gracias por tu interés fornelasa
OpenOffice 3.1 en Windwos Vista
ELMAKY
 
Mensajes: 17
Registrado: Jue Jul 06, 2017 12:00 pm

Re: Añadir Texto en Celdas con Contenido

Notapor fornelasa » Jue Ago 24, 2017 9:28 pm

Ok bien, yo sigo sin entender, pero bueno, a veces hay días en los que no doy una :mrgreen:
Esperemos que alguien más del foro nos ayude.
Saludos, Federico.
lo 5.3.7 | aoo 4.1.4 | win 7/10
¡Un aplauso para todos los que luchan por proteger y promover la Web abierta!
Avatar de Usuario
fornelasa
 
Mensajes: 2790
Registrado: Jue Feb 17, 2011 8:30 pm
Ubicación: Estado de México, México.


Volver a Calc

¿Quién está conectado?

Usuarios navegando por este Foro: Google [Bot] y 9 invitados