[RESUELTO] BuscarV con matriz de búsqueda variable

Discute sobre la aplicación de hojas de cálculo

[RESUELTO] BuscarV con matriz de búsqueda variable

Notapor josele30 » Mié Jul 13, 2016 1:13 am

Hola, por mas que estuve buscando no pude encontrar la solucion a este problema que tengo. Vi que en excel funciona, pero no pude hacerlo funcionar con Calc.

Imagen

LA cosa es así.
Tengo una lista de elementos en la columna "B" que se van repitiendo como en el ejemplo. Esa cantidad de elementos es variable, en el ejemplo son 10 pero pueden ser mas o menos. Esa cantidad está en la celda A1.
Necesito ordenarlos como esta ejemplificado en la columna H7. O sea, se listan los elementos en una columna cualquiera (en el ejemplo la H) y cada vez que encuentra el elemento en la columna B se coloca el numero de la columna C en la misma fila a partir de la H.
Para eso se me ocurrieron las fórmulas que indico. El problema es que como la cantidad de elementos es variable,las matrices de los "busvarv" deben ser tambien dependientes del valor de A1. Se me ocurrió usar INDIRECTO, pero no pude hacerlo funcionar.
No se mucho de macros, así que por ahí no pude avanzar.
Les agradecería si me pueden ayudar.
Última edición por mauricio el Jue Jul 14, 2016 4:33 am, editado 2 veces en total
Razón: Marcar icono de resuelto
OpenOffice 4.1.2 en Windows 7
josele30
 
Mensajes: 3
Registrado: Mar Jul 12, 2016 4:56 pm

Re: BuscarV con matriz de búsqueda variable

Notapor fornelasa » Mié Jul 13, 2016 8:50 pm

Hubiera sido bueno ver la formula en Excel para darnos una idea y ver como funcionaba.
Si hubiera entendido bien, aqui un posible ejemplo:
Copia el rango de formulas I6:I16 hacia la derecha.
Saludos, Federico.
Adjuntos
Desface.ods
Desface
(11.73 KiB) 292 veces
lo 6.1.2 | aoo 4.1.6 | win 7/10
¡Un aplauso para todos los que luchan por proteger y promover la Web abierta!
Avatar de Usuario
fornelasa
 
Mensajes: 3128
Registrado: Jue Feb 17, 2011 8:30 pm
Ubicación: Estado de México, México.

Re: BuscarV con matriz de búsqueda variable

Notapor josele30 » Mié Jul 13, 2016 11:17 pm

Hola fornelasa, muchas gracias.
Es exactamente eso lo que quería hacer, pero se ve que no daba con los parámetros del INDIRECTO dentro del BUSCAR. Ahora lo que hice fue reemplazar los FILA(), que no entiendo porqué lo planteaste así, por directamente el nro resultado que da y me va perfecto!
OpenOffice 4.1.2 en Windows 7
josele30
 
Mensajes: 3
Registrado: Mar Jul 12, 2016 4:56 pm

Re: BuscarV con matriz de búsqueda variable

Notapor fornelasa » Mié Jul 13, 2016 11:44 pm

Precisamente para eso puse FILAS() para que se notara, ..... pensando en: ¿que pasaría si los datos no empiezan en B4?, es más facil notar el "error" de FILAS que un numero.
Si consideras que el tema esta resuelto aqui dice como marcarlo como tal :super:
https://forum.openoffice.org/es/forum/v ... f=3&t=2668

Saludos, Federico.
lo 6.1.2 | aoo 4.1.6 | win 7/10
¡Un aplauso para todos los que luchan por proteger y promover la Web abierta!
Avatar de Usuario
fornelasa
 
Mensajes: 3128
Registrado: Jue Feb 17, 2011 8:30 pm
Ubicación: Estado de México, México.

Re: [RESUELTO] BuscarV con matriz de búsqueda variable

Notapor josele30 » Jue Jul 14, 2016 12:41 am

Excelente Federico,un paso adelante mío!!! ejejej :-D
OpenOffice 4.1.2 en Windows 7
josele30
 
Mensajes: 3
Registrado: Mar Jul 12, 2016 4:56 pm

Re: [RESUELTO] BuscarV con matriz de búsqueda variable

Notapor bogs » Lun Ago 27, 2018 10:30 pm

Hola.

Estoy buscando una solución parecida a este ejemplo.


En lugar de usar INDIRECTO en el segundo parámetro de la función BUSCARV, requiero usarlo en el tercer parámetro.


=buscarv(a1,c:x,INDIRECTO(A2),falso)

en donde A2 contiene el valor de la columna donde se encuentran los datos, esta columna puede variar aleatoriamente.

espero me haya explicado

gracias
OpenOffice 3.1 en Windows Vista
bogs
 
Mensajes: 1
Registrado: Lun Ago 27, 2018 10:02 pm

Re: [RESUELTO] BuscarV con matriz de búsqueda variable

Notapor PepeOooSevilla » Mié Ago 29, 2018 11:42 am

Hola.

Te damos la bienvenida al Foro y, por favor, no dejes de leer la Guía de supervivencia y, también, cuando un tema está "RESUELTO" es conveniente crear un nuevo tema para una nueva pregunta. Ya sabes, una pregunta por tema y un tema por pregunta.
bogs escribió:... A2 contiene el valor de la columna donde se encuentran los datos ...

¿Este valor es un número o la letra de la columna?

Para el primer caso una posible solución es (ver celda A3 de la Hoja1 del archivo adjunto):
Código: Seleccionar todo   Expandir vistaContraer vista
=BUSCARV(A1;$C$2:$K$28;A2;0)
' $C$2:$K$28 es el rango de la tabla donde busca

Para el segundo caso una posible solución es (ver celda A3 de la Hoja2 del archivo adjunto):
Código: Seleccionar todo   Expandir vistaContraer vista
=BUSCARV(A1;$C$2:$K$28;COLUMNA(INDIRECTO(A2 & "1"))-2;0)
' El -2 es porque hay que restar las columnas A y B, ya que la tabla donde busca comienza en la columna C

También hay que tener en cuenta que si se adjunta un archivo con la incidencia/consulta/... (por favor, sin datos personales, que este es un Foro público) aumenta, y mucho, las posibilidades de conseguir una respuesta adecuada. Ver Cómo adjuntar un archivo a este sitio. He de aclarar que hay veces que, aun subiendo un archivo de ejemplo, no es posible encontrar una solución.

Saludos cordiales.
Adjuntos
FORO_CALC_BUSCARV_Columna_variable.ods
(12.74 KiB) 70 veces
LibreOffice 6.1.5 en Windows 7 / 10
Por favor, utiliza el Foro para tus consultas, no los mensajes privados
Avatar de Usuario
PepeOooSevilla
 
Mensajes: 1005
Registrado: Sab Abr 04, 2009 6:10 pm
Ubicación: Sevilla (España)


Volver a Calc

¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 6 invitados