Página 1 de 1

Error: #NAME?

NotaPublicado: Mar Jun 09, 2009 4:00 pm
por GDELZO
Al estar utilizando la formula BUSCARV...me sale el mensaje como resultado de la formula, #NAME? , es muy curioso porque cuando uso la misma formula en donde la base de datos y lo que busco esta en el mismo archivo, la formula funciona excelente, pero si donde quiero buscar esta en alguna parte recondita del disco duro, es alli donde me sale ese mensaje, y cuando yo deseo poner el rango de busqueda es teniendo ambos archivos abiertos, es mas, al irme a buscar la tabla me voy por la opcion Ventana/ y alli selecciono el archivo que obviamente debe estar abierto, la verdad que no entiendo porque del error, probe poniendo ambos archivos en la raiz (D:\) y si funciona la misma formula con los archivos alli...porque sera? gracias

Re: Error: #NAME?

NotaPublicado: Mié Jun 10, 2009 4:05 am
por FJCC-ES
Guardé un archivo (Archivo A) en C:\ y investigué si la función Buscarv podía buscar en un archivo (Archivo B) en el disco D:\. Encontré lo siguiente:

La fórmula

Código: Seleccionar todo   Expandir vistaContraer vista
=BUSCARV(B3;'file:///D:/Documents%20and%20Settings/username/Desktop/vlookuptarget.ods'#$Sheet1.B1:C9;2;0)


funciona correctamente

La fórmula

Código: Seleccionar todo   Expandir vistaContraer vista
=BUSCARV('file:///D:/Documents%20and%20Settings/username/Desktop/vlookuptarget.ods'#$Sheet1.A3;'file:///D:/Documents%20and%20Settings/username/Desktop/vlookuptarget.ods'#$Sheet1.B1:C9;2;0)


resulta en #N/A. La única diferencia entre las fórmulas es que en la secunda el Criterio de la Búsqueda está in Archivo B.

Sin embargo esta fórmula con el Criterio de la Búsqueda en Archivo B sí funciona

Código: Seleccionar todo   Expandir vistaContraer vista
=BUSCARV('file:///D:/vlookuptarget.ods'#$Sheet1.A3;'file:///D:/vlookuptarget.ods'#$Sheet1.B1:C9;2;0)


Parece que hay un bug en Buscarv.

Buscaré en www.OpenOffice.org si alguien lo ha reportado

Re: Error: #NAME?

NotaPublicado: Mar Jun 16, 2009 4:47 pm
por GDELZO
holitas...me tendras alguna novedad? :| :crazy:

Re: Error: #NAME?

NotaPublicado: Mié Jun 17, 2009 5:49 pm
por FJCC-ES
Esta fórmula
Código: Seleccionar todo   Expandir vistaContraer vista
=BUSCARV('file:///D:/Documents%20and%20Settings/username/Desktop/vlookuptarget.ods'#$Sheet1.A3;'file:///D:/Documents%20and%20Settings/username/Desktop/vlookuptarget.ods'#$Sheet1.B1:C9;2;0)


que devolvía #N/A hace una semana, ahora sí funciona correctamente. No hice nada mas que guardar el archivo y dejar lo seis días. No sé qué sugerir.