Página 1 de 1

[RESUELTO] Buscar Texto en una Matriz de Celdas

NotaPublicado: Mar Mar 17, 2015 1:01 pm
por diegotco
Hola amigas y amigos

Llevo peleando varios días con este asunto.

El tema es que quiero buscar, usando una fórmula, una parte de texto dentro de una celda. Ojo, no es importante que sea case sensitive

Ejemplo:

00000018.png


Como pueden observar, esa es la única fórmula que me sirve... SALVO que debo escribir el texto y lo que yo quiero es, según la imagen de arriba, poner B1 en lugar de escribir Defense Nutrition pues siendo así debería escribir el texto en cada una de las 400 celdas... y no tendría sentido usar fórmulas.

Pues el objetivo es que CADA CELDA DE LA COLUMNA B BUSQUE TEXTO (O PARTE DE UN TEXTO) EN EL RANGO DE A1 HASTA A400

Es posible esto?

Muchas gracias por cualquier ayuda

Re: Buscar Texto en una Matriz de Celdas

NotaPublicado: Mar Mar 17, 2015 1:22 pm
por SLV-es
Hola

Necesitar utilizar expresiones regulares en la fórmula; previamente, desde Herramientas > opciones > OpenOffice Calc > Calcular > Permitir expresiones regulares en las fórmulas debe estar activado.

En mi ejemplo, la fórmula de la celda D4 hace lo que pides

Código: Seleccionar todo   Expandir vistaContraer vista
=CONTAR.SI($A$4:$A$23;".*" & B4 & ".*")


Te adjunto el ejemplo.

Para los nuevos usuarios del foro:
Te damos la bienvenida a este foro. Esperamos poder ayudarte y que tus aportaciones ayuden también a otros.
Dado que recien has desembarcado en esta costa, te recomiendo que leas la Guía de supervivencia del foro :super: .
Si con las respuestas obtenidas consideras que se ha dado solución a tu consulta :), por favor, marca el tema como [RESUELTO],
(aunque la solución obtenida sea que no la hay :(, o hayas resuelto tú mism@ el problema :bravo: ).
Si no sabes cómo, por favor, lee Como marcar como [RESUELTO] un tema.

Gracias por participar en el foro y ayudar a que todo esté ordenado.

Re: Buscar Texto en una Matriz de Celdas

NotaPublicado: Mar Mar 17, 2015 1:56 pm
por diegotco
Hola SLV-es muchas gracias por tu ayuda :)

La fórmula está casi lista.

Tengo sin embargo 1 pregunta más para que la fórmula quede perfecta

-En cualquier celda de la columna B2 al dar un espacio (pues es posible que luego del texto existan espacios) la fórmula ya no funciona ;(

De nuevo apelo a tu sabiduría para resolver esta "nimiedad" jiji

Espero tu gentil ayuda una vez más :)

Re: Buscar Texto en una Matriz de Celdas

NotaPublicado: Mar Mar 17, 2015 4:16 pm
por SLV-es
Puedes utilizar la función REDUCIR para eliminar los espacios en blanco

Código: Seleccionar todo   Expandir vistaContraer vista
=CONTAR.SI($A$4:$A$23;".*" & REDUCIR(B4) & ".*")


Si vas a utilizar fórmulas en Calc, échale un vistazo al capítulo http://wiki.open-office.es/Las_formulas_en_Calc y a los 3 siguientes :D

Saludos

Nota: una simple búsqueda en el foro, en internet o en las funciones de texto de Calc te habrían llevado a la solución.
También pedimos siempre una pregunta por tema. Por favor, en adelante, inténtalo por tu cuenta antes y crea nuevos temas para nuevas preguntas. Gracias.

[Resuelto] Buscar Texto en una Matriz de Celdas

NotaPublicado: Mar Mar 17, 2015 9:12 pm
por diegotco
Solo una palabra: ESPECTACULAR

Muchas gracias SLV-es por tu tiempo :)

Re: [RESUELTO] Buscar Texto en una Matriz de Celdas

NotaPublicado: Mar Jun 12, 2018 5:52 pm
por CECI.LTS
Hola; intento utilizar esta formula que pusiste para casi el mismo ejemplo pero me da como resultado cero, y no encuentro la forma de activar las expresiones regulares que comentas. Mi excel es 2013, no se si por eso sea distinto.
Gracias

Re: [RESUELTO] Buscar Texto en una Matriz de Celdas

NotaPublicado: Mar Jun 12, 2018 6:04 pm
por fornelasa
Hola CECI.LTS, De bote pronto, la forma de hacerlo en excel es exactamente como dice el primer post de este debate sin usar los puntos.
Me gustaría comentar que no damos soporte a la hoja de calculo Excel. Aquí en este foro se da soporte a la hoja de calculo Calc de Apache OpenOffice o LibreOffice.
Hasta donde yo sé Excel no maneja expresiones regulares de manera digamos "normal", creo puede hacerlo con macros.

Si es que buscamos soporte para Excel debemos ir al foro adecuado.

Saludos, Federico.