Página 1 de 1

Código Barras no funciona en 4.1.2 al Exportar a PDF

NotaPublicado: Lun Nov 28, 2016 5:25 pm
por SIALSOFT
Buenas a tod@s.

Resulta que tenía instalada la Versión 4.1.1 y tengo documentos con códigos de barras 128C y al exportar el documento a PDF SI me lo hacía bien, pero resulta que con la Versión 4.1.2 y 4.1.3 NO me exporta a PDF el código de barras correctamente. Cualquier código de barras 128C tiene la característica de que tiene un carácter de comienzo "‰" = Alt+00137 y otro carácter de fin "Š" = Alt-00138. Pues resulta que ninguno de los 2 caracteres los exporta a PDF y por tanto el lector de código de barras no lo lee bien.

Por ejemplo, tengo el siguiente número 905224701071600603000084100616614200005000615700010000. Mediante un algoritmo que va cogiendo pares de números y convirtiéndolos a caracteres ASCII llegamos a la siguiente cadena de caracteres ‰zT8f*g\&# t*&0]J R ]Y ! &Š Si exportas esta cadena a PDF lo hace correctamente pero si le aplicas la Fuente de Código de Barras 128C, aunque en el .odt se vé correcto, al exportarlo no lo hace correctamente y ambos caracteres no los muestra o no lo exporta.

Espero haberme explicado bien. Adjunto prueba.odt en el cual se puede ver el código de barras bien y adjunto también el prueba.pdf una vez convertido. SE puede observar que le falta un carácter al principio y otro al final.

Espero vuestra ayuda.

Saludos

Re: Código Barras no funciona en 4.1.2 al Exportar a PDF

NotaPublicado: Mar Nov 29, 2016 6:23 pm
por SIALSOFT
Hola de nuevo, mirando bug posibles, he encontrado este que es muy parecido y que tal vez aquí esté la solución.............que por cierto aún están resolviendo. Os dejo el enlace para ver que opináis.

https://bz.apache.org/ooo/show_bug.cgi?id=126883

Saludos