Página 1 de 1

Búsqueda en una tabla con dos variables

NotaPublicado: Vie Jun 03, 2016 6:46 pm
por PepeOooSevilla
>>> Caso:
Tenemos que hallar una tasa (porcentaje), previamente establecida (datos ficticios), que va en función de dos variables: los ingresos y el número de hijos (ver imagen).

>>> Solución:
Nos la da la fórmula =BUSCARV(B13;$B$4:$F$10;1+COINCIDIR(B14;$C$3:$F$3)) del archivo de ejemplo que se adjunta.

¡Atención! Si queremos que la búsqueda sea por datos exactamente iguales (no por tramos) entonces a la función BUSCARV() se le tiene que añadir un cuarto parámetro (opcional) que le indique ese estado. En este caso es el número 0 (cero) o la función FALSO().
Igualmente con la función COINCIDIR(). Aquí sería el tercer parámetro (opcional) al que le tendríamos que poner el valor 0 (cero).

Para más información sobre estas funciones y sus parámetros debemos consultar la Ayuda de Calc.

Como podemos comprobar, la solución a este caso se puede aplicar a otros casos parecidos.

Saludos cordiales.

Re: Búsqueda en una tabla con dos variables

NotaPublicado: Sab Jun 04, 2016 11:46 am
por xiseme
:super:

Re: Búsqueda en una tabla con dos variables

NotaPublicado: Mar Jun 21, 2016 11:50 am
por SLV-es
:super: :bravo: :bravo: :bravo: