[Solved] Error 1714. The older version of cannot be removed

Issues with installing under all versions of MS Windows

[Solved] Error 1714. The older version of cannot be removed

Postby Alex6361 » Thu Aug 20, 2015 12:36 pm

"Error 1714. The older version of . . . cannot be removed. Contact your technical support group."

It's not a very helpful message -- especially if you're your own "technical support group". The usual advice on this forum and elsewhere seems to be to re-run the install/remove program for the last version of the program. If you have it, try it -- it might work. But if you don't have it, or that effort fails, or you just want to go straight to the problem, try the following. It won't remove left-over files from a previous install, but it will hopefully reveal and fix what caused the Error 1714 failure. The usual warnings about making changes to the registry apply.

Open a command window and enter the following but do not enter return until told:

"msiexec /i " without the quotes. This will execute the MicroSoft Installer program in the install mode.

Enter the name of the .msi file (including the path) or drag it from wherever it is in Windows Explorer to the command window. If the file or path includes spaces, enclose the entire path in "". (If you drag the file name, Windows will do that for you if it's needed.)

Enter " /l*v " without the quotes. "l" is the letter "L". This requests the generation of a verbose log about the process, and you will need a file to capture it, so:

Enter the name of a log file to receive a detailed log of the msi execution. The entire path is needed.

Examine what you've just entered and make sure there is at least one space between each part of the command. The command should look something like this, with appropriate changes based on your msi file, what you chose to call the log file, and the paths to each:

Code: Select all   Expand viewCollapse view
msiexec  /i  C:\DownloadedFiles\LibreOffice_4.4.5_Win_x86.msi  /l*v  C:\temp\msi.log


Now, enter return and follow the directions for the install as you did before when it failed. It will fail again.

When it does, close out the installer process, and open the log file.

Search in that file for "Error 1714". It should be towards the end of what may be a long file.
A few lines above that you will hopefully find what the msi installer didn't like, and it is usually a registry key that is missing something msiexec is looking for. An example might be:

"Unexpected or missing value (name: 'PackageName', value: '') in key
HKLM\Software\Classes\Installer\Products\E9FFD8907BD5F964E8A51312EEBD6B0E\SourceList".

What's missing for you may be something else, and the long hex key can be anything. Open the registry and find that key ("HKLM" is short for "HKEY_LOCAL_MACHINE"). If you're feeling brave and confident, just delete that key (E9FFD8907BD5F964E8A51312EEBD6B0E in this example) and all of its sub keys. If you'd rather be cautious and conservative, add something like "-00" to the end of that key to hide it from the installer.

Now repeat the install procedure. (If you just go back to the command window, recall the same command line, and re-execute it you will have a new log file to review in case it fails again.) If the install is successful and you hid the offending key, then go back to the registry and remove it. However, it's possible that there may be more than one problem, and if so, it/they will be revealed one at a time with each install try.
LibreOffice Version: 5.0.0.5
OpenSUSE Linux 3.11.10-29 & Windows XP
Alex6361
 
Posts: 24
Joined: Fri Jun 05, 2015 2:15 am

Re: [Solved] Error 1714. The older version of cannot be remo

Postby alanjones » Fri Jan 27, 2017 8:56 pm

Thank you !!!
After month of attemps to solve this , tens of and microsoft web forum..
Hours of time lost !!!
And simply deleting ( renaming ... ) the key that the installer was searching the vc_minimum_x86.msi...
SOLVED SOLVED

IUUUUUUU !!!!! :D :D :D :D :D :D :D .... IUUUUI !!! :D :D :D :D :D
Openoffice 3.1 on Windows 7
alanjones
 
Posts: 1
Joined: Fri Jan 27, 2017 8:50 pm

Re: [Solved] Error 1714. The older version of cannot be remo

Postby rgnkng » Sun May 28, 2017 10:27 pm

I thought these instructions would help with my problem. When I entered the msiexec /i in a command prompt I got this message "Installation package could not be opened. Verify package exists and that you can access it. Any thoughts on this?
OpenOffice 4.1.1 Windows 7
rgnkng
 
Posts: 1
Joined: Sun May 28, 2017 10:13 pm

Re: [Solved] Error 1714. The older version of cannot be remo

Postby __JJ__ » Fri Aug 10, 2018 7:49 pm

Alex6361 wrote:"Error 1714. The older version of . . . cannot be removed. Contact your technical support group."

It's not a very helpful message -- especially if you're your own "technical support group". .....


Hi,
I just wanted to say thanks for posting this. I have been trying to uninstall the last remnants of an old MySql version for hours so that the new version would install, and getting nowhere, and this is the only thing that actually allowed me to see exactly why and where the install of a newer version was failing.
OpenOffice 4 on Windoze.
__JJ__
 
Posts: 1
Joined: Fri Aug 10, 2018 7:45 pm


Return to MS Windows

Who is online

Users browsing this forum: No registered users and 3 guests