[Solved] Cells show formula instead of result

Discuss the spreadsheet application

[Solved] Cells show formula instead of result

Postby mattandgizmo » Wed Apr 14, 2010 3:10 pm

Hiya
I'm going crazy with this spreadsheet
No matter what formula I put into any cell, even if it's just a basic "=A6+A7" where A6=5 and A7=5, the cell just displays the formula and not the result
And in the bottom right of the screen, next to the zoom bar, it has in a box "Sum=10"
Can someone please tell me what I can do to get my spreadsheet to actually show the answer in the cell rather than the formula?
I have searched for this but I seem to be the only one with this problem :?
Thanks very much in advance
Last edited by mattandgizmo on Wed Apr 14, 2010 4:59 pm, edited 1 time in total.
OpenOffice Version 3.1, Windows Vista
mattandgizmo
 
Posts: 2
Joined: Wed Apr 14, 2010 3:04 pm

Re: Cells show formula instead of result

Postby Villeroy » Wed Apr 14, 2010 4:38 pm

Tools>Options...Calc>View: "SHow Formulas"=OFF
Please, edit this topic's initial post and add "[Solved]" to the subject line if your problem has been solved.
Ubuntu 18.04, OpenOffice 4.x & LibreOffice 6.x
User avatar
Villeroy
Volunteer
 
Posts: 26389
Joined: Mon Oct 08, 2007 1:35 am
Location: Germany

Re: [Solved] Cells show formula instead of result

Postby mattandgizmo » Wed Apr 14, 2010 5:04 pm

Thats great thank you very much
OpenOffice Version 3.1, Windows Vista
mattandgizmo
 
Posts: 2
Joined: Wed Apr 14, 2010 3:04 pm

Re: [Solved] Cells show formula instead of result

Postby darksander » Thu May 28, 2015 2:43 pm

Hey,

It doesnt work for me. I have that check off in my options, but I still see the formula.
The thing is that sometimes it works, other times it doesn't, while using the same formula.

I have tried all sorts of ways of inserting the formula, wizard, copy-paste, write in..

Thanks for any help,
Sander
Open Office 4.1.1
darksander
 
Posts: 2
Joined: Thu May 28, 2015 2:19 pm

Re: [Solved] Cells show formula instead of result

Postby darksander » Thu May 28, 2015 10:42 pm

Update: noticed that if I let the autocomplete fill in the rest of function name (such as, I write conc.. and it completes with atenate) it works.
Open Office 4.1.1
darksander
 
Posts: 2
Joined: Thu May 28, 2015 2:19 pm

Re: [Solved] Cells show formula instead of result

Postby mandrill » Wed Jun 08, 2016 11:03 am

Check that the sheet and cells that are showing the formula aren't protected.

1. Select the cells in question
2. Format > Cells > Cell protection
3. Uncheck everything.

The above solutions didn't work for me but this did.
OOo 3.3.0 | Windows Vista Business 32bit SP2
mandrill
 
Posts: 10
Joined: Mon Nov 28, 2011 12:00 pm

Re: [Solved] Cells show formula instead of result

Postby jkjambsj » Sat Mar 16, 2019 8:30 pm

Oh my word! I just had the same problem and a soupson of the above suggestions was the only solution. I had occasion to test my solution thoroughly.

I have SheetA and SheetB with "master" information in it that is read by SheetC. SheetA and SheetB do not read each other. Every month, I create a SheetMMYYYY that reads SheetA, SheetB and SheetC. All of these were (1) on drive S and (2) in the same subfolder. I had to move the whole system to drive M. I tried to preserve the folder structure on drive S, but I had to make do. I also moved all the SheetMMYYYY sheets into a subfolder of the folder where SheetA, SheetB and SheetC are.

After moving the whole system from M:\Folder1\Folder2 to S:\Folder1\Folder3\Folder2, it was cinch doing a search of the M drive path to replace with the S drive path in Sheet C. On moving the SheetMMYYY sheets to S:\Folder1\Folder3\Folder2\Reports\YYYYMM folder, all the links to SheetA, SheetB and SheetC changed to include the \Reports\YYYYMM subfolder, so I searched \Reports\YYYYMM and removed them.

That should have been sufficient, but on two of the tabs in each SheetMMYYYY sheet, certain formulae were being displayed instead of their results. I was exasperated, and finally braved the forums. I hate searching forums. My final solution to the problem was:

STEP ONE
Villeroy wrote:Tools>Options...Calc>View: "SHow Formulas"=OFF

AND
mandrill wrote:Check that the sheet and cells that are showing the formula aren't protected.

1. Select the cells in question
2. Format > Cells > Cell protection
3. Uncheck everything.

The above solutions didn't work for me but this did.


STEP TWO
1. Select all the troublesome forumula cells and convert them to type "All" and "Standard"
2. Convert them again to type "Text"

STEP THREE
darksander wrote:Update: noticed that if I let the autocomplete [with INSERT on] fill in the rest of function name (such as, I write conc.. and it completes with atenate) it works.

This was tricky. My formulae contained either ONE or TWO instances of the word VLOOKUP, and that is the only function used in them. In formulae where the VLOOKUP was used twice, I had to do the autocomplete thing on BOTH instances of the word for the cell to wake up and show me the RESULT of the formula instead of the raw formula.

And that was the only way it would work. Copying a "woken" cell and pasting it preserved the fix.
Mr J Jacobs
Open Office 4.1.5 on Windows 10 Pro
jkjambsj
 
Posts: 8
Joined: Wed Feb 27, 2019 10:57 am

Re: [Solved] Cells show formula instead of result

Postby Villeroy » Sat Mar 16, 2019 8:36 pm

jkjambsj wrote:2. Convert them again to type "Text"

No, don't do that.

1. Select the cells in question
2. Format > Cells > Cell protection
3. Uncheck everything.

Not necessary. Just unprotect the sheet. This will also "open" all locks that are applied to any cells.
Please, edit this topic's initial post and add "[Solved]" to the subject line if your problem has been solved.
Ubuntu 18.04, OpenOffice 4.x & LibreOffice 6.x
User avatar
Villeroy
Volunteer
 
Posts: 26389
Joined: Mon Oct 08, 2007 1:35 am
Location: Germany


Return to Calc

Who is online

Users browsing this forum: No registered users and 35 guests