[Solved] Extra blank page added to mail merge while printing

Discuss the word processor

[Solved] Extra blank page added to mail merge while printing

Postby jaybaluh » Fri Oct 23, 2009 1:06 am

Has anyone seen this problem? During a simple mail merge operation a blank page is being inserted to document when the merged document is printed. The blank does not display while in the document but shows on print preview. I am using a very simle template that I constructed. The project is print inserts for a friend dvd collection and all that is required is the title and year to appear on the spine and the title on the front cover. I am using a compaq nx9010 laptop running xp pro service pack two. The printer is a deskjet 820cse. I am on openoffice version 3.1.1 000310m19 (build: 9420). I am working around the problem by printing pages listed in the print dialog (page 1,3,5,7,9....). This works but slows the process down quite a bit. I am a new user of oo and have many years experience with ms products and have never run across this kind of problem. Redoing the merge does not alter the results. Please try to help as I have more than 5000 pages to print. I will try to attach the template and a merged file (if that helps).
Thanks.
jjb
Attachments
100-print.odt
(120.68 KiB) Downloaded 398 times
dvd4d.ott
(9.21 KiB) Downloaded 111 times
Last edited by Hagar Delest on Fri Oct 23, 2009 10:09 pm, edited 1 time in total.
Reason: tagged [Solved].
OOo 2.4.X on Ms Windows XP + none
jaybaluh
 
Posts: 2
Joined: Mon Sep 29, 2008 10:58 pm

Re: extra blank page added to mail merge document while printing

Postby baronobeefdip » Fri Oct 23, 2009 6:28 am

did you try back spacing all of the spaces (if any) on the blank pages

or adjusting the margins on the second to last page so more characters fit, just need to sync everything back together after you do this but not that that much of a problem
User avatar
baronobeefdip
 
Posts: 16
Joined: Mon Oct 05, 2009 4:03 pm

Re: extra blank page added to mail merge document while printing

Postby tn@BeWo » Fri Oct 23, 2009 1:54 pm

While in Writer go to
Tools / Options -> OpenOffice.org Writer / Print
(in lower 3rd of right pane under 'Other ---') uncheck [] Print automatically inserted blank pages
OOo 3.2.1 on ubuntu 10.4, MsWXP, MsW2k
tn@BeWo
Volunteer
 
Posts: 253
Joined: Fri Jul 24, 2009 8:26 am

Re: extra blank page added to mail merge document while printing

Postby JohnV » Fri Oct 23, 2009 8:25 pm

To answer your question, this always happens if your basic merge doc has an odd number of page.

tn@BeWo has told you how to avoid the print problem.

To avoid blank pages all together you can use this macro to double the size of the document thus having a even number of pages.
http://www.oooforum.org/forum/viewtopic ... mail+merge
JohnV
Volunteer
 
Posts: 1585
Joined: Mon Oct 08, 2007 1:32 am
Location: Kentucky, USA

Re: Extra blank page added to mail merge document while printing

Postby jaybaluh » Fri Oct 23, 2009 9:41 pm

Thanks everybody! Knew that there had to be something simple that I had not gotten to yet.

Thanks again,
jjb
OOo 2.4.X on Ms Windows XP + none
jaybaluh
 
Posts: 2
Joined: Mon Sep 29, 2008 10:58 pm

Re: [Solved] Extra blank page added to mail merge while prin

Postby Daz1970 » Mon Feb 18, 2019 10:55 pm

This is quite an old post for someone with this problem to be looking at in Feb 2019 but it was the first one I came across from a google search. The reason for the reply is the solution given doesn't work on the current version (4.1.5) but I did find the solution so I thought I should mention it just in case there are still visitors to this page.
It seems that mail merge automatically inserts a blank page between each record that is printed. It seems these are called 'comments' pages and they can be turned off.
Go to File/Print, this takes you to the mail merge dialog box, press ok to then go to the print dialog box, select 'Page Layout' tab towards the top of the box, part the way down it says 'Page Sides' and below that there's a drop down box labelled 'Comments Only'. Press the down arrow and select 'None(document only)'. There's a preview panel to the left, you'll notice that when you do this the page numbers drop to the number of records you have.
Annoyingly it seems to have to change this setting for each new set of printouts.
OpenOffice 4.1.5 on Windows 10
Daz1970
 
Posts: 1
Joined: Mon Feb 18, 2019 9:52 pm


Return to Writer

Who is online

Users browsing this forum: No registered users and 37 guests