OOo sluggish with Gutsy

Issues with installing under all Linux Distributions

OOo sluggish with Gutsy

Postby secret_squirrel » Tue Jan 15, 2008 1:43 pm

I'm running Gutsy on a Thinkpad T42 - reasonably speedy CPU, 1.5GB RAM. No performance issues on the PC: no swapping, no excessive disk i/o, CPU OK.

Most apps are fine, but OOo is very sluggish. It starts up OK, but then immediately redraws the icons along the top, taking a few seconds. Normal typing is OK, as is scrolling around within a document, but menus are slow and the icons get redrawn all the time. In calc, switching between tabs is painfully slow.

Most other apps are fine, but not all. Thunderbird is also sluggish (typing is slow).

So far I've tried a few things, without success:

  • I thought it might be an issue with the Ubuntu build of OOo (which had crashing issues on my wife's Gutsy PC) so I uninstalled and installed OOo 2.3.1 from the OpenOffice.org website. Made no difference at all.
  • Tweaking OOo memory settings as suggested on this page.
  • Uninstalling Compiz and making sure that I was running on Metacity.

The problem seems rare, but not unique (see http://ubuntuforums.org/showthread.php?t=624862). Any suggestions would be gratefully received.
secret_squirrel
 
Posts: 6
Joined: Tue Jan 15, 2008 1:31 pm

Re: OOo sluggish with Gutsy

Postby Hagar Delest » Tue Jan 15, 2008 10:09 pm

I've seen so many bugs with the Ubuntu versions that I always advise to remove it and install the official version from OOo site: install the official version of OOo : [Ubuntu] Installing OOo on Debian and Co.
AOO 4.1.6 on Xubuntu 19.04 and 4.1.5 on Windows 7 (with winPenPack port).
User avatar
Hagar Delest
Moderator
 
Posts: 28558
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: OOo sluggish with Gutsy

Postby secret_squirrel » Wed Jan 16, 2008 1:08 am

Ah, forgot to mention that. I did try uninstalling the Ubuntu version and installing standard OOo 2.3.1 from the OOo website, but it didn't make any difference.

(On another laptop I have, it did fix a problem with OOo crashing though, so definitely good advice).
secret_squirrel
 
Posts: 6
Joined: Tue Jan 15, 2008 1:31 pm

Re: OOo sluggish with Gutsy

Postby Hagar Delest » Wed Jan 16, 2008 9:09 am

Try to rename your OOo user profile (~/.openoffice.org2) so that a new one is created. Perhaps the Ubuntu install has created bad configuration files.
AOO 4.1.6 on Xubuntu 19.04 and 4.1.5 on Windows 7 (with winPenPack port).
User avatar
Hagar Delest
Moderator
 
Posts: 28558
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: OOo sluggish with Gutsy

Postby secret_squirrel » Wed Jan 16, 2008 11:40 am

No luck, unfortunately.

My hunch is that this is nothing to do with OOo and something very obscure to do with the graphics driver; unfortunately I've no idea how to diagnose or solve it :(
secret_squirrel
 
Posts: 6
Joined: Tue Jan 15, 2008 1:31 pm

Re: OOo sluggish with Gutsy

Postby sybille » Tue Jan 22, 2008 2:09 pm

secret_squirrel wrote:My hunch is that this is nothing to do with OOo and something very obscure to do with the graphics driver...

Have you checked out the pages for the Thinkpad T42 at the ThinkWiki?:
http://www.thinkwiki.org/wiki/Category:T42

There it lists several possible graphics controllers, some of which are supported by the Xorg drivers and some of which are not and require ATI's proprietary drivers. Which controller does your laptop have, and which driver are you using?

There are a number of ways to get that information. For example, to see which hardware you have, you can run
Code: Select all   Expand viewCollapse view
sudo lspci | grep Display
in a terminal and look at the results. If there are no results, try removing the second half of the command above (the pipe symbol "|" and everything that follows it), and then look through the results for something about ATI.
To see which driver you are using, you can run
Code: Select all   Expand viewCollapse view
lsmod
in a terminal and look for "radeon," "fglrx," or "vesa" - these are the most likely suspects.

If you are using the radeon driver, which is the free Xorg driver, there may be some things you can add to your xorg.conf file to improve performance: Additional options for the radeon driver. In particular, you might try setting the AGP speed to the correct value for your graphics controller (which you can find in the ThinkWiki).

I've only ever used the radeon driver (with a 9250 card on a desktop machine), so I'm not sure of what might be done for the fglrx driver if that's what you're using. But I have found that the correct AGP setting improves how my display performs.
If your problem has been solved, please edit this thread's initial post and add "[Solved]" to the subject line. Thanks!
-------
About Ubuntu Linux
Zotero, for research and bibliography management with OOo.
OOo 2.4.X on Ubuntu 8.x + None needed :)
sybille
Volunteer
 
Posts: 122
Joined: Sat Jan 05, 2008 12:21 pm
Location: France

Re: OOo sluggish with Gutsy

Postby secret_squirrel » Tue Jan 29, 2008 11:44 am

Hi sybille,

Thanks for the advice. I was using the fglrx driver but, despite radeon being installed, couldn't get the system to work properly with it.

In the end I went for a complete reinstall (pretty painless as I always keep /home on a separate partition). It's now using the radeon driver and everything is working fine.

(I also tried Fedora 8: the graphics worked OK but it totally failed to even see my wireless adapter, that's worked flawlessly with Ubuntu for two years and sound didn't work either so giving Ubuntu another go seemed like the better bet and it seems to have worked).

Thanks to Hagar too.
secret_squirrel
 
Posts: 6
Joined: Tue Jan 15, 2008 1:31 pm


Return to Linux

Who is online

Users browsing this forum: No registered users and 2 guests