[Solved] Personal settings are locked

Issues with installing under all Linux Distributions

[Solved] Personal settings are locked

Postby dacey » Mon Apr 06, 2009 10:36 am

I am currently using OpenOffice.org 2.3.0 on an Acer Aspire One Netbook running Linpus Linux.

Due to shutting down the power to my netbook before OOo had a chance to exit properly I now get the following error message when I try to load Writer or Calc or any other OOo program:

Either another instance of OpenOffice.org is accessing your personal settings or your personal settings are locked.
Simultaneous access can lead to inconsistencies in your personal settings. Before continuing, you should make sure user "closes OpenOffice.org on host"

Do you really want to continue?

If I click Yes and continue then Writer still loads and appears to function as normal, but I would still like to get rid of the error message. And to answer the obvious question: no, there isn't another instance of OpenOffice.org open at the time.

From searching this board I have found similar problems and it seems the solution may be to delete a ".locked" file, however I'm not overly familiar with Linux and I am not sure which folders the personal settings are stored in.

Can anyone point me in the right direction?
Last edited by dacey on Wed Apr 08, 2009 9:52 am, edited 1 time in total.
OOo 3.0.X on MS Windows Vista + Linpus Linux
Posts: 2
Joined: Mon Apr 06, 2009 10:22 am

Re: Personal settings are locked

Postby Hagar Delest » Mon Apr 06, 2009 10:59 am

It should be in your user profile: [Tutorial] The OOo user profile.

Thanks to add '[Solved]' at beginning of your first post title (edit button) if your issue has been fixed.
AOO 4.1.7 on Xubuntu 20.04 and 4.1.5 on Windows 10 (with winPenPack port).
User avatar
Hagar Delest
Posts: 28916
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Personal settings are locked

Postby Jimmer57 » Wed Apr 08, 2009 2:17 am

I was getting the same error, plus crashes and other difficulties.

I tried deleting the "user" folder but OOo still displayed the error on setup. I then tried deleting the whole OpenOffice.org folder from /Library/Application Support, and that worked.
OOo 3.0.X on Mac OSx Leopard
Posts: 1
Joined: Wed Apr 08, 2009 2:12 am

Re: [Solved] Personal settings are locked

Postby dacey » Wed Apr 08, 2009 9:53 am

Thanks. I took your advice and deleted all the whole folder and that solved the problem.
OOo 3.0.X on MS Windows Vista + Linpus Linux
Posts: 2
Joined: Mon Apr 06, 2009 10:22 am

Re: [Solved] Personal settings are locked

Postby DanielDG » Fri Jul 04, 2014 8:51 am

The same thing happened to me after I change my user name. I deleted a file called ~.lock from the OpenOffice user folder and my personal settings were not locked anymore.
OpenOffice 4.1.0; Windows 7 Pro SP1 x64
User avatar
Posts: 78
Joined: Wed Jun 25, 2014 10:44 am

Return to Linux

Who is online

Users browsing this forum: No registered users and 1 guest