Forum pages load slowly

Let us know how we are doing -
Post Reply
User avatar
Mr.Dandy
Posts: 427
Joined: Tue Dec 11, 2012 4:22 pm

Forum pages load slowly

Post by Mr.Dandy »

Hello,

The forum is frankly very slow this morning.
It takes almost a minute to get to a page.
is it just me or is there a problem?
Last edited by MrProgrammer on Wed Jan 31, 2024 4:14 pm, edited 1 time in total.
Reason: Edited topic's subject
OpenOffice 4.1.12 - Windows 10
User avatar
robleyd
Moderator
Posts: 5014
Joined: Mon Aug 19, 2013 3:47 am
Location: Murbko, Australia

Re: Slow

Post by robleyd »

It is not just you; the site is intermittently slow. Unfortunately we have no administrative access to the web server.
Cheers
David
OS - Slackware 15 64 bit
Apache OpenOffice 4.1.15
LibreOffice 24.2.0.3; SlackBuild for 24.2.0 by Eric Hameleers
User avatar
Mr.Dandy
Posts: 427
Joined: Tue Dec 11, 2012 4:22 pm

Re: Slow

Post by Mr.Dandy »

OK it's a pain

But perhaps an admin could warn the person in charge at Apache? :)
OpenOffice 4.1.12 - Windows 10
User avatar
robleyd
Moderator
Posts: 5014
Joined: Mon Aug 19, 2013 3:47 am
Location: Murbko, Australia

Re: Slow

Post by robleyd »

This has been an issue on and off for some time and it has been reported on several occasions.
Cheers
David
OS - Slackware 15 64 bit
Apache OpenOffice 4.1.15
LibreOffice 24.2.0.3; SlackBuild for 24.2.0 by Eric Hameleers
User avatar
RoryOF
Moderator
Posts: 34547
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Slow

Post by RoryOF »

One recent report was that the slowness was (at that time, perhaps not now) caused by a large number of bots. I think a restriction on their allowed number was put in place then, which speeded up response at that time.

I do not know if an overload of bots is causing the current problem.
Apache OpenOffice 4.1.15 on Xubuntu 22.04.3 LTS
User avatar
Mr.Dandy
Posts: 427
Joined: Tue Dec 11, 2012 4:22 pm

Re: Slow

Post by Mr.Dandy »

Reported where?


Seems to be fluent now. :)
OpenOffice 4.1.12 - Windows 10
User avatar
RoryOF
Moderator
Posts: 34547
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Slow

Post by RoryOF »

Reported on the Forum forwarded from one of the server administrators.
Apache OpenOffice 4.1.15 on Xubuntu 22.04.3 LTS
User avatar
Hagar Delest
Moderator
Posts: 32565
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Slow

Post by Hagar Delest »

Mr.Dandy wrote: Wed Jan 31, 2024 12:29 pm Reported where?
You can report it also on the AOO dev mailing list. The more they will see such reports, the more they will tackle the issue.
LibreOffice 7.6.2.1 on Xubuntu 23.10 and 7.6.4.1 portable on Windows 10
User avatar
Mr.Dandy
Posts: 427
Joined: Tue Dec 11, 2012 4:22 pm

Re: Forum pages load slowly

Post by Mr.Dandy »

Isn't that what forum administrators do? ;)
OpenOffice 4.1.12 - Windows 10
User avatar
robleyd
Moderator
Posts: 5014
Joined: Mon Aug 19, 2013 3:47 am
Location: Murbko, Australia

Re: Forum pages load slowly

Post by robleyd »

Do not confuse those who manage the forum with those who manage the server that runs the forum. We - moderators - have no access to the server that runs the forum, and in fact have limited access to the admin functions of the forum software.
Cheers
David
OS - Slackware 15 64 bit
Apache OpenOffice 4.1.15
LibreOffice 24.2.0.3; SlackBuild for 24.2.0 by Eric Hameleers
User avatar
Mr.Dandy
Posts: 427
Joined: Tue Dec 11, 2012 4:22 pm

Re: Forum pages load slowly

Post by Mr.Dandy »

robleyd wrote: Thu Feb 01, 2024 11:18 am We - moderators - have no access to the server
Who talk about moderators?
OpenOffice 4.1.12 - Windows 10
User avatar
RoryOF
Moderator
Posts: 34547
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Forum pages load slowly

Post by RoryOF »

Forum moderators have some access to Forum admin functions, not to all such functions. Our main role is Forum moderation. We do not have any administrative access to the Apache servers on which the Forum is hosted.
Apache OpenOffice 4.1.15 on Xubuntu 22.04.3 LTS
User avatar
Hagar Delest
Moderator
Posts: 32565
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Forum pages load slowly

Post by Hagar Delest »

The comment was toward me and the admins I guess.

Actually, I shouldn't have quoted that snip. I had read the discussion too fast; sorry about that.
To answer the first question: it has been reported here (3 topics below this discussion): Site very slow for a few days. Has anyone noticed this?

For the second, yes, admin can do that, sometime they do. But my point was that like a class action, if there is one rant, it can be easily disregarded. However, if several or even plenty of rants are sent to the mailing list, then it will accelerated the process.

So yes, you can count on others. But as it is a community driven application and forum, everyone, you included, can get involved too and his part. Especially when it amounts to a mere mail to send...
LibreOffice 7.6.2.1 on Xubuntu 23.10 and 7.6.4.1 portable on Windows 10
User avatar
Mr.Dandy
Posts: 427
Joined: Tue Dec 11, 2012 4:22 pm

Re: Forum pages load slowly

Post by Mr.Dandy »

In that case, why didn't you moderators send this e-mail?
I think it's easier for me as simple user of this forum, to let the administrators manage their tasks (in this part named "Site feedback").
;)

Note that this morning I got a lot of errors: Peer failed to perform TLS handshake
Maybe not the same issue than previous thread
OpenOffice 4.1.12 - Windows 10
User avatar
RoryOF
Moderator
Posts: 34547
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Forum pages load slowly

Post by RoryOF »

At 08:45 UTC this morning there were 680+ guests (bots mostly?) and just now 09:08 UTC there were 380+. Normal traffic is perhaps 100/110 connections at any peak time.
Apache OpenOffice 4.1.15 on Xubuntu 22.04.3 LTS
User avatar
Hagar Delest
Moderator
Posts: 32565
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Forum pages load slowly

Post by Hagar Delest »

Mr.Dandy wrote: Fri Feb 02, 2024 11:08 am In that case, why didn't you moderators send this e-mail?
I think it's easier for me as simple user of this forum, to let the administrators manage their tasks (in this part named "Site feedback").
;)
We do report it, as mentioned earlier (see also: https://www.mail-archive.com/dev@openof ... 44995.html), but if normal users also start to report it then, maybe the infra team in charge of the servers will pay more attention.

As said it has been reported several times with unstable results. Who cares who send the email? The point is the number of emails sent.
I'm quite displeased by you finger pointing the moderators and admins who have no lever to fix this issue. Again if you consider yourself part of the community, then do your part and report it too.
LibreOffice 7.6.2.1 on Xubuntu 23.10 and 7.6.4.1 portable on Windows 10
User avatar
Mr.Dandy
Posts: 427
Joined: Tue Dec 11, 2012 4:22 pm

Re: Forum pages load slowly

Post by Mr.Dandy »

Hagar Delest wrote: Fri Feb 02, 2024 4:15 pm We do report it, as mentioned earlier (see also: https://www.mail-archive.com/dev@openof ... 44995.html), but if normal users also start to report it then, maybe the infra team in charge of the servers will pay more attention.
Okay, but which address?
It's not specified in Dick Groskamp's message
OpenOffice 4.1.12 - Windows 10
User avatar
Hagar Delest
Moderator
Posts: 32565
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Forum pages load slowly

Post by Hagar Delest »

Write to the dev mailing list.
Infra is to be contacted with their ticket interface only. If few can contact them by mail, good. But it is not the standard channel and I were them, I would discard any request that don't come through the proper channel.
LibreOffice 7.6.2.1 on Xubuntu 23.10 and 7.6.4.1 portable on Windows 10
Post Reply