Impress: images not displaying in slide

Discuss the presentation application
Post Reply
bsfinkel
Posts: 28
Joined: Fri May 12, 2017 9:05 pm

Impress: images not displaying in slide

Post by bsfinkel »

OpenOffice 4.1.13 Windows 10 21H2 64-bit
I have a presentation that I created in 2020 as .ppt format. When I come to a slide that has a JPEG image,I get a small square in the upper left corner of the screen; the graphical image does not display. IN the left column with preview of slides, I see the image. I have included a screenshot.
ooimpress.220917.nographics.JPG
ooimpress.220917.nographics.JPG (96.98 KiB) Viewed 629 times
Apache OpenOffice 4.1.3
Windows 7 32-bit
erbsenzahl
Volunteer
Posts: 210
Joined: Tue Apr 18, 2017 8:23 am
Location: Germany

Re: Impress: images not displaying in slide

Post by erbsenzahl »

Hi,
do you have the same results (display) when you tick the tabs Outline | Notes | Handout | Slide Sorter ?
Have you checked menu Edit | Links... | Source File ? (Altering and recovering may be helpful.)
Your file is saved as a PPT file. Have you always saved as a PPT file or is the PPT file a result of a conversion of your ODP file's last version?
Cheers

EDIT
Please update your forum's profile. Thank you.
LibreOffice current versions 7 and OpenOffice 4.1.13
on LinuxMint 19 or 20 Mate, W10-64 pro
John_Ha
Volunteer
Posts: 9097
Joined: Fri Sep 18, 2009 5:51 pm
Location: UK

Re: Impress: images not displaying in slide

Post by John_Ha »

That looks like the classic "lost images" bug.

See the Writer tutorial Useful hints on images for a full explanation and for why you should swap to LibreOffice.
LO 6.4.4.2, Windows 10 Home 64 bit

See the Writer Guide, the Writer FAQ, the Writer Tutorials and Writer for students.

Remember: Always save your Writer files as .odt files. - see here for the many reasons why.
bsfinkel
Posts: 28
Joined: Fri May 12, 2017 9:05 pm

Re: Impress: images not displaying in slide

Post by bsfinkel »

I went to Slide Sorter, and each page that had a graphical image displayed that image and then immediately changed to a small square in the upper right corner. Now, even in the Normal view I see small squares in the upper right corner.
ooimpress.220918.nographics.JPG
ooimpress.220918.nographics.JPG (93.41 KiB) Viewed 585 times
I saved the file in .odp format. Then I closed and re-opened. All of the graphics are now small rectangles. Does this mean that they are gone, and I have to restore from a backup file? I save in .ppt format because I am not sure that the current MS PowerPoint will read .odp files. I have not experimented because I do not have easy access to PowerPoint.
Apache OpenOffice 4.1.3
Windows 7 32-bit
erbsenzahl
Volunteer
Posts: 210
Joined: Tue Apr 18, 2017 8:23 am
Location: Germany

Re: Impress: images not displaying in slide

Post by erbsenzahl »

Check @John_Ha's hint: [Tutorial] Some useful hints on using images and read this discussion, which may be helpful for you. See this statement from there:
Hagar Delest wrote:Personally, I've disabled the autorecovery feature. Never seen any benefit for that feature.
Cross-links can work in master document depending on the kind of link used. Not sure about hyperlinks but cross-references do work (I use them in master docs).
Better anchor the pics As character, it's the most robust way of keeping them in place IMHO.
I've documents +1,200 pages with lots of pics with no issue. Resolution is optimized.
If you had not linked but embedded the images, they could still be available. Rename your odp file into a zip file and open with a ZIP program. Within this file you will notice a folder images (or similar). Check its contents, the images' names could be horrible, but - if existing - that could help you to rebuild your original presentation...
Cheers and godspeed!
LibreOffice current versions 7 and OpenOffice 4.1.13
on LinuxMint 19 or 20 Mate, W10-64 pro
bsfinkel
Posts: 28
Joined: Fri May 12, 2017 9:05 pm

Re: Impress: images not displaying in slide

Post by bsfinkel »

The images were embedded. I copied the .odp file into a .zip. and when I opened it, there was only ONE jpeg image. And that image still appears in the one slide. So, I assume that the images are gone. The questions are these:
1) What happened to the images? Is it due to a bug in OpenOffice?
2) If I restore the .ppt file from a backup, how can I ensure that the images will not disappear from that backup copy when I open it?
3) Should I be using LibreOffice instead? I have not done any research lately on the differences.
Apache OpenOffice 4.1.3
Windows 7 32-bit
User avatar
Hagar Delest
Moderator
Posts: 30689
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Impress: images not displaying in slide

Post by Hagar Delest »

LibreOffice has fixed some issues with the code for saving, it is much more robust for that than AOO. You won't notice the differences.
LibreOffice 7.2.6 on Xubuntu 22.04 and 7.2.6 portable on Windows 10
bsfinkel
Posts: 28
Joined: Fri May 12, 2017 9:05 pm

Re: Impress: images not displaying in slide

Post by bsfinkel »

I ran a quick test. I renamed tie xxx.ppt, .zip, and .odp files to xxx-bad. Then I restored the xxx.ppt file from a 211115 backup. When I did a "diff xxx.ppt xxx-bad.ppt", diff found no differences. I have not yet had a chance to copy the restored file into a ,zip file and look at it. I assume that this implies that the graphics in the restored file are still present in the bad file.
Apache OpenOffice 4.1.3
Windows 7 32-bit
John_Ha
Volunteer
Posts: 9097
Joined: Fri Sep 18, 2009 5:51 pm
Location: UK

Re: Impress: images not displaying in slide

Post by John_Ha »

1. Download 7-Zip
2. Open tie xxx.ppt with 7-Zip (7-Zip opens the Microsoft format file which is not a ZIP file)
3. Extract the files in \Pictures.

You will have to give the images their file qualifiers as 7-Zip doesn't seem to do so. Open with a binary editor HxD to see the file qualifier close to the top of the file.
LO 6.4.4.2, Windows 10 Home 64 bit

See the Writer Guide, the Writer FAQ, the Writer Tutorials and Writer for students.

Remember: Always save your Writer files as .odt files. - see here for the many reasons why.
User avatar
Hagar Delest
Moderator
Posts: 30689
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Impress: images not displaying in slide

Post by Hagar Delest »

.ppt is a binary format, can't be opened with an archive manager AFAIK (I just tested it on an old ppt file on my xubuntu machine).
LibreOffice 7.2.6 on Xubuntu 22.04 and 7.2.6 portable on Windows 10
John_Ha
Volunteer
Posts: 9097
Joined: Fri Sep 18, 2009 5:51 pm
Location: UK

Re: Impress: images not displaying in slide

Post by John_Ha »

Hagar Delest wrote: Mon Sep 19, 2022 10:17 pm .ppt is a binary format, can't be opened with an archive manager AFAIK (I just tested it on an old ppt file on my xubuntu machine).
Hagar

Microsoft .doc, .xls, .ppt files etc are OLE compound files as specified by [MS-CFB]. They open in 7-ZIP and then behave like ZIP files.

Microsoft .docx, .xlsx and .pptx files are ZIP files.
Attachments
Clipboard01.png
Clipboard01.png (22.75 KiB) Viewed 476 times
LO 6.4.4.2, Windows 10 Home 64 bit

See the Writer Guide, the Writer FAQ, the Writer Tutorials and Writer for students.

Remember: Always save your Writer files as .odt files. - see here for the many reasons why.
User avatar
Hagar Delest
Moderator
Posts: 30689
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Impress: images not displaying in slide

Post by Hagar Delest »

Indeed, 7zip works. But how to extract the content?
You get some things with a text editor but not as clear as a OOXML or ODF file to retrieve the content.
I tested with 2 files and retrieved each time a single picture only by renaming the picture item to picture.jpg.
LibreOffice 7.2.6 on Xubuntu 22.04 and 7.2.6 portable on Windows 10
John_Ha
Volunteer
Posts: 9097
Joined: Fri Sep 18, 2009 5:51 pm
Location: UK

Re: Impress: images not displaying in slide

Post by John_Ha »

Hagar Delest wrote: Tue Sep 20, 2022 7:52 am Indeed, 7zip works. But how to extract the content?
You get some things with a text editor but not as clear as a OOXML or ODF file to retrieve the content.
I tested with 2 files and retrieved each time a single picture only by renaming the picture item to picture.jpg.
Good point! I only tested it with one image. With two images both are in the file Pictures.

I expect Microsoft makes an extraction utility available.

Googling found How to Extract Images, Text, and Embedded Files from Word, Excel, and PowerPoint Documents which says
How to Extract Images from Older Office Documents (.doc, .xls, or .ppt)

If you need to extract images from an Office 2003 (or earlier) document, there’s a free tool called Office Image Extraction Wizard that makes this task easy. This program also allows you to extract images from multiple documents (of the same or different types) at once. Download the program and install it (there’s also a portable version available if you’d rather not install it).
LO 6.4.4.2, Windows 10 Home 64 bit

See the Writer Guide, the Writer FAQ, the Writer Tutorials and Writer for students.

Remember: Always save your Writer files as .odt files. - see here for the many reasons why.
bsfinkel
Posts: 28
Joined: Fri May 12, 2017 9:05 pm

Re: Impress: images not displaying in slide

Post by bsfinkel »

I am not sure what tests to run next. I think that I will install LibreOffice and see what is displays with my "corupted" .ppt file. What I do not understand is this - the file I restored from a backup seems to be the same as the corrupted file (same length, and diff says no differences). But a zip on the corrupted file shows only one image; the others do not show. Where did they go? All of the images are inline JPEG s. Will diff on a .ppt (binary) file show differences?
Apache OpenOffice 4.1.3
Windows 7 32-bit
bsfinkel
Posts: 28
Joined: Fri May 12, 2017 9:05 pm

Re: Impress: images not displaying in slide

Post by bsfinkel »

I installed libreoffice 7.4.1.2 (it took me two downloads, as the first was corrupted), and opened my corrupted file. it displayed fine; no graphic images were missing. So, the question is this - why does OpenOffice not display those images, when they are clearly in the file?
Apache OpenOffice 4.1.3
Windows 7 32-bit
John_Ha
Volunteer
Posts: 9097
Joined: Fri Sep 18, 2009 5:51 pm
Location: UK

Re: Impress: images not displaying in slide

Post by John_Ha »

See Tools > Options > something ..., where you may have switched off Display images.
LO 6.4.4.2, Windows 10 Home 64 bit

See the Writer Guide, the Writer FAQ, the Writer Tutorials and Writer for students.

Remember: Always save your Writer files as .odt files. - see here for the many reasons why.
bsfinkel
Posts: 28
Joined: Fri May 12, 2017 9:05 pm

Re: Impress: images not displaying in slide

Post by bsfinkel »

"something" is not exact enough. I looked through the options, and I did not find any for images. Maybe I missed something. But I rarely go to the options page.
Apache OpenOffice 4.1.3
Windows 7 32-bit
erbsenzahl
Volunteer
Posts: 210
Joined: Tue Apr 18, 2017 8:23 am
Location: Germany

Re: Impress: images not displaying in slide

Post by erbsenzahl »

John_Ha wrote: Tue Sep 20, 2022 6:41 pmSee Tools > Options > something ..., where you may have switched off Display images.
Only Writer, not Impress.
bsfinkel wrote:So, the question is this - why does OpenOffice not display those images, when they are clearly in the file?
John_Ha » Sun Sep 18, 2022 3:28 pm wrote:That looks like the classic "lost images" bug.
Probably John could supply a link to the bug announcement? But: ApacheOpenOffice has not been developed for years, a change to LibreOffice could be the easiest remedy for your problem... :oops:
LibreOffice current versions 7 and OpenOffice 4.1.13
on LinuxMint 19 or 20 Mate, W10-64 pro
John_Ha
Volunteer
Posts: 9097
Joined: Fri Sep 18, 2009 5:51 pm
Location: UK

Re: Impress: images not displaying in slide

Post by John_Ha »

Issue 126970 - Lost images while editing a Writer .odt file - two scenarios but there are numerous other bug reports about it. I have witnessed it in Writer and Impress and it no doubt happens in all modules as the image handling code with the bugs is common to all. See the detailed comments in the Tutorial.

If the images are in the file but are not displayed then it is not this bug. Please upload the file showing the problem so that it can be analysed.

If LO works, switch to it as the bug will never get fixed in the walking dead AOO.

Press POSTREPLY and click the Upload attachment tab below where you type (128 kB max); or use a file share site such as mediafire, Dropbox or Google Drive for a larger file.
LO 6.4.4.2, Windows 10 Home 64 bit

See the Writer Guide, the Writer FAQ, the Writer Tutorials and Writer for students.

Remember: Always save your Writer files as .odt files. - see here for the many reasons why.
bsfinkel
Posts: 28
Joined: Fri May 12, 2017 9:05 pm

Re: Impress: images not displaying in slide

Post by bsfinkel »

As I wrote above, my restored file is the same length as the corrupted file, and diff shows that the two files are identical. I opened the "corrupted: file with OpenOffice, and the graphics displayed correctly. So, I have NO IDEA what might have happened within Impress (or the common elements of OpenOffice) to cause Impress not to display the images, which were (and still are) clearly in the file. I have these files(annotated) in my directory:
11/09/2021 11:00 AM 1,336,320 begwkshp3-bad.zip one image
11/09/2021 11:00 AM 1,336,320 BegWkshp3.zip can't open
11/09/2021 11:00 AM 1,336,320 BegWkshp3.ppt displays all images
11/09/2021 11:00 AM 1,336,320 BegWkshp3-restored.ppt displays all images
11/09/2021 11:00 AM 1,336,320 BegWkshp3-restored.zip can't open
11/09/2021 11:00 AM 1,336,320 begwkshp3-bad.ppt displays all images
09/18/2022 10:01 AM 185,619 begwkshp3-bad.odp

The zip files that can't open - Windows gives me an error window:

Compressed (zipped) Folder Error
Windows cannot open the folder.
The Compressed (zipped) folder d:\XXX-restored-zip is invalid.

Here are the results of the diffs on all of the files with length 1,336,320:

D:\>diff begwkshp3-bad.zip begwkshp3-bad.zip
D:\>diff begwkshp3-bad.zip begwkshp3.zip
D:\>diff begwkshp3-bad.zip begwkshp3.ppt
D:\>diff begwkshp3-bad.zip BegWkshp3-restored.ppt
D:\>diff begwkshp3-bad.zip BegWkshp3-restored.zip
D:\>diff begwkshp3-bad.zip BegWkshp3-bad.zip
D:\>

I do not know if GOW (Gnu On WIndows) diff works correctly on binary files; all these files have the same length and appear to be identical. But zip (I am not sure which zip is installed on my Windows 10 machine) will not open two and shows only one image in the other.
Apache OpenOffice 4.1.3
Windows 7 32-bit
John_Ha
Volunteer
Posts: 9097
Joined: Fri Sep 18, 2009 5:51 pm
Location: UK

Re: Impress: images not displaying in slide

Post by John_Ha »

Please upload a file so it can be a analysed.
LO 6.4.4.2, Windows 10 Home 64 bit

See the Writer Guide, the Writer FAQ, the Writer Tutorials and Writer for students.

Remember: Always save your Writer files as .odt files. - see here for the many reasons why.
bsfinkel
Posts: 28
Joined: Fri May 12, 2017 9:05 pm

Re: Impress: images not displaying in slide

Post by bsfinkel »

The "corrupted" file is 1.3 Mb, so I cannot attach it. Here is the dropbox link:
https://www.dropbox.com/s/zgug8mp5af4f0 ... d.ppt?dl=0
Apache OpenOffice 4.1.3
Windows 7 32-bit
erbsenzahl
Volunteer
Posts: 210
Joined: Tue Apr 18, 2017 8:23 am
Location: Germany

Re: Impress: images not displaying in slide

Post by erbsenzahl »

OS: LinuxMint 20.3 Mate
bsfinkel wrote: Thu Sep 22, 2022 10:36 pm The "corrupted" file is 1.3 Mb ... begwkshp3-bad.ppt
I could open/convert the ppt file to odp file and then extract pictures from zip with following apps: AOO 3.4.1; AOO 4.1.13; LO 7.4.1.2. I did not find any problem in your bad file. Probably there is some (hidden) malfunction on your machine?
Cheers
 
 
ppt-odp-zip-extract-pict.png
ppt-odp-zip-extract-pict.png (70.88 KiB) Viewed 170 times
LibreOffice current versions 7 and OpenOffice 4.1.13
on LinuxMint 19 or 20 Mate, W10-64 pro
John_Ha
Volunteer
Posts: 9097
Joined: Fri Sep 18, 2009 5:51 pm
Location: UK

Re: Impress: images not displaying in slide

Post by John_Ha »

1. Reset the profile - search the forum for how.
2. Boot in Safe Mode and test - Google for how.

What happens?
LO 6.4.4.2, Windows 10 Home 64 bit

See the Writer Guide, the Writer FAQ, the Writer Tutorials and Writer for students.

Remember: Always save your Writer files as .odt files. - see here for the many reasons why.
bsfinkel
Posts: 28
Joined: Fri May 12, 2017 9:05 pm

Re: Impress: images not displaying in slide

Post by bsfinkel »

When I open the supposedly bad file, I get images. I have no idea what caused OpenOffice to decide not to display the images; I did not change any settings. So I have no idea what happened, and I cannot reproduce it. As we can see, the bad file and the restored file have all of the images.
Apache OpenOffice 4.1.3
Windows 7 32-bit
Post Reply